-   Linux - Networking (
-   -   Redhat EL4 server's NetBIOS name wont resolve from any windows machine... (

evank 12-29-2006 12:19 PM

Redhat EL4 server's NetBIOS name wont resolve from any windows machine...
We have an existing SMB network consisting of a couple win2k3 servers and 20-30 winxp home and pro workstations. I just set up samba on a Redhat (RHEL4) server, and am having issues with NetBIOS name resolution.

From said linux server, I can use nmblookup to resolve itself along with any other windows machines just fine:

[root@RHEL ~]# nmblookup RHEL
querying RHEL on RHEL<00>
[root@RHEL ~]# nmblookup WIN2K3_PRIMARY
querying WIN2K3_PRIMARY on WIN2K3_PRIMARY<00>
[root@RHEL ~]# nmblookup WIN2K3_SECONDARY
[root@RHEL ~]# nmblookup WINXPPRO_FRONTDESK

However, from any windows machine, i can't resolve the linux server (using the UNC path \\RHEL or the net view command), but I can still get to it and browse its shares directly by IP (using the UNC path \\ so I've obviously misconfigured something that keeps it from resolving, I just have no clue what. My smb.conf follows:



        workgroup = INTERNAL
        netbios name = RHEL
        server string = Redhat Enterprise Linux 4 via Samba

        hosts allow = 192.168. 127.
        hosts deny = ALL

        log file = /var/log/samba/%m-%U.log
        max log size = 500

        smb passwd file = /etc/samba/smbpasswd

        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

        remote announce =

        local master = no
        os level = 33
        domain master = no
        preferred master = no

        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        template shell = /bin/false
        username map = /etc/samba/smbusers
        winbind use default domain = yes
        browseable = yes

# test share, will remove later
        comment = Temporary file space
        path = /tmp
        writeable = no
        guest ok = yes

any ideas on what the problem is or how to fix it? i'd appreciate any help, thanks for taking the time to read all this!

win32sux 12-30-2006 06:14 AM

have you checked to make sure your firewall isn't blocking the NetBIOS Name Service (Port 137/UDP)??

evank 12-30-2006 12:03 PM

i fixed it, though I'm not sure how...

we were having trouble with one of our DNS servers, and switched to a different one in /etc/resolv.conf, and for some reason that seems to have fixed it, though i have no clue as to how.

All times are GMT -5. The time now is 03:12 AM.