LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-14-2005, 07:52 AM   #1
alinuxLQ
LQ Newbie
 
Registered: Aug 2005
Distribution: RedHat, PC Linux, Xandros, SUSE
Posts: 4

Rep: Reputation: 0
RedHat: dhcpd.conf - error: Not configured to listen on any interfaces!


Using RedHat AS Enterprise edition I copied out the recommended dchpd.conf file (from the RHFedora + Enterprise Linux Bible by C. Negus) with my own adaptions - very little.

When I used the command line "service dhcpd start" I got the following message:
Not configured to listen on any interfaces!

Here is my entire dhcpd.conf file:

ddns-update-style interim;
ignore client-updates;

subnet 10.0.0.0 netmask 255.255.255.0 {

option routers 10.0.0.1;
option domain-name-servers 10.0.0.1;
option subnet-mask 255.255.255.0;
option domain-name "itec240.com";
range dynamic-bootp 10.0.0.150 10.0.0.225;
default-lease-time 21600;
max-lease-time 43200;

#set name server to appear at a fixed address

host ns {
next-server ns1.itec240.com;
hardware ethernet 00:0D:87:09:E8:B9;
fixed-address 10.0.0.1;
}
}

Yes, I know using 10.0.0.1 isn't the best choice - but that is what the text gives - and it enables me to be sure it doesn't interfere with the settings of the router I usually use.

So how can I configure it to work on an interface?

Last edited by alinuxLQ; 10-14-2005 at 01:19 PM.
 
Old 10-15-2005, 04:50 PM   #2
debianmike
Member
 
Registered: Sep 2005
Posts: 115

Rep: Reputation: 15
i quick thought is that you have not defined any range's.

I had same issue when i went with dual nic's on a server, and for some reason, adding an empty scope on the second nic made this problem go away.

Ill post my dhcpd.conf file shortly
 
Old 10-15-2005, 04:56 PM   #3
debianmike
Member
 
Registered: Sep 2005
Posts: 115

Rep: Reputation: 15
# dhcpd.conf
# Author: me
# Date: Sept 20, 2005
#
#
ddns-update-style ad-hoc;
# options common to all subnets
option domain-name "domain.com";
# name servers
option domain-name-servers x.x.x.x;
default-lease-time 600;
max-lease-time 7200;
authorative;
#
# configuration for 10 subnet
subnet x.x.10.0 netmask 255.255.255.0{
range x.x.10.74 x.x.10.150;
option routers x.x.10.254;
option broadcast-address x.x.10.255;
}
subnet x.x.214.0 netmask 255.255.255.0{
}



Once I added the last 2 lines, my error went away and th 10.x subnet got IP's. I had 2 nics on 2 subnets.
 
Old 10-15-2005, 06:26 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,672

Rep: Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892
One possibility is the /etc/sysconfig/dhcpd file does not contain any command line arguments. This sets the interface.

DHCPDARGS=eth0
 
Old 10-15-2005, 11:55 PM   #5
alinuxLQ
LQ Newbie
 
Registered: Aug 2005
Distribution: RedHat, PC Linux, Xandros, SUSE
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the suggestions debianmike and michaelk. There wasn't any designation in the /etc/sysconfig/dhcpd file so I put in the eth0 info BUT that didn't solve the problem. Didn't restart the computer to see if that made any difference - but don't have access to it now to try it - will do later. Nor did adding the new subnet line help - couldn't get the syntax to work.
 
Old 10-17-2005, 06:03 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,672

Rep: Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892
Did you restart the server?
 
Old 10-18-2005, 03:38 AM   #7
alinuxLQ
LQ Newbie
 
Registered: Aug 2005
Distribution: RedHat, PC Linux, Xandros, SUSE
Posts: 4

Original Poster
Rep: Reputation: 0
Finally got it working but not sure how - a bit annoying. I configured a client on the network with Primary address of 10.10.10.2 and secondary address of 10.10.10.1. This seemed to spark the error report request for a submask for eth0 (10.10.10.1) when I tried to start the server. I put it in and then the server started. However, the other computer I tried on the network failed to activate the eth0 device on it when I changed it's settings to get an IP address from dhcp - so the server may be running but it isn't functioning as a dhcp server yet!

Back to the texts ...

Thanks
 
Old 03-14-2014, 12:50 AM   #8
brianhorakh
LQ Newbie
 
Registered: Mar 2014
Posts: 1

Rep: Reputation: Disabled
Another thing

dhcpd gives that error when no ip address is bound to the INTERFACE= specified in /etc/default/isc-dhcp-server
 
1 members found this post helpful.
Old 11-05-2015, 06:00 PM   #9
jkwilborn
LQ Newbie
 
Registered: Jun 2013
Location: Peoria, Arizona
Distribution: Debian
Posts: 12

Rep: Reputation: Disabled
brianhorakh, thanks for your last post on this old thread. You're one liner fixed my problem... Thanks

Jack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Making dhcpd listen to unplugged NIC Steamrunner Linux - Networking 4 07-25-2005 04:53 AM
dhcpd subnet declaration problems in dhcpd.conf vcrispo Linux - Networking 6 07-15-2005 10:32 AM
dhcpd - Not configured to listen on any interfaces. ritter Linux - Networking 1 07-05-2004 03:48 PM
dhcpd.conf (not listening error) SWAT Linux - Newbie 2 11-11-2003 03:22 AM
X11 server to listen on single configured interface kailesmith Linux - Networking 0 08-09-2003 05:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration