LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-19-2003, 05:06 AM   #1
Bamber
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Rep: Reputation: 0
Redhat 9 ntl cable modem dhcp problems


I previously had this working under RH8 but since installing RH9 (on dual boot machine with XP) I have problems both with USB and Cat5 conection (both OK under XP)

Specifically, I get corect IP address asingned to eth0 (or eth1 if usb) but then I can not ping or attach to anything. Have copied most settings from RH8 but same result.

If I specify Gateway IP address and run "route add default eth0", I can then ping gateway, but not nameservers. (nameservers are specified in resolve.conf)

I notice that pump is not included with RH9 but is still refered to in /sbin/ifup. Also in RH8, I had a load of lease stuff in /etc/dhcpc directory, but this directory is not even present under RH9.

Should I try to install pump and add DHCP_PROG=/sbin/pump ?
Any other sugestions or details required ?

Last edited by Bamber; 08-20-2003 at 04:40 PM.
 
Old 08-19-2003, 12:50 PM   #2
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
RedHat is always making changes.
I suggest using the RedHat Network Configuration GUI
Type: redhat-config-network

You may need to restart the network.
Type: service network restart
 
Old 08-20-2003, 03:37 AM   #3
Bamber
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Mathieu

Thanks for the reply, but I have lost count of the number of times that I have re-started the network service and run redhat-config-network. I deleted all config files and the device and re-installed from scratch last night, but same result: correct IP address is obtained but then Network unreachable, can not even ping numerical IP address. I'm going to try installing Pump and if that fails I think I'll go back to RH8
 
Old 08-20-2003, 02:03 PM   #4
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
It may be a routing problem.
Take a look at your routing table:
Code:
route -n
 
Old 08-20-2003, 04:33 PM   #5
Bamber
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Mathieu, thanks again,

Here's some output from route -n and some other commands
Code:
route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
213.105.253.0   0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
Code:
ifconfig

eth0      Link encap:Ethernet  HWaddr 00:80:5F:B7:37:BC  
          inet addr:213.105.253.227  Bcast:255.255.255.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9297 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:435228 (425.0 Kb)  TX bytes:994 (994.0 b)
          Interrupt:11 Base address:0xc800 Memory:e0000000-e0000038
If I ping any IP address i get:
Code:
connect: Network is unreachable
but if I run
Code:
route add default eth0
then when I ping any IP address i get
Code:
From 213.105.253.227 icmp_seq=1 Destination Host Unreachable
BUT if I ping the gateway I now get a normal response.

Hope some of this helps someone to suggest a few things to try!

Last edited by Bamber; 08-20-2003 at 04:37 PM.
 
Old 08-20-2003, 06:40 PM   #6
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
You are missing the default gateway to your ISP.
There should be a fourth line with the Gateway column set to 213.105.253.1 (or 213.105.253.254).

If you want to add it manually, use the following syntax:
Code:
route add default gw my_ISP_gateway
You can also try to add it to the eth0 configuration file (/etc/sysconfig/network-scripts/ifcfg-eth0).
 
Old 08-22-2003, 05:31 AM   #7
Bamber
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Runing

Code:
route add default gw 213.105.226.254
gives me

Code:
SIOCADDRT: Network is unreachable
 
Old 08-22-2003, 10:24 AM   #8
Bamber
LQ Newbie
 
Registered: Aug 2003
Posts: 8

Original Poster
Rep: Reputation: 0
OK

Thanks Mathieu for trying to help, I'm typing this in RH9, as all of a sudden it started working with just the same basic settings that I started with. I found a forum (nthellworld.com) where several users form my area had been reporting wierd problems over the last few days - so it seems that problem was at the ISP end all the time. Why it worked with XP and not RH9 I will probably never know.

Last edited by Bamber; 08-22-2003 at 10:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ntl Cable modem (usb) on CL Mahony Linux - Hardware 16 01-27-2004 01:50 PM
NTL USB Cable Modem robpaz26 Linux - Networking 1 05-14-2003 03:37 AM
RH8 and NTL Cable Modem fcuku Linux - Networking 2 03-02-2003 03:31 PM
NTL Cable modem ozkarfizz Linux - Software 1 04-10-2002 01:21 AM
NTL Cable modem ozkarfizz Linux - Newbie 1 04-09-2002 07:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration