LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-11-2003, 08:27 AM   #1
flapjackboy
Member
 
Registered: Jul 2003
Location: Norwich, UK
Distribution: Mandrake 9.1
Posts: 310

Rep: Reputation: 30
Angry Red Hat 9 having difficulty remembering its internet settings.


Okay guys, I've a bit of a problem with RH9...

I recently switched from MDK 9.1 to RH9 and I can't seem to get RH to automatically activate my realtek 8139 NIC. Every time I log in, the settings for my bb internet connection disappear and the card is inactive by default. I sort it out in the Internet Configuration Wizard and it says that it is saving the configuration, but next time I log in, it forgets it all over again.

It all worked flawlessly in MDK, but I don't really want to go back as the scroll wheel on my mouse works in RH!
 
Old 08-11-2003, 08:57 AM   #2
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Do you have more than one network card in your PC ?
Are you using DHCP ?

Open a terminal window and type:
Code:
chkconfig --list network
3 and 5 should be set to on
 
Old 08-11-2003, 09:04 AM   #3
flapjackboy
Member
 
Registered: Jul 2003
Location: Norwich, UK
Distribution: Mandrake 9.1
Posts: 310

Original Poster
Rep: Reputation: 30
nope, I'm not using dhcp. I'm entering the details manually.

3 and 5 are set to on.
 
Old 08-11-2003, 09:48 AM   #4
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
So, you have a static IP address.

Take a look at /etc/sysconfig/network-scripts/ifcfg-eth0, you should have at least the following lines.
Code:
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
IPADDR=<your_IP_address>
NETMASK=255.255.255.0
TYPE=Ethernet
You will need to add your ISPs DNS servers in /etc/resolv.conf
Code:
nameserver <ip_of_DNS_server_1>
nameserver <ip_of_DNS_server_2>
To restart and apply your network settings, type:
Code:
service network restart
 
Old 08-11-2003, 10:12 AM   #5
flapjackboy
Member
 
Registered: Jul 2003
Location: Norwich, UK
Distribution: Mandrake 9.1
Posts: 310

Original Poster
Rep: Reputation: 30
Contents of ifcfg-eth0:1

TYPE=Ethernet
DEVICE=eth0:1
HWADDR=00:02:44:70:1b:b3
BOOTPROTO=none
ONBOOT=yes
USERCTL=no
PEERDNS=yes
NETWORK=192.168.0.0
BROADCAST=192.168.255.255
IPADDR=192.168.0.101
NETMASK=255.255.0.0
GATEWAY=192.168.0.197

Contents of resolve.conf

nameserver 192.168.0.197
 
Old 08-11-2003, 10:29 AM   #6
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Lightbulb Found it.

Ok, you have two eth0 files.

Copy (or move) the contents of ifcfg-eth0:1 to ifcfg-eth0.
In the file, change the line DEVICE=eth0:1 to DEVICE=eth0

Then restart the network service.

You can also use the GUI tool.
 
Old 08-11-2003, 12:16 PM   #7
flapjackboy
Member
 
Registered: Jul 2003
Location: Norwich, UK
Distribution: Mandrake 9.1
Posts: 310

Original Poster
Rep: Reputation: 30
Problem solved, I went back to mandrake.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Difficulty installing proftpd-1.2.10.tar.bz2 on Red Hat 9 dkgilbey Linux - Software 2 03-25-2005 07:43 AM
Remembering window settings in OpenBox LavaDevil94 Linux - Software 0 11-21-2004 11:33 AM
xfce sound mixer not remembering settings killerbob Slackware 5 10-30-2004 03:22 PM
difficulty in red hat working eviroment nitin403 Linux - Newbie 1 07-25-2004 05:52 AM
Remembering network settings ShakyJake Linux - Newbie 5 04-13-2003 09:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration