LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Red Hat 7.1 fresh install, confused (https://www.linuxquestions.org/questions/linux-networking-3/red-hat-7-1-fresh-install-confused-31321/)

mmilhofer 09-27-2002 11:59 AM

Red Hat 7.1 fresh install, confused
 
Hi
I have just installed RH 7.1, and I'm confused by what isn't working.

I notice that SSHD is installed by default, fine, but I can't access it from a remote machine. I have checked that it is running, and I have installed SSH in the past on Unix and it's worked out of the box, so what am I missing here?

Also, there are no (what I would call) inet services running. I've worked out that it's called xinet.d now, so I tried editing the xinetd.conf file to run ftp (got the example from the MAN pages) but with no luck. I thought this sort of stuff ran by default and a dutiful admin would run around turning it all off...

All I want is to be able to ssh and ftp to this server. Surely that's not too much to ask..

Any help much appreciated

Manfred

mwtheobald 09-27-2002 07:06 PM

look in the /etc/xinet.d directory and you will see an entry for wu-ftp. Look inside and ensure there is not a 'disable = yes' line. Also check your /etc/hosts.allow or /etc/hosts.deny to ensure that TCPWrappers is not stopping things.

SSH problem might also be the TCPWrappers or check the config file for it (/etc/ssh/ssh_config)

AMDPwred 09-28-2002 12:04 AM

If you see the services are running and you cannot connect, it's probably a firewall rule blocking you. Check your ipchains file and see what rules are set. You can find it in: /etc/sysconfig/

Thaidog 09-28-2002 02:55 AM

Re: Red Hat 7.1 fresh install, confused
 
Quote:

Originally posted by mmilhofer
Hi
I have just installed RH 7.1, and I'm confused by what isn't working.

I notice that SSHD is installed by default, fine, but I can't access it from a remote machine. I have checked that it is running, and I have installed SSH in the past on Unix and it's worked out of the box, so what am I missing here?

Also, there are no (what I would call) inet services running. I've worked out that it's called xinet.d now, so I tried editing the xinetd.conf file to run ftp (got the example from the MAN pages) but with no luck. I thought this sort of stuff ran by default and a dutiful admin would run around turning it all off...

All I want is to be able to ssh and ftp to this server. Surely that's not too much to ask..

Any help much appreciated

Manfred

You need to go to: cd /etc/xinetd.d
ls that directory and you should find a list of services... one probably ftp and ftp-udp ... sudo pico ftp
and now you should be at the personal config file...
no need to edit the xinetd.conf file.. like when inetd.conf was used for all services... now xinetd.conf uses several personal files for each application/protocol.

mmilhofer 09-30-2002 04:55 AM

thanks for the info. I'll try it all and let you know how I get on.

mmilhofer 09-30-2002 05:45 AM

Well you've sussed out the problems, thank you very much.

FTP was indeed disabled in its config file.

Also, all traffic on ports beneath 1024 was disabled.

All I need to work out now is how to configure ipchains. I tried the man pages but they don't seem to be a very good intro.

any recommendations?

Anyway, thanks for your help in spotting the issues.

Manfred

unSpawn 09-30-2002 06:30 AM

RH 7.1 comes with Netfilter (iptables) installed IIRC, search the security and networking forums, because there's lotsa info on it and usually also some addresses where HOWTO's are at like tldp.org and linuxguruz.org/iptables/

mmilhofer 09-30-2002 09:22 AM

thank you very much.
having spent the morning trying to enable ftp and ssh by using ipchains (I know I should upggrade to iptables but I don't think I can manage it), could anyone tell me why the following isn't working (I used as reference the ipchains HOWTO by Rusty Russell):

ipchains -A input -p TCP -s 0.0.0.0/0 21 -j ACCEPT

this adds a line to the ipchains listing which looks sensible to me, but still can't use ftp. Added the same line for UDP but still nothing.
Is this anything to do with the rule in the input chain which rejects anything below port 1024? I had hoped my subsequent rules would open just port 22?

mmilhofer 09-30-2002 09:35 AM

me again

just had a brainwave and realised that my rules should go BEFORE the rule which rejects everything below 1024, so I changed my command to 'ipchains -I', and the ipchains listing showed what I thought I wanted to see (ie my rule first), but it STILL doesn't work??
Do I need to restart anything? I can't find anything in the HOWTO which says that

mmilhofer 09-30-2002 10:16 AM

finally got it sorted. turned out I had my 'source' and 'destination' flags the wrong way round (still can't get my head round it but it works so who cares).
thanks all.


All times are GMT -5. The time now is 03:55 AM.