LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Really strange browsing problem (https://www.linuxquestions.org/questions/linux-networking-3/really-strange-browsing-problem-200646/)

Ninaw 07-03-2004 09:37 AM

Really strange browsing problem
 
Lately I've been having a really strange browsing problem.
Here's my setup.

Dualboot:
Slackware 9.0
Windoze XP

Internet Connection: DSL-PPPoE
-Configured the router to use its DHCP server.
-Used Slack's netconfig util to configure the DHCP client.

Router (D-Link DPT DI-704P)
--A. 5-port Switch
--------1. My own computer (Let's call it PC1)
--------2. Another computer
--------3. Another computer
--B. Single computer

(A and B directly connected to the router; 1,2,3 connected to A)

Under linux in PC1, I can't visit some sites, particularly .org domains and some subdomains, e.g. ctan.org, fluxbox.sourceforge.net. I tried pinging the said sites only to get "host not found" errors. Yet I can visit some subdomains like groups.yahoo.com. When I used the router's own ping tool it reported that it was able to ping the sites that I was not able to ping under linux.

However, under windoze in PC1, I can visit the said sites without any problems.

So now I am quite confused whether it is a problem with the hub, or with how linux interacts with the router, or it's something really mysterious that I am not supposed to discover.

Ninaw 07-03-2004 10:07 AM

I noticed also after I have visited a site using its IP address, I can use its url for subsequent visits.

Also, the host name of PC1, 'anino,' isn't showing up in the router's browser-based control interface; only the IP address is present in the DHCP clients list.

Ninaw 07-03-2004 01:01 PM

I've discovered the problem. DHCP places the nameservers of my isp in my resolv.conf file although the correct value should be the ip address of my router. The question I have now is how to maintain the dynamically set IP addresses yet have a fixed nameserver.

andrewdodsworth 07-03-2004 03:01 PM

Have a look in /etc/sysconfig/network/ (or at least that's where it is in SuSE) for ifcfg-ethX where X is whatever your NIC is (usually 0 if you only have one NIC).

In there you may have the following or there may be nothing like this as it could be using defaults. You can put these in there and they will override any defaults. Just change the 'yes' to 'no' for MODIFY_RESOLV_CONF and it won't modify your resolv.conf

BOOTPROTO='dhcp'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'

Ninaw 07-03-2004 09:17 PM

Quote:

Originally posted by andrewdodsworth
Have a look in /etc/sysconfig/network/ (or at least that's where it is in SuSE) for ifcfg-ethX where X is whatever your NIC is (usually 0 if you only have one NIC).

In there you may have the following or there may be nothing like this as it could be using defaults. You can put these in there and they will override any defaults. Just change the 'yes' to 'no' for MODIFY_RESOLV_CONF and it won't modify your resolv.conf

BOOTPROTO='dhcp'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'

thanks, this is probably better than what I did
I modified rc.inet1 and added a -R option to the dhcp line so that it doesn't override resolv.conf (talk about inelegant)

andrewdodsworth 07-04-2004 08:30 AM

Quote:

Originally posted by Ninaw
thanks, this is probably better than what I did
I modified rc.inet1 and added a -R option to the dhcp line so that it doesn't override resolv.conf (talk about inelegant)

Well so long as you're sorted - I needed to sort out a fight between onboard ethernet and unsupported PCMCIA wireless card both using DHCP and didn't really want to muck about with system scripts as the wireless card isn't usually in the machine.


All times are GMT -5. The time now is 03:05 AM.