LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-26-2005, 03:54 PM   #1
jacko1729
LQ Newbie
 
Registered: Apr 2005
Distribution: Redhat 9
Posts: 10

Rep: Reputation: 0
read-only access after a few days


I have a Samba server running on RH 9, and everything is fine except for this one thing. After a few days, the windows clients can only open their files in read-only mode. I have a public shared folder, with each users subfolder, and all belong to group root, and all the users belong to group root.

If I go in and do a chgrp to root for the public folder, and chmod 777, all the files are accessible for a few days, then slowly the problem re-appears.

Any ideas? and do I need to give more info? Thanks!!

Jack O'Brien
 
Old 07-26-2005, 04:53 PM   #2
issinho
Member
 
Registered: Jun 2005
Location: Bosie, ID
Distribution: Fedora Core 4, Kurumin,BackTrack, Slackware 10.2, IPCop
Posts: 105

Rep: Reputation: 15
One option would be: In the smb.conf file, add a line like this: force user = {the user who owns the file}.

Esentially what you're telling Samba is, "No matter who connects, act as though they are {}." So, if you're sharing a folder that is owned by, let's call him Joe Blow, then Samba will act as though Joe signed in, authenticated and is currently accessing the share.

I don't advise you do this with root (as that is always a bad idea--security wise). But, if Root owns the folder, either change it, or go with it.
 
Old 07-26-2005, 09:09 PM   #3
mpeg4codec
Member
 
Registered: Jul 2005
Distribution: Debian, Gentoo, self-built [not LFS]
Posts: 109

Rep: Reputation: 15
Make sure you set the create mode to something like 666. In Samba, you would add something like this to the share's definition:

create mask = 0666
directory mask = 0777

See if that does the trick.
 
Old 07-27-2005, 09:50 AM   #4
jacko1729
LQ Newbie
 
Registered: Apr 2005
Distribution: Redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by issinho
One option would be: In the smb.conf file, add a line like this: force user = {the user who owns the file}.

Esentially what you're telling Samba is, "No matter who connects, act as though they are {}." So, if you're sharing a folder that is owned by, let's call him Joe Blow, then Samba will act as though Joe signed in, authenticated and is currently accessing the share.

I don't advise you do this with root (as that is always a bad idea--security wise). But, if Root owns the folder, either change it, or go with it.
Thanks! Point well taken about Root, but I will give this a try.

Jack
 
Old 07-27-2005, 09:52 AM   #5
jacko1729
LQ Newbie
 
Registered: Apr 2005
Distribution: Redhat 9
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by mpeg4codec
Make sure you set the create mode to something like 666. In Samba, you would add something like this to the share's definition:

create mask = 0666
directory mask = 0777

See if that does the trick.
Ahhh, I will have to check this. Thanks so much!

Jack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
access to read only files absalon Linux - Newbie 4 06-22-2005 07:31 AM
read write access phoenix_wolf Linux - Newbie 2 12-05-2004 10:35 AM
read-only access to my own /home files esteeven Linux - General 7 07-16-2004 11:27 PM
Read/Write access to a partition? Boggit Linux - Newbie 5 04-04-2004 04:05 PM
vsftp anonymous read access kwilliams0 Linux - Software 2 08-19-2003 05:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration