LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-26-2004, 05:25 AM   #1
treotan
Member
 
Registered: Jun 2004
Posts: 126

Rep: Reputation: 15
Unhappy Re-install Apache


Hi!
My machine cannot start the httpd service; I think I need re-install the apache for my machine. Any suggestion.
How to uninstall the apache and install the new one?

Thks
 
Old 06-26-2004, 09:40 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
what distro do you use?

If it is a rpm based install, you can simply

#rpm -e httpd

If you have compiled apache with the --prefix option, you can safely delete that directory (obviously after backing up important files) and do a fresh compile.
 
Old 06-26-2004, 10:00 AM   #3
treotan
Member
 
Registered: Jun 2004
Posts: 126

Original Poster
Rep: Reputation: 15
Unhappy

I don't know what is the version of the apache! This is came from Fedora! I did not install apache before!

I tried type rpm -e httpd, it was shown the msg:

[root@localhost conf]# rpm -e httpd
error: Failed dependencies:
httpd is needed by (installed) redhat-config-httpd-1.1.0-5
httpd >= 2.0.40 is needed by (installed) mod_perl-1.99_12-2
httpd >= 2.0.40 is needed by (installed) mod_python-3.0.4-0.1
httpd is needed by (installed) mod_ssl-2.0.48-1.2
httpd is needed by (installed) mapserver-4.0.1-2
httpd-mmn = 20020903 is needed by (installed) php-4.3.4-1.1
httpd-mmn = 20020903 is needed by (installed) mod_perl-1.99_12-2
httpd-mmn = 20020903 is needed by (installed) mod_python-3.0.4-0.1
httpd-mmn = 20020903 is needed by (installed) mod_ssl-2.0.48-1.2
webserver is needed by (installed) webalizer-2.01_10-14
[root@localhost conf]#

How to fix it?
 
Old 06-26-2004, 01:07 PM   #4
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
What error message do you get when you try to start apache?

2.0.40 is pretty old anyways... download the updates from download.fedora.redhat.com

Install those rpms with

#rpm -Fvh <those updates>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install Apache stanleytiew Linux - Newbie 2 04-27-2005 10:07 AM
Apache virtualhost problems, apache install problems nyroc Linux - Software 2 06-09-2003 11:16 PM
RH8.0 : Need to uninstall Apache 2 and install Apache 1 ericcarlson Linux - Software 1 02-10-2003 02:13 PM
Apache 1.3.24 Install Help Lorddraco98 Slackware 5 04-27-2002 12:18 PM
Removing apache rpm and install apache from source john lee Linux - Software 2 11-15-2001 08:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration