LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-14-2008, 04:46 AM   #1
arani
LQ Newbie
 
Registered: Feb 2008
Posts: 2

Rep: Reputation: 0
r8169.ko driver automatically activated, card detected but link is down


Hi,

I have trouble using a gigabit card using RTL8169 from Debian Etch
4.0r-0 (amd64) and Debian Etch 4.0r-1 (i386). I have tried both
versions. The card gets detected (ifconfig shows hardware address and
I can ping the card) but the link LED goes off and `dmesg' shows
eth0 link down. The NIC is connected to a dumb 100 Mb/s switch
D-Link DES1008D. LEDs go off at both the card and switch ends. However,
Windows XP can use this link. Is there some compatibility problems
regarding the gigabit/100 Mbps protocols? Do I need to pass some parameters
to the module to tell it that it should go to the 100 Mb/s mode? I have
not seen inside the card? Do I need to make sure whether it is really
RTL8169?
 
Old 02-14-2008, 01:03 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Have you seen this thread?

http://www.linuxquestions.org/questi...roblem-591466/

Especially posts #9 & #12
And welcome to LQ!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
card detected, driver & modules loaded, but no sound? Chowroc Linux From Scratch 8 12-28-2006 08:08 AM
Problem compiling r8169 driver BeGosV Linux - Networking 2 02-23-2006 03:25 PM
_very_ strange problems with r8169 nic driver outwardlymobile Linux - Hardware 3 11-24-2004 04:41 PM
Sound card not detected even after driver installed eam Linux - Hardware 7 11-11-2004 01:14 AM
Compiling r8169.c network card driver on Alpha... Minuteman Linux - Hardware 1 04-03-2004 07:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration