LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-19-2013, 10:15 PM   #1
taylorbyte
LQ Newbie
 
Registered: Aug 2013
Location: Australia
Distribution: archlinux, openwrt, debian
Posts: 2

Rep: Reputation: Disabled
quagga zebra ospfd nsm_change_state Full -> Init routes disappear and reappear


Zebra routes disappear at random times for aproximately 5 seconds and then re-appear in router 1 and 2 not sure what is causing it. I believe the 1st and 2nd router are going into Init mode, i don't know what is happening after that.


ROUTER 1
========

"while true; do echo; ip route; sleep 1; done"

ip route:

Code:
default via 10.0.0.1 dev eth0  proto zebra 
10.0.0.0/24 dev eth0  proto kernel  scope link  src 10.0.0.2 
10.0.1.0/30 dev wlan0  proto kernel  scope link  src 10.0.1.1 
10.0.1.4/30 via 10.0.1.2 dev wlan0  proto zebra  metric 20 
10.0.1.8/30 dev wlan0-1  proto kernel  scope link  src 10.0.1.9 
192.168.0.0/24 via 10.0.1.2 dev wlan0  proto zebra  metric 30 
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.1 
192.168.4.0/24 via 10.0.1.10 dev wlan0-1  proto zebra  metric 20
then randomly the routes to connect to networks on router 2 disappear

Code:
default via 10.0.0.1 dev eth0  proto zebra 
10.0.0.0/24 dev eth0  proto kernel  scope link  src 10.0.0.2 
10.0.1.0/30 dev wlan0  proto kernel  scope link  src 10.0.1.1 
10.0.1.8/30 dev wlan0-1  proto kernel  scope link  src 10.0.1.9 
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.1 
192.168.4.0/24 via 10.0.1.10 dev wlan0-1  proto zebra  metric 20

ospf running in foreground:

Code:
2013/08/19 23:55:34 OSPF: nsm_change_state(10.0.1.5, Full -> Init): scheduling new router-LSA origination
2013/08/19 23:55:34 OSPF: DR-Election[1st]: Backup 10.0.1.1
2013/08/19 23:55:34 OSPF: DR-Election[1st]: DR     10.0.1.1
2013/08/19 23:55:34 OSPF: DR-Election[2nd]: Backup 0.0.0.0
2013/08/19 23:55:34 OSPF: DR-Election[2nd]: DR     10.0.1.1
2013/08/19 23:55:53 OSPF: DR-Election[1st]: Backup 0.0.0.0
2013/08/19 23:55:53 OSPF: DR-Election[1st]: DR     10.0.1.1
2013/08/19 23:55:53 OSPF: Packet[DD]: Neighbor 10.0.1.5: Initial DBD from Slave, ignoring.
2013/08/19 23:55:53 OSPF: Packet[DD]: Neighbor 10.0.1.5 Negotiation done (Master).
2013/08/19 23:55:53 OSPF: nsm_change_state(10.0.1.5, Loading -> Full): scheduling new router-LSA origination
2013/08/19 23:55:54 OSPF: DR-Election[1st]: Backup 10.0.1.2
2013/08/19 23:55:54 OSPF: DR-Election[1st]: DR     10.0.1.1
2013/08/19 23:55:54 OSPF: DR-Election[1st]: Backup 10.0.1.2
2013/08/19 23:55:54 OSPF: DR-Election[1st]: DR     10.0.1.1

Code:
ospfd> show ip ospf neighbor

    Neighbor ID Pri State           Dead Time Address         Interface            RXmtL RqstL DBsmL
10.0.1.5          1 Full/Backup       33.427s 10.0.1.2        wlan0:10.0.1.1           0     0     0
10.0.1.10         1 Full/DR           34.262s 10.0.1.10       wlan0-1:10.0.1.9         0     0     0

zebra.conf:

Code:
hostname zebra_router
password zebra
enable password zebra
!
interface eth0
description internet connection
ip address 10.0.0.0/24 
!
interface wlan0
description wireless backbone to tb-hotspot2
ip address 10.0.1.1/30
!
interface wlan0-1
description wireless backbone to dan
ip address 10.0.1.9/30
!
ip route 0.0.0.0/0 10.0.0.1
!
access-list access permit 127.0.0.1/32
access-list access deny any
!
line vty
access-class access

ospfd.conf:
Code:
hostname ospfd
password zebra
log stdout
!
! Create an access list that allows access from localhost and nowhere else
access-list access permit 127.0.0.1/32
access-list access deny any
!
! Enable access control on the command-line interface
line vty
access-class access
!
interface eth0
!
interface wlan0
!
interface wlan0-1
!
router ospf
network 10.0.1.0/30 area 0.0.0.0
network 10.0.1.8/30 area 0.0.0.0
network 10.0.0.0/24 area 0.0.0.0
default-information originate

ROUTER 2
========
zebra.conf:

Code:
hostname zebra_router
password zebra
enable password zebra
!
interface bb1
description wireless backbone interface
ip address 10.0.1.2/30
!
interface eth0
description wireless backbone interface
ip address 10.0.1.5/30
!
ip route 0.0.0.0/0 10.0.1.1
!
access-list access permit 127.0.0.1/32
access-list access deny any
!
line vty
access-class access

ospfd.conf:

Code:
hostname ospfd
password zebra
log stdout
!
! Create an access list that allows access from localhost and nowhere else
access-list access permit 127.0.0.1/32
access-list access deny any
!
! Enable access control on the command-line interface
line vty
access-class access
!
interface eth0
!
interface bb1 
!
router ospf
network 10.0.1.0/30 area 0.0.0.0
network 10.0.1.4/30 area 0.0.0.0
default-information originate
 
Old 08-26-2013, 05:40 AM   #2
taylorbyte
LQ Newbie
 
Registered: Aug 2013
Location: Australia
Distribution: archlinux, openwrt, debian
Posts: 2

Original Poster
Rep: Reputation: Disabled
I suspect that the problem is caused by high nework traffic causing HELLO packets to be dropped. so I changed the hello-interval from 10 the default to 5

telnet localhost ospfd
Code:
enable
configure terminal
interface eth0
ip ospf hello-interval 5
ip ospf network point-to-point
write
this needs to be changed on all routers in the sam segment, since the network is a /30 there are only 2 ips so i made it also a point-to-point link.

/etc/quagga/ospfd.conf
Code:
!
! Zebra configuration saved from vty
!   2013/08/26 17:39:03
!
hostname ospfd
password zebra
log stdout
!
!
!
interface eth0
 ip ospf network point-to-point
 ip ospf hello-interval 5
!
interface lo
!
interface wlan0
 ip ospf network point-to-point
 ip ospf hello-interval 5
!
router ospf
 network 10.0.1.0/30 area 0.0.0.0
 network 10.0.1.4/30 area 0.0.0.0
!
access-list access permit 127.0.0.1/32
access-list access deny any
!
line vty
 access-class access
!
So the routes have stayed, more testing needs to be done to make sure...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount points disappear and reappear under /media for USB drives alamode Linux - Server 2 06-11-2012 02:47 PM
How to open zebra service after installed quagga source file xman2548 Linux - Newbie 2 04-13-2011 09:28 AM
Zebra/quagga and ISIS pm010537 Linux - Networking 0 01-22-2008 05:37 PM
QUAGGA, start zebra daemon problem. ERBRMN Linux - Networking 2 01-23-2007 01:29 PM
zebra and ospfd: error mandana Linux - Networking 0 03-09-2006 02:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration