-   Linux - Networking (
-   -   Qmail - SMTP problems (

chrisfirestar 06-14-2004 04:29 AM

Qmail - SMTP problems
I have done an install of Qmail from this guide:

the problem is that now its all setup i cant seem to send via SMTP.
from the webmail i get a Connection Refused Error and I have tried everything (not everything obviously cause otherwise i would have fixed it) but everything i can think of.

any where that i can check configurations etc?

the webmail works.. IMAP works, pop3 works everything seems to work except for the stupid SMTP :(

Any ideas? Anything you want me to post?

btw its not a firewall issue.

Donboy 06-14-2004 07:22 AM

When you try to send a message using SMTP, I would think there should be a message in /var/log/qmail/qmail-smtpd/current that may give you some insights.

You may also want to check /var/qmail/supervise/qmail-smtpd/run and be sure it looks like the tutorial specifies.

You may also want to try doing a "ps -ef | grep proc" and see if there are any errors showing up on readproctile service errors. Normally they will just be dots, which is fine.

chrisfirestar 06-15-2004 04:30 AM

ok heres some more info for you... i have tried to fix the problems but so far can not find a solution

when i do a ./qmail stat i get this:


qmail-pop3d: up (pid 3589) 24652 seconds
qmail-send: up (pid 3597) 24652 seconds
qmail-smtpd: up (pid 3595) 24652 seconds
qmail-pop3d/log: up (pid 3609) 24650 seconds
qmail-send/log: up (pid 3606) 24650 seconds
qmail-smtpd/log: up (pid 3603) 24650 seconds

this means that it IS up and running but when i do this:
ps -efl | grep "service errors" | grep -v grep

i get this


0 S root      3592  3585  0  75  0    -  334 pipe_w 10:37 ?        00:00:00 readproctitle service errors: temporary failure?supervise: fatal: unable to acquire log/supervise/lock: temporary failure?supervise: fatal: unable toacquire log/supervise/lock: temporary failure?supervise: fatal: unable to acquir

Donboy 06-15-2004 06:29 AM

Ok, try going into the /var/qmail/supervise directory and delete the lock files. There are lock files located under each of the directories. Get them all. qmail will make them again in a few seconds. You may also wanna stop and restart qmail just for good measure.

chrisfirestar 06-15-2004 08:29 PM

ok when i clear the lock files and restart I got this in the qmail log:


@4000000040cfa22c136d9c24 tcpserver: fatal: unable to bind: address already used
@4000000040cfa22d15364664 tcpserver: fatal: unable to bind: address already used
@4000000040cfa22e1700fffc tcpserver: fatal: unable to bind: address already used

so i did a restart.... im really baffled on this... i have obviously done SOMETHING wrong but cant figure it out...

Donboy 06-15-2004 08:56 PM

Yeah, sorry.. I seem to have forgotten that would happen. It's trying to start another instance of qmail and you've already got daemons listening on those ports. You can reboot and it'll clear right up, but if you don't wanna reboot, you can just stop qmail and be sure to kill all those processes that are running. Just do ps -ef and kill anything that talks about qmail, but of course be sure to stop qmail first.

chrisfirestar 06-15-2004 09:30 PM

yeah but as soon as i reboot i end up with the same problem with SMTP :(

Donboy 06-15-2004 10:53 PM

Ok, let's try this... run the command /var/qmail/bin/qmail-showctl and post the output here. This will show all your current settings and how you've got qmail configured. If you feel like you need to censor the output, that's Ok, but be aware that it really helps to show everything as-is so we can be sure it's all good.

also, is it possible you have a CR/LF problem? Have you modified any of your control files using a windows text editor through samba? If so, this is certainly a problem. If you have been editing your control files through windows, you'll need to do a vi -b on each control file and delete the ^M characters you see at the end of each line.

chrisfirestar 06-16-2004 02:03 AM

ok this is what i get from ./qmail-showctl


qmail home directory: /var/qmail.
user-ext delimiter: -.
paternalism (in decimal): 2.
silent concurrency limit: 255.
subdirectory split: 199.
user ids: 91, 92, 93, 0, 94, 95, 96, 97.
group ids: 91, 92.

badmailfrom: (Default.) Any MAIL FROM is allowed.

bouncefrom: (Default.) Bounce user name is MAILER-DAEMON.

bouncehost: (Default.) Bounce host name is

concurrencylocal: (Default.) Local concurrency is 10.

concurrencyremote: Remote concurrency is 255.

databytes: (Default.) SMTP DATA limit is 0 bytes.

defaultdomain: Default domain name is

defaulthost: (Default.) Default host name is

doublebouncehost: (Default.) 2B recipient host:

doublebounceto: (Default.) 2B recipient user: postmaster.

envnoathost: (Default.) Presumed domain name is

helohost: (Default.) SMTP client HELO host name is

idhost: (Default.) Message-ID host name is

localiphost: (Default.) Local IP address becomes

Messages for are delivered locally.

me: My name is

percenthack: (Default.) The percent hack is not allowed.

plusdomain: Plus domain name is com.

qmqpservers: (Default.) No QMQP servers.

queuelifetime: (Default.) Message lifetime in the queue is 604800 seconds.

rcpthosts: (Default.) SMTP clients may send messages to any recipient.

morercpthosts: (Default.) No rcpthosts; morercpthosts is irrelevant.

morercpthosts.cdb: (Default.) No effect.

smtpgreeting: (Default.) SMTP greeting: 220


timeoutconnect: (Default.) SMTP client connection timeout is 60 seconds.

timeoutremote: (Default.) SMTP client data timeout is 1200 seconds.

timeoutsmtpd: (Default.) SMTP server data timeout is 1200 seconds.

Virtual domain:

virtualdomains.lock: I have no idea what this file does.

i have just changed my domain to thats the only change.

in relation to editing on windows machines ive been ssh'ing in and using vi :)

Thanks for your help.. hope we are getting somewhere :D

chrisfirestar 06-16-2004 02:26 AM

Ps: this line i have not modified... i think this is not correct??

virtualdomains.lock: I have no idea what this file does.

ppuru 06-16-2004 02:26 AM

can you successfully telnet to port 25 of your mail server?

chrisfirestar 06-16-2004 02:30 AM

can... comes up with a blank screen i guess this means it can... then as soon as i press CTRL it kicks me out...

ppuru 06-16-2004 02:51 AM

QMail should respond with something when you telnet to port 25 ... AFAIK it can't be blank.


#netstat -ltp

show qmail listening on port 25?

chrisfirestar 06-16-2004 02:54 AM

tcp 0 0 *:smtp *:* LISTEN 3604/


chrisfirestar 06-16-2004 02:55 AM

further more:

.qmail stat gives

qmail-pop3d: up (pid 3596) 1829 seconds
qmail-send: up (pid 3599) 1829 seconds
qmail-smtpd: up (pid 3604) 1829 seconds
qmail-pop3d/log: up (pid 3615) 1825 seconds
qmail-send/log: up (pid 3612) 1825 seconds
qmail-smtpd/log: up (pid 3609) 1825 seconds

All times are GMT -5. The time now is 03:05 PM.