LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-11-2012, 04:10 AM   #1
Ze MoreirA
LQ Newbie
 
Registered: Aug 2007
Location: Tbilisi, Georgia
Posts: 18

Rep: Reputation: 0
Proxy problem opensuse 11.4


Hello

I just installed Opensuse 11.4 on my old laptop, I'm trying to use corporate proxy server (authenticated as user\domain), but found a problem.

I configured proxy settings from yast, when I click "test settings I get error with details:

Code:
* About to connect() to proxy tb-proxy port 8080 (#0)
*   Trying 172.30.140.125...   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0connected
* Connected to tb-proxy (172.30.140.125) port 8080 (#0)
* Proxy auth using Basic with user 'user@domain'
> GET http://www.novell.com HTTP/1.1
> Proxy-Authorization: Basic Z2dhYnVuaXlhQGJlZS5tb2JpdGVsLmxvY2FsOkdhYnVuaWExMjM=
> User-Agent: curl/7.21.2 (i686-pc-linux-gnu) libcurl/7.21.2 OpenSSL/1.0.0c zlib/1.2.5 libidn/1.15 libssh2/1.2.7
> Host: www.novell.com
> Accept: */*
> Proxy-Connection: Keep-Alive
> 
< HTTP/1.1 407 Proxy Authentication Required ( Forefront TMG requires authorization to fulfill the request. Access to the Web Proxy filter is denied.  )
< Via: 1.1 TB-TMG003
* gss_init_sec_context() failed: : Credentials cache file '/tmp/krb5cc_0' not foundProxy-Authenticate: Negotiate
< Proxy-Authenticate: Kerberos
< Proxy-Authenticate: NTLM
< Connection: Keep-Alive
< Proxy-Connection: Keep-Alive
< Pragma: no-cache
< Cache-Control: no-cache
< Content-Type: text/html
< Content-Length: 4132  
< 
{ [data not shown]

100  4132  100  4132    0     0   203k      0 --:--:-- --:--:-- --:--:--  252k* Connection #0 to host tb-proxy left intact

* Closing connection #0
I tried to input domain\username, username@domain, but nothing works

username/password is correct, Firefox requested proxy credentials on startup, I entered username and password and connected to internet.

/etc/sysconfig/proxy looks like this:

Code:
# Path:        Network/Proxy
## Description:
## Type:        yesno
## Default:     no
## Config:      kde,profiles
#
# Enable a generation of the proxy settings to the profile.
# This setting allows to turn the proxy on and off while
# preserving the particular proxy setup.
# 
PROXY_ENABLED="yes"

## Type:        string
## Default:     ""
#
# Some programs (e.g. lynx, arena and wget) support proxies, if set in
# the environment.  SuSEconfig can add these environment variables to
# /etc/SuSEconfig/* (sourced by /etc/profile etc.) -
# See http://portal.suse.com/sdb/en/1998/01/lynx_proxy.html for more details.
# Example: HTTP_PROXY="http://proxy.provider.de:3128/"
HTTP_PROXY="http://tb-proxy:8080"

## Type:        string
## Default:     ""
#
# Some programs (e.g. lynx, arena and wget) support proxies, if set in
# the environment.  SuSEconfig can add these environment variables to
# /etc/SuSEconfig/* (sourced by /etc/profile etc.) -
# this setting is for https connections
HTTPS_PROXY="http://tb-proxy:8080"

## Type:        string
## Default:     ""
#
# Example: FTP_PROXY="http://proxy.provider.de:3128/"
#
FTP_PROXY="http://tb-proxy:8080"

## Type:        string
## Default:     ""
#
# Example: GOPHER_PROXY="http://proxy.provider.de:3128/"
#
GOPHER_PROXY=""

## Type:        string(localhost)
## Default:     localhost
#
# Example: NO_PROXY="www.me.de, do.main, localhost"
#
NO_PROXY="localhost, 127.0.0.1"
Can someone help me please?
 
Old 04-12-2012, 03:47 AM   #2
Ze MoreirA
LQ Newbie
 
Registered: Aug 2007
Location: Tbilisi, Georgia
Posts: 18

Original Poster
Rep: Reputation: 0
I found that other people have similar problem, using cntlm seems to solution, but I can't make it work
No matter how I configure /etc/cntlm.conf I can't establish connection to proxy server. I tried to input plain text password, hash from cntlm -H, but nothing works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up of proxy in Opensuse 11 jayamurugan Linux - Newbie 10 05-17-2009 06:41 PM
Cannot use office proxy - opensuse 10.3 eastkidz SUSE / openSUSE 1 06-01-2008 06:46 PM
Transparent proxy on opensuse aswinkillua_z Linux - Server 2 09-03-2007 09:27 PM
Problem with firefox proxy settings in openSuSE 10.2 naveenlinux SUSE / openSUSE 2 06-14-2007 03:23 AM
get opensuse use proxy ar43r Linux - Networking 1 12-10-2006 03:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration