LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-13-2004, 03:50 AM   #1
Rajahuroman
Member
 
Registered: May 2004
Location: Romania; Arad
Distribution: Archlinux
Posts: 91

Rep: Reputation: 15
proftpd won't start


Hy

I installed ProFTPD with no problems but when I ran it it wouldn't start. To see what was wrong I ran it with the parameter -n. i got these messages:

linux.rdsar.ro - Failed binding to 0.0.0.0 port 21: Adress already in use
linux.rdsar.ro - Check the ServerType directive to ensure you are configured corectly

But the server type is the one I want it to be. How can I make it not to be in use?

Thank you.

Last edited by Rajahuroman; 08-14-2004 at 03:31 AM.
 
Old 08-13-2004, 07:40 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
I would first check the error "Failed binding to 0.0.0.0 port 21: Aress already in use"... something is already running on or using port 21. Check and make sure you don't already have an ftp server running.

Cause if your using Slackware 9.1 like your profile states, it comes already installed with Proftpd and to enable it is as easy as uncommenting the correct line in /etc/inetd.conf file.
 
Old 08-13-2004, 08:40 AM   #3
bruj3w
Member
 
Registered: Mar 2004
Location: england
Distribution: slackware
Posts: 164

Rep: Reputation: 30
yeah, it looks asif something else has got to port 21 first.

try netstat -p and see if you can see any services that might be running already and kill the process if there is one.
 
Old 08-14-2004, 01:15 AM   #4
Rajahuroman
Member
 
Registered: May 2004
Location: Romania; Arad
Distribution: Archlinux
Posts: 91

Original Poster
Rep: Reputation: 15
I checked and you're right, proftpd is already installed on Slackware 9.1.

At this point I think I should do some explaining:
My PC is inside a local network formed with one gateway an another computer. I would like to enable proftpd on both but I started with the one that is not conected to the Internet.

I enabled proftpd by uncommenting the proper line (well actually I realised it was already uncommented, this was the cause for the message I got when trying to run it again). Next I went to the other computer (the one connected to the Internet which acts as a gateway) and tried several ways to connect. First I ran mc and tried a ftp link to rajah@rajah (username@remote host). I got a "cannot chdir to /#ftp:rajah@rajah". Then I tried connecting still with the ftp link from mc but by writing rajah@192.168.0.2. I was prompted for my password which is OK since I do have a password on this account but after giving the correct password I got an error message that said "Login incorrect for user rajah". The same happens if I try connecting with anonymous@182.168.0.2 (I add here that I commented the lines from /etc/ftpusers that stopped anonymous acces and I also set the /etc/proftpd.conf file in such way that anonymous access is also possible.)

Next I tried connecting with another application. My choice was the ftp command. So I ran ftp, then open rajah,the computer sits for about 3 seconds thinking then pops out "rajah:Name or service unknown". If I try open 192.168.0.2 then I get the message

Connected to 192.168.0.2 (192.168.0.2)
421 Service not available, remote server has closed connection

What else must I do to set up the ftp server?

Last edited by Rajahuroman; 08-14-2004 at 01:17 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 10:27 AM
Set Proftpd on Start Up sysmgr Red Hat 1 02-12-2004 12:33 PM
how do you start and stop inetd / proftpd? wendallsan Linux - Networking 2 10-14-2003 12:53 PM
Proftpd Service Start ERROR!! poisonousmist Linux - Newbie 2 10-14-2003 08:34 AM
proftpd Fatal Error on start rose_bud4201 Linux - Software 33 09-24-2003 06:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration