LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Proftpd - Unstable speed & Slow transfer of large files (https://www.linuxquestions.org/questions/linux-networking-3/proftpd-unstable-speed-and-slow-transfer-of-large-files-501110/)

Retrievil_Knievil 11-13-2006 05:37 AM

Proftpd - Unstable speed & Slow transfer of large files
 
Hi all,

I have been reading a lot of these threads lately, but I cannot find a fix for my problem. The problem appeared when I moved my office, but the setup was the same, this makes me think it could be a hardware/network issue I cannot figure out...

I have a Gentoo-Hardened server running proftpd, and I am syncronizing this with several different machines. My problem is as follows:

The down/upload process will work excellently, (well, this is a really slow computer, so 40-50Kb/s is rather excellent...:), but if the file is large, i.e. 1 Mb or larger, the transfer speed will drop to some bytes/sec without any (obvious) reason. Most of the time this happens after a large portion of the file has been transferred, so the connection actually works fine for a little while....?

I have tried just about every solution I have seen here, turning off DNSlookups and Ident, rearranging my entire dns setup locally, switching between passive/active mode and a lot of other "problemsolvers", but the problem persists.

Any input on how to solve this would be appreciated, this is my final effort before switching to vsftpd, something I'd like to avoid. Tell me if you need any screendumps or setupfiles, I am happy to provide you with anything that could help you help me..:)

Could the problem be somwhere else, not the proftpd server? The computers are connected on a local network, and I have also tried this with all IP-based security off. I am mainly using Total Commander and Midnight Commander for copying, but have also tried other software to replicate the problem.

PS.: If you don't have an answer, please don't hesitate to tell me which solution you prefer for syncronizing linux/windows machines, I actually have no need for ftp if I can set up a good alternative sync-process, I used to use Unison, but needed access to easy single-file copying.....

Retrievil

Retrievil_Knievil 11-14-2006 08:49 AM

Lets not blame proftpd - blame the user..:)
 
Update:

Today I discovered that I was barking up the wrong tree. I tried vsftpd yesterday.....no change. Tried NFS today.....same result.

...

Thought about that for a couple of minutes. :confused:

...

Uttered some words I shouldn't repeat, changed the NIC, and was back in business. I regret my own stupidity, and bow down to the magnitude of layer-1 errors....;)

Anyway, learned a lot about configuring/errorchecking ftp and nfs this week...

Cheers,
Retrievil


All times are GMT -5. The time now is 06:13 PM.