LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-20-2021, 04:32 PM   #1
nikoslagios
LQ Newbie
 
Registered: Jul 2021
Posts: 2

Rep: Reputation: Disabled
Problems with WiFi connection in Debian 10 Xfce


Hello there. I am new to the Debian family but I find most things familiar since I come from Ubuntu. I have installed the latest Xfce version which works perfectly except one thing. My WiFi connection isn't always recognized. When I turn on my laptop, sometimes the connection is there. Some other times, it keeps trying to connect itself and eventually fails. I have to restart the laptop to make it work. Any ideas?
 
Old 07-20-2021, 07:51 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,504
Blog Entries: 28

Rep: Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434Reputation: 5434
Two questions:

What is the wireless chipset in this machine? (The command lspci issued in a terminal should reveal that; you may have to issue the command as root.)

When it is there (to quote your post), does the connection actually wconnect?
 
Old 07-21-2021, 12:44 AM   #3
nikoslagios
LQ Newbie
 
Registered: Jul 2021
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you for your reply. My wireless driver is Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (168c:0042). I used the non-free firmware image to install the operating system and afterwards I modified the sources list with the official one. The problem must have started after my first terminal update (sudo apt update, sudo apt upgrade). Before that, my wireless was always recognized. After I have applied all updates, sometimes it is recognized and sometimes not. I have to restart my laptop (occasionally twice) to have wireless working. Maybe installing firmware-atheros_20190114-2_all.deb would help. Thanks.

Last edited by nikoslagios; 07-21-2021 at 01:34 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 20LTS dual boot Laptop Dell Inspiron 5548 I can not turn on wifi and in wifi settings indicates no wifi device was found Shra94 Linux - Hardware 1 05-19-2020 04:22 PM
Wifi option is there but no wifi scanning or wifi not working Aakash447 Linux - Newbie 3 06-28-2018 11:48 PM
file association for wifi internet connection to error "interface down" (ubuntu 4.4.0+xfce dsktp env) win 7 non-genuine grubmember Dun El Linux - Newbie 21 10-13-2016 11:24 AM
Want to share my wifi by creating a wifi hotspot ( While staying connected to wifi)? shadyXV Linux - Desktop 4 07-20-2015 05:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration