LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Problems with Verizon DSL Connection to Internet (https://www.linuxquestions.org/questions/linux-networking-3/problems-with-verizon-dsl-connection-to-internet-249778/)

Roxbury Ranger 11-01-2004 06:40 AM

Problems with Verizon DSL Connection to Internet
 
I'm having some perplexing issues when connecting to the Internet using Verizon DSL in Mandrake 10.0, and I'm not sure why.

I've tried connecting using both DHCP and pppoe. The results are pretty much the same: on initially logging in, I am able to surf the Web for an unspecified period of time before mysteriously I am disconnected.

I have to reboot every time to get connected again, at which point the process starts all over again.

My NIC card (eth0) is connected directly to my Westell modem through a Hub (for a Windows XP home network).

When Linux boots, I usually get a FAILED message for "Bringing up interface eth0"; although, sometimes Linux recognizes the card. Either way, I'm still able to use the Internet for some period of time. Depending on how I set up the Internet connection, I either get a "Network Down" or "Connection Not Configured" message in KDE. Recently, it seems to have settled on "Connection Not Configured".

When I've assigned Primary and Secondary DNS settings in pppoe, I've used the settings that Verizon suggests on its Web site: 4.2.2.1 and 4.2.2.2, respectively. These get changed to other entries (which also vary, suggesting that they're dynamically assigned I guess).

Any help you can provide in diagnosing this would be greatly appreciated. I really want to use Linux for my everyday tasks, and use XP only when I have to.

Thanks.
:confused:

Mara 11-01-2004 01:24 PM

All errors there are should be mentioned in /var/log/messages file (you need to be root to read it). So, when a problem occurs, note down the time and look in the log file (timestamps before all messages). Are there any errors that may be network related? If they are, they may be easy to understand and fix. If not, please post the messages.

Roxbury Ranger 11-01-2004 01:46 PM

Thanks for the help. Right now, I'm at work on an XP box :rolleyes: so I can't check it out.

But when I get home, I'll be sure to do so and get back to the forum.

Thanks.

Roxbury Ranger 11-01-2004 05:21 PM

Hi:

As suggested, I am posting the relevant information from tonight's message file. As usual, I was able to surf the Web - though only for about five minutes this time - before being disconnected.

My settings in the Mandrake Control Center were as follows:

pppoe
Provider: dsl.verizon.net
Primary DNS: 4.2.2.1
Secondary DNS: 4.2.2.2

Interestingly, when I booted into Linux this time, I got an "OK" (as you'll see in the log) for eth0.

Here's the relevant log info:

Nov 1 18:00:20 dsl ifplugd(eth0)[3937]: Program executed successfully.
Nov 1 18:00:20 dsl network: Bringing up interface eth0: succeeded
Nov 1 18:01:00 dsl CROND[4133]: (root) CMD (nice -n 19 run-parts /etc/cron.hourly)
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.24.77.214.167 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.94.2 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.81.84.35.6 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.217.159.171.174 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/cups/error_log from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.177.164 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.18.100 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.62.43.1.210 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.162.35.135 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.162.32 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.82.182.140.96 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.25.128 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.246.213 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.will-ewbnjicoj7 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.44.65 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.104.143 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.39.142 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.217.215.48.236 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.206.28.56.71 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/cups/page_log from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/XFree86.0.log.old from 644 to 640
Nov 1 18:01:01 dsl msec: changed group of /var/log/XFree86.0.log.old from root to adm
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.3.108 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.238.14.123 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /etc/rc.d/init.d/internet from 755 to 744
Nov 1 18:01:01 dsl msec: changed mode of /var/log/wtmp from 664 to 640
Nov 1 18:01:01 dsl msec: changed group of /var/log/wtmp from utmp to adm
Nov 1 18:01:01 dsl msec: changed mode of /var/log/XFree86.0.log from 644 to 640
Nov 1 18:01:01 dsl msec: changed group of /var/log/XFree86.0.log from root to adm
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.18.35.158 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.220.220.119.75 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.143.44 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.23.160.17 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.145.190 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.207.229.189.35 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.156.49 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.200.125.28.15 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.220.144.242.147 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.67.208 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/ksyms.1 from 644 to 640
Nov 1 18:01:01 dsl msec: changed group of /var/log/ksyms.1 from root to adm
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.166.24 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/ksyms.0 from 644 to 640
Nov 1 18:01:01 dsl msec: changed group of /var/log/ksyms.0 from root to adm
Nov 1 18:01:01 dsl msec: changed mode of /var/log/ksyms.3 from 644 to 640
Nov 1 18:01:01 dsl msec: changed group of /var/log/ksyms.3 from root to adm
Nov 1 18:01:01 dsl msec: changed mode of /var/log/ksyms.2 from 644 to 640
Nov 1 18:01:01 dsl msec: changed group of /var/log/ksyms.2 from root to adm
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.65.124.65.59 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.203.73.155.178 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/cups/access_log from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.195.5.158.149 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.21.35 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.182.201 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.70.19.145.95 from 644 to 640
Nov 1 18:01:01 dsl msec: changed mode of /var/log/samba/log.68.239.203.78 from 644 to 640
Nov 1 18:02:58 dsl su(pam_unix)[4208]: session opened for user root by (uid=501)

As I've said earlier, I'm a newbie, so a lot is foreign to me. Is there anything from the log that would indicate the direction I should be looking for a resolution?

This is very frustrating:scratch:

Help me....please...

Mara 11-02-2004 03:48 AM

There's no error here (network going up correctly). The logs are from 18:00 to 18:02. When was the disconnect exactly? Are logs from that time also included?


All times are GMT -5. The time now is 04:33 PM.