LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-29-2016, 06:24 AM   #1
Andi1982
LQ Newbie
 
Registered: Sep 2012
Posts: 4

Rep: Reputation: Disabled
Problems with Post requests only on Linux


Hey there,

I have some strange problem. I got some new mobile phone with Android 5.1 (Cubot X12). I tried to login to some website and I got timeout (or the server responded empty result). I thought ok, maybe chinese phone blocked. Then again I got other Android 5.1 phone (Wiko Pulp 4G) and same Problem there.

So I did the logins on windows and it worked fine. Connected with same wireless!

When I turned off wireless and used mobile data it suddenly worked perfect. On both phones!

Then I had the idea to try same on my ubuntu computers. And on all of them I had same problem. I was able to open the website but login (post request via https) did not work.

I noticed now lot of apps where same problem exists. I am thinking it maybe can be some IPv6 problem. But i really don't understand why.

this is the site where i want to login: https://account.xiaomi.com
I can open the login page and the post request is going to the same host (account.xiaomi.com) where i also requested the login-form. But why it is working when I am on mobile data or on windows, but not with any linux device?

Any hints how i can go on to figure out the reason for this problem? you can try by yourself to login to this page with any login data, if you are on Linux then maybe you will get same problem.

can it be IPv6 problem? Or maybe https?

I would be very thankful for some help...

Andi
 
Old 02-02-2016, 07:47 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,314
Blog Entries: 28

Rep: Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138
I was able to sign up for an account at that site using Seamonkey v. 2.39 on Slackware --Current.

I don't expect I'll ever use the account, but the site worked for me, at least to that extent.

Last edited by frankbell; 02-02-2016 at 07:48 PM.
 
Old 02-03-2016, 02:19 AM   #3
Andi1982
LQ Newbie
 
Registered: Sep 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Also possible to login? Have you been with IPv6 network?
 
Old 03-07-2016, 06:34 AM   #4
Andi1982
LQ Newbie
 
Registered: Sep 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
So some updates:

I was in contact with UnityMedia (ISP). They deactivated Dual Stack lite for me and gave me some normal IPv4 connection and then everything worked fine. So the problem occours only when Dual Stack Lite is enbaled. Now they will send me some new Hardware (but again the Technicolor TC7200 modem). They hope that there is just some problem in my modem at home. I will keep you up to date how it will go on.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Linux v. 6.0.4 - Post Installation Problems ... CoolHipDude Linux - Newbie 6 05-13-2012 03:15 PM
socket header requests problems. some work some do not eagle-bear Programming 1 01-13-2012 10:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration