Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 12-04-2005, 09:39 PM   #1
LQ Newbie
Registered: Dec 2005
Location: Santa Cruz, Ca
Distribution: Slackware Linux 10.2 (Kernel 2.4.31)
Posts: 5

Rep: Reputation: 0
Unhappy Problems with Intel Pro 100, Intel Pro 1000 NIC Drivers

Hello all,
This post is about a problem I'm having with my NIC drivers running under Slackare Linux Version 10.2 (Kernel Version 2.4.31). As far as hardware I'm running an ABIT FATAL1TY AA8XE Motherboard, a 256Mb Nvidia Geforce 6600, 1024Mb PC5400 DDR2, and an Intel P4 3.2 Ghz CPU. After a fresh install of Slackware 10.2 on my system I needed to install drivers for my dual onboard Intel Pro 100/1000 Network adaptors. Using Windows I downloaded the appropriate drivers from the ABIT website: e100-3.0.27.tar.gz and e1000-5.3.19.tar.gz, both of which I then transfered to my Linux Partition and extracted to its own directory. I then followed the installation intructions supplied by Intel starting with the e100 driver because that is the interface which connects to my cable modem, the other connects to my LAN. I managed to bring the e100 up as eth0 and connect to the internet using insmod, modprobe, and ifconfig. Next I installed the e1000 driver and brought it up as eth1. After Setting up my IP configuration this is what I was left with:
Intel Pro 100: Intel Pro 1000:
Device eth0 eth1
IP Type Assigned by DHCP Set by User
IP Address
DNS Servers
Subnet Mask
DHCP Server
MAC Address 00-5D-8D-70-41-4A 00-5D-8D-70-41-4B

At this point my internet and LAN were both up and running, I also was able to start DHCP server on eth1 which I tested using other computers on my network and confirmed to be working. My problem is that when I restart my computer, the network settings aren't properly reset to what they should be. I can get the module loaded using insmod e100, modprobe e100, and ifconfig, but when I try to set the device number using ifconfig it always mounts the Pro1000 at eth0 and it won't let me set the Pro100 as eth0. The only way to restore internet connectivity after restarting seems to be: to remove all the extracted driver files and also the module files installled by the driver at /lib/modules/KERNEL/drivers/net, then reboot the system and redo driver installation first e100 then e1000.
In a nutshell I'm asking two questions the first is the only one that I need so think of the second as more of an; if you have time thing.

Firstly what do I do to save the configuration so that the network adaptors are set to be loaded and brought up at start up with properly assigned settings for their device number(ethX) and settings as shown above (Dynamic for eth0/pro100 and Assigned Settings for eth1/pro1000)?

My other question is in regards to using my system to share its cable internet connection eth0 with the other computers on my LAN which I am connected to with eth1
As I mentioned I was able to start DHCP server and confirm that it was able to assign IPs to other computers on the LAN however none of my other networked systems are able to access the internet, all IPs, Subnets, etc. are applied as defined in my /etc/dhcpd.conf file but no access to the internet. I get the impression that I might not have set the proper subnet, not sure what number I should be using for that. My understanding is that I should be able to share my eth0 Internet connection with my LAN computers using my other network adaptor, eth1. Do I need to install additional software or do I just need to properly configure my existing network and DHCPD?

This question has probably been answered here or somewhere on the internet before so feel free to post a link if you'd like. I have been reading forums now for a while but this is my first post, thanks in advance for your help.
Old 12-05-2005, 01:40 AM   #2
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Not sure about Slackware in particular, but there should be a modules.conf or a modprobe.conf file in /etc. Try adding:

alias eth0 e100
alias eth1 e1000

This should resolve your driver load sequence issue. This is also how I was configuring systems for network testing at the last plae I worked. We used Redhat AS, Fedora Core 4, Suse 9.3, and Mandriva 2005 for testing.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel D845GLLY + Multiple Intel Pro 100 NICs + kernel 2.6.x = NICs don't work egable Linux - Hardware 0 02-04-2005 03:30 PM
Linux net driver for Intel D815EFV integrated mobo (Intel PRO/100 VE) bikermagi Linux - Networking 0 05-07-2002 02:51 PM
Intel Pro 100 VE or EthernetExpress PRO SkYzOpReNiCk Linux - Networking 0 02-26-2001 11:00 PM
Which linux can support Intel PRO 100 VE NIC sojsam Linux - Networking 1 12-22-2000 01:03 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:51 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration