-   Linux - Networking (
-   -   problems with ethernet internet connection and sound on laptop with OS suse 10/ winXP (

elena06 02-06-2006 10:56 AM

problems with ethernet internet connection and sound on laptop with OS suse 10/ winXP
I am not an expert linux user. Recently i bought a laptop Acer Aspire 1694WLMi with preinstalled WindowsXP home edition. There were three partitions on the hard disk, I deleted one and resized another one and I installed on the free disk suse10.
I have the following problems:
no sound is produced and I don't have internet access via ethernet cable.
I want to connect via DHCP to the LAN of my workplace. I can do this under windows but not under linux. More precisely, I was able connect once (after doing manual configuration with YAST) and at that moment the sound server was working.
Then I rebooted the machine I booted windows then rebooted again linux and sound and internet connection didn't work anymore.
Givng the command route -n I can see only the line lo and no rows for eth0.
Giving ifconfig command I can see that no IP adress is given to the card, wich by the way is recognized by the system (like the audio card, AC97 integrated).
Any suggestions?
It seems that DHCP is not working (still at least once it worked).
By the way, I tried with Knoppix and sound and network were Ok.
The configuration settings seem to be correct....

satinet 02-07-2006 04:53 AM

have you run alsaconf for your sound card?

not sure about dhcp on suse. what's the output of (as root) dmesg|egrep -i 'eth0|dhcp'

and 'dmesg|grep -i ac97'.

and 'ps -ef|grep -i dhcp'

elena06 02-07-2006 10:52 AM

I run alsaconf and now I have a sound card configured n addition to the one recognized by the system as AC97 etc...
I cannot configure anymore the last one with YAST and I can't remove the card configured with alsaconf.
Kmix does'n work anymore. When I run alsaconf it tests the sound and I can hear something but I can reproduce audio files just for a very short while. When the system boots no sound.

sorry, I can't connect to the web with the laptop so I'll describe the output.

dmesg|egrep -i 'eth0|dhcp'
gives several rows starting with eth0. The last one says:
eth0: no IPv6 routers present

'dmesg|grep -i ac97'.
intel8xo_measure_ac97_clock 54303 usecs

'ps -ef|grep -i dhcp'
two rows appear one for eth0 and another similar for eth1 (I ignore what eth1 is)
root 4427 1 0 16:38? 00:00:00 /sbin/dhcpcd -C-H-D-K -R-N -t999999 -h linux -c /etc/sysconfig/network/scripts/dhcpcd-hook eth0

thank you

satinet 02-07-2006 03:19 PM

unfortunately i dont know much about SuSE and YAST.

sounds like your dchp daemon is running. and that your sound card is configured with alsaconf. after you run alsaconf you need to run 'alsamixer' then 'alsactl store'. then you will reboot with sound...
try to restart kmix... go to the kde control panel and make sure the sound work...

dont worry about ipv6. ipv4 is what you want.... please show the whole out put of dmesg|egrep -i 'eth0|dhcp'

and "ifconfig"...

elena06 02-08-2006 09:47 AM

Hi, I forced the connection with the comand
/etc/init.d/network (it should be bascally dhclient)
I think it is a temporary solution. Now I can easily post the output
of the commands you suggested me:

# dmesg|egrep -i 'eth0|dhcp'
tg3: eth0: Link is up at 1000 Mbps, full duplex.
tg3: eth0: Flow control is on for TX and on for RX.
eth0: no IPv6 routers present
# ifconfig
eth0 Link encap:Ethernet HWaddr 00:C0:9F:AC:AE:EF
inet addr: Bcast: Mask:
inet6 addr: fe80::2c0:9fff:feac:aeef/64 Scope:Link
RX packets:2345 errors:0 dropped:0 overruns:0 frame:0
TX packets:964 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1042898 (1018.4 Kb) TX bytes:165920 (162.0 Kb)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2056 (2.0 Kb) TX bytes:2056 (2.0 Kb)
ps -ef|grep -i dhcp
root 4609 1 0 14:09 ? 00:00:00 /sbin/dhcpcd -C -H -D -K -R -N -t 999999 -h linux -c /etc/sysconfig/network/scripts/dhcpcd-hook eth0
root 6208 5765 0 15:45 pts/1 00:00:00 grep -i dhcp
#dmesg|grep -i ac97
no output for this today....
# alsamixer
alsamixer: function snd_ctl_open failed for default: No such device

# alsactl store
alsactl: save_state:1163: No soundcards found...
Running Yd.ast I can see two cards, a first one configured and another one, recognized as AC97... not configured.
When I try to do so an error message appears saying that
the kernel modul snd_intel8x0 cannot be loaded (it is used to configure the other sound card and I don't know how to remove this one)
By the way now, even if alsamixer and alsactl on't work I can reproduce audio files! (can't get any is not the first time that when I succed in some way in connecting to the internet the sound works...)

Thanks a lot

All times are GMT -5. The time now is 02:10 AM.