LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-08-2016, 04:12 AM   #1
Aeca
LQ Newbie
 
Registered: May 2016
Location: France
Distribution: Raspbian
Posts: 4

Rep: Reputation: Disabled
Problems setting up Raspberry Pi as a VPN Router


Hi all,

I am really hoping there is someone that can help me here and this is the right place. I have not had any response on Raspberrypi.org's and PIA's forums.

I've been trying to set up a RPi VPN Router according to the guide at https://gist.github.com/superjamie/ac55b6d2c080582a3e64. The idea is to set up a router directly to my Sky box in order to circumvent the country restrictions (I'm in France). I was hoping to plug the ethernet from the SKY box into the RPi and then use the WiFi to hook up with the adsl modem, however I can't seem to get the VPN to start when I start up the RPi (I'm using Raspberry Pi 3).

I get the following error messages when the RPi starts up.
[FAILED] Failed to start OpenVPN connection to London.
See 'systemctl status openvpn@London.service for details.
[FAILED] Failed to start OpenVPN connection to UK.
See 'systemctl status openvpn@UK.service for details.
[FAILED] Failed to start OpenVPN connection to UK\x20London.
See 'systemctl status openvpn@UK\x20London.service for details.


I presume it has to do with that the PIA (PrivateInternetAccess) files in question are with a space in the name (UK London.conf etc). I tried to do everything with ' ' to ensure it would work, but still same problem. What do I do? Could I have missed something?

Also what do I need to make sure that the Ethernet is tunnelled to the WiFi on the RPi? I can't seem to get access to internet through the RPi if I hook my laptop via ethernet to the RPi even though I know the RPi has WiFi internet access to the adsl router. I have tried to do various versions of:
sudo iptables -t nat -A POSTROUTING -o tun0 -j MASQUERADE
sudo iptables -A FORWARD -i tun0 -o eth0 -m state --state RELATED,ESTABLISHED -j ACCEPT
sudo iptables -A FORWARD -i eth0 -o tun0 -j ACCEPT

Shifting around wlan0 and eth0 in the above commands has not helped so I am a bit at a loss.

Any help on this matter would be really appreciated.

Regards,
Henrik

(I am good with computers but I feel like a beginner when it comes to anything Linux related...)

Last edited by Aeca; 05-08-2016 at 04:14 AM.
 
Old 05-08-2016, 05:41 AM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: Fedora
Posts: 4,157

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
Why do you need to us filenames with spaces?
 
Old 05-08-2016, 05:49 AM   #3
Aeca
LQ Newbie
 
Registered: May 2016
Location: France
Distribution: Raspbian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Because the files for the different servers that came with the install files for PrivateInternetAccess had spaces for the UK servers and the US servers. If I needed to hook up to a server in Sweden for example it would be easy. So the server I need to hook up to is designated 'UK London'. I wish they'd use an underscore or something...

Regards,
Henrik
 
Old 06-03-2016, 03:12 PM   #4
Aeca
LQ Newbie
 
Registered: May 2016
Location: France
Distribution: Raspbian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Is there anyone that could help me with this please? I'm a bit lost as there are many confusing solutions to this. Just a point in the right direction would be great.

Henrik
 
Old 06-05-2016, 09:36 AM   #5
slepax
LQ Newbie
 
Registered: Oct 2003
Location: Home
Distribution: Debian
Posts: 3

Rep: Reputation: 0
Why do you think it has anything to do with spaces?

Can you run openvpn to pia from the command line with no error? e.g. openvpn UK\ London.conf

Alternatively you could simply rename the file name to UK_London.conf just to verify if it is an issue with spaces or not.

Run ifconfig and if you are connected to the VPN then you should also see an interface called tun0 (which does the VPN tunneling).
 
Old 06-07-2016, 05:25 AM   #6
Aeca
LQ Newbie
 
Registered: May 2016
Location: France
Distribution: Raspbian
Posts: 4

Original Poster
Rep: Reputation: Disabled
OK, great, thanks guys!

The "space" issue I've sorted just by renaming the .conf file so finally the VPN works. Now I just need the tunnelling SKY Box -> Ethernet cable -> RasperryPi -> WiFi -> router to work. Do I really need to set up hostapd and DCHP on the RaspberryPi to get that to work?

Henrik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection problems to VPN using pptp (ppp0 is down wont go up) no errors. Raspberry Pi, Raspbian, CptNorbert Linux - Networking 3 01-25-2016 09:38 AM
Router... gateway... VPN need some help with setting up a linux router i think.. crehop Linux - Newbie 1 01-12-2016 06:54 PM
LXer: Browse Anonymously with a DIY Raspberry Pi VPN/TOR Router LXer Syndicated Linux News 0 01-30-2015 04:01 PM
IPSec questions setting up to connect to a Linksys VPN router dendon Linux - Networking 2 10-30-2008 07:38 AM
Problems setting up router mheath Linux - Networking 0 12-20-2004 03:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration