-   Linux - Networking (
-   -   Problems mounting Netgear NAS drive with CIFS, NFS. (

Cenobite 07-06-2010 03:59 AM

Problems mounting Netgear NAS drive with CIFS, NFS.
I'm trying to mount a Netgear ReadyNAS drive. Initially I tried CIFS with the following:

mount -t cifs // /mnt/temp -o user=administrator,password=password123,domain=VOLUME

But I get the following error:

mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page ( mount.cifs)

I've gotten the same error when using mount.cifs instead of mount -t cifs.

The username and password are 100% correct, as using

smbclient -L // -U administrator

Successfully authenticates me to the drive. I have tried setting up a credentials file and adding the details to /etc/fstab, as well as enclosing the password in single- and double-quotes.

I then thought about using NFS, but I get the following error:

mount: mount to NFS server '' failed: RPC Error: Program not registered.

rpcinfo gives the following output:

rpcinfo -p
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper

No nfsd or mountd seems to be running on the NAS.

Please help. Any ideas will be greatly appreciated.

Disillusionist 07-07-2010 01:52 AM

Check the following link:

All times are GMT -5. The time now is 03:43 PM.