Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 11-21-2005, 07:57 PM   #1
Registered: Feb 2005
Posts: 42

Rep: Reputation: 15
Problem with DHCP Server.

Hi I have recently built a debian dhcp server for my company. I got everything on it up and running for our DSL customer. But when we cut our wireless customers over to DHCP we ran into some major problems. What I have going on is I have some client radios out there that when they send out a DHCP request to my server they put there mac address at the front of the packet. So when it hits the server the server sees that mac and tries to send the offer back to that mac however the radio with that mac will not accept this. I need my DHCP server to look at the mac address of the device that is actually plugged into these radios. The mac of the device is there because it is what sent out the request. I am using SmartBridges radios and I have searched there website and they have told me that in order fix this problem I need to make my server look at the broadcast message instead of the Unicast message. So from the research that I have done I have found that I need to put this command into my DHCP server "always-broadcast on;" however I have to put this into an if statement or a class declaration or a host declaration. I think that I can build this if statement into my subnet declaration and that will work. However to build the if statement I have been told that I will need to use the "vendor-class-identifier" which I don't really understand how to use and get this information.

OK so now for the real questions here. Can I set an identifier into my if statement for a certain mac address?? The radios that I am using all have 00:0c as the beginning of there mac address. If I can how do I go about doing this. If I can't use the mac address how do I figure out what class-vendor-identifier I want to use?? Also does anyone know of an easier solution to this problem?? If so I would like to hear any thoughts. If you need anymore info from me please let me know and I will do my best to get it to you.


Old 11-22-2005, 02:23 PM   #2
Registered: Feb 2001
Location: South Africa
Distribution: Fedora, Mandriva, PCLOS, SUSE - anything a can get my hands on
Posts: 140

Rep: Reputation: 15
Hmmm, I'm not sure I understand your network setup......

Do you need to give the wireless pc static ip's from the dhcp?
Do they get any ip's at all from the dhcp server?
If they do get a ip, can you ping them?

Maybe you can post your dhcp.conf?
Old 11-22-2005, 06:25 PM   #3
Registered: Feb 2005
Posts: 42

Original Poster
Rep: Reputation: 15
Hi thank you for getting back to me on this. Yes I want the client pc or router to get a public ip address. And no when the server gives out an address the client pc or router does not receive the address. What is happening is that the radio's that I am using have NAT macaddress enabled on them. So when the client pc or router sends out a request to the server the radio that it sends the request over puts it's mac address in front of the request. So when it gets to the server it then reads that mac address and tries to send the offer back to it. However that radio is unable to accept this offer and does not pass it on to the device. So I have been told that i have to put the command of "always-broadcast on" into my dhcpd.conf file. But in order to do so I have to have an if statement or a class or host declaration. Here is my dhcpd.conf file so that you can take a look at it and see what I have.

# Sample configuration file for ISC dhcpd for Debian
# $Id: dhcpd.conf,v 2002/07/10 03:50:33 peloy Exp $
#option definitions common to all supported networks...
#option domain-name "";
#option domain-name-servers 207.171.***.***, 207.171.***.***;

#option subnet-mask 255.255.***.***;
#option vendor-class-identifier; <-- [Here is where I tried to use the identifier but with no such luck. And as you can see below this is where I think it would have to go to work.]
#default-lease-time 172800;
#max-lease-time 172800;

#subnet 207.171.192.*** netmask 255.255.***.*** {
# range 207.171.***.*** 207.171.***.***;
# option routers 207.171.***.***;
# if {
# option vendor-class-identifier (Unique Identifier);
# always-broadcast on;
# range 207.171.***.*** 207.171.***.***;
# }
# else {
# range 207.171.***.*** 207.171.***.***;
# }

I know I have it all edited out but as you can see I have the if else statement in my subnet declaration. I am trying to use the Vendor-class_identifier as a way to identify any of these radios on the network. So if it matches up with the identifier I want to have always-broadcast on and I want it to pull from this range. However if it does not match this then go ahead and pull from this range.

So what I am having trouble with here is I could not get the option vendor-class-identifier to work in my config. I tried putting it up at the beginning of the dhcpd.conf file and in the subnet declaration but it would not work. Once I find a unique identity for all of those radio's I think that this statement should work. Am I wrong?? If you need anything else please let me know.

Thank You



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gateway / DHCP Server problem on Slackware captain_bogus Linux - Networking 11 11-25-2008 01:28 PM
problem with dhcp server version 2.0p15 of Snapgear maryam Linux - Networking 0 09-08-2005 10:40 AM
problem with dhcp server egyptian Linux - Networking 4 10-24-2004 02:56 AM
DHCP Server Problem bally Linux - General 1 11-10-2003 11:30 AM
DHCP server config problem Q25 Linux - Networking 2 07-18-2003 07:58 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:40 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration