LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-17-2001, 01:02 PM   #1
N1HNJ
LQ Newbie
 
Registered: Apr 2001
Posts: 16

Rep: Reputation: 0

I'm using a box with Linux and pmfirewall-1.1.4 to configure IP-Masquerade between my @home cable connection and four computers here at home (two boxes running Linux, one with Win2k, and a laptop with Win98SE). At the moment they are only using the switched hub to access the Internet via the gateway box. (Setting up access between computers will come later.)

Each of the machines can access the Internet via the pmfirewalled gateway with web browsers and ftp clients just fine. I can ping the @home gateway and the machines within the LAN. But none of the email clients on any of the machines can retrieve or send mail with the @home servers, but the pmfirewalled gateway can.

Now, with @home the incoming and outgoing servers are identified simply as "mail" and I've already figured out what the qualified domain name is. But, when I use that I get a message from the clients that the server terminated the connection unexpectedly.

Any ideas what I need to do to remedy this?
 
Old 04-22-2001, 12:50 AM   #2
N1HNJ
LQ Newbie
 
Registered: Apr 2001
Posts: 16

Original Poster
Rep: Reputation: 0
Bump.

No ideas?
 
Old 04-24-2001, 08:55 PM   #3
N1HNJ
LQ Newbie
 
Registered: Apr 2001
Posts: 16

Original Poster
Rep: Reputation: 0
Bump.

While testing fetchmail, I noticed the domain name was different and that the domain itself was the same as assigned to the IP-Masq'ing box via DHCP.

On a hunch, I appended the servername, "mail," with the domain I saw and the email clients can send and receive fine. On that same hunch, I went into netconf on the main Linux box and entered the domain into the default search domain in the DNS section and changed the POP and SMTP server names back to, "mail." That worked, too.

Well, it took a few days to figure it out. But I did.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with PMFirewall Elbryan Linux - Software 35 09-24-2005 06:21 AM
LQ email problem j0ck LQ Suggestions & Feedback 2 09-04-2003 07:34 PM
Problem receiving email from email server sharon Linux - Newbie 3 07-11-2003 03:57 AM
Email Problem WeNdeL Linux - Networking 1 01-21-2003 06:48 AM
PMFIREWALL and VPN brain1214 Linux - Networking 1 04-24-2001 08:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration