LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-27-2007, 10:16 AM   #1
gonphsn1
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
problem creating default ipv6 gateway on fc6


Hey folks,
I'm doing some feasibility research on IPv6 and I've run into a problem while
attempting to set up an IPv6/IPv4 network that includes a FC6 machine. It appears
to me to be some sort of kernel incompatibility issue, yet I know that the 2.6.18 kernel is IPv6 compliant...

Here's the setup

Fedora Core Release 6 (Zod)
Kernel 2.6.18-1.2798.fc6 on an i686
Pentium II (Deschutes)

/etc/sysconfig/network:
NETWORKING=yes
NETWORKING_IPV6=yes
HOSTNAME=xxxxxxx.xxxxxx
IPV6_DEFAULTGW=12::1%eth0


/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:10:4B:1F:77:2C
IPV6INIT=yes
IPV6ADDR=12::2/126
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
IPADDR=193.168.0.2
GATEWAY=193.168.0.1
NETWORK=193.168.0.0
NETMASK=255.255.255.0

With this configuration, restarting the networking service results in the following:

service network restart

....
....
Bringing up interface eth0: WARN [ipv6_add_route] Unknown error.

Investigating the network-function-ipv6 file shows that the operation fails at the point where it is adding the default route for this interface, i.e. ip -6 route.

The command is:

ip -6 route add ::/0 via 12::1 dev eth0 metric 1

Manually entering this at the command line results in the following error:

RTNETLINK answers: Invalid argument

I have also tried adding the route using the route command, the corresponding command is:

route -A inet6 add ::/0 gw 12::1 dev eth0 metric 1

Manually entering this at the command line results in the following error:

SIOCADDRT: Invalid argument


route version: net-tools 1.60 route 1.98 (2001-04-15)
ip version: ip utility, iproute2-ss060323

What's the deal? I can ping6 between adjacent nodes in my network but I can't set up any routing tables! Any help would be great, thanks.

Last edited by gonphsn1; 07-27-2007 at 10:18 AM.
 
Old 07-30-2007, 08:33 AM   #2
gonphsn1
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Original Poster
Rep: Reputation: 0
bump.

So no one has any idea? Bummer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely no sound on Sigmatel / Intel FC6 Gateway steveywonderboy Linux - Newbie 14 08-26-2007 08:14 PM
FC6 Sendmail Gateway SmartHost to Exchange Funkester Linux - Software 1 01-15-2007 11:23 PM
IPv6 by default? alewis Linux - Networking 5 04-07-2006 11:06 PM
default gateway problem with ndiswrapper and broadcom card gh05t Linux - Wireless Networking 1 02-01-2006 04:03 PM
Problem pinging default gateway robeb Linux - Networking 6 01-30-2003 01:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration