LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-16-2004, 06:03 AM   #1
Nik0s
Member
 
Registered: Jan 2004
Location: Thessaloniki
Distribution: Fedora Core 1
Posts: 41

Rep: Reputation: 15
Problem conncetin to the net with wvdial!


With jppp i connect to the net just fine me wvdial connection drops every 1 sec.. why?

I tried at /etc/ppp/options these
lcp-echo-interval 0
lcp-echo-failure 0

but no good why?

Here is the log....

wvdial output!
--> Starting pppd at Wed Jul 7 20:01:36 2004
--> pid of pppd: 6248
--> Disconnecting at Wed Jul 7 20:01:39 2004
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man
pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Initializing modem.
--> Sending: ATZ


[root@localhost root]# tail -f /var/log/messages
Jul 7 19:57:14 localhost last message repeated 2 times
Jul 7 20:01:36 localhost kernel: CSLIP: code copyright 1989 Regents of the
University of California
Jul 7 20:01:36 localhost kernel: PPP generic driver version 2.4.2
Jul 7 20:01:36 localhost pppd[6248]: pppd 2.4.1 started by root, uid 0
Jul 7 20:01:37 localhost pppd[6248]: Using interface ppp0
Jul 7 20:01:37 localhost pppd[6248]: Connect: ppp0 <--> /dev/ttyACM0
Jul 7 20:01:39 localhost pppd[6248]: Hangup (SIGHUP)
Jul 7 20:01:39 localhost pppd[6248]: Modem hangup
Jul 7 20:01:39 localhost pppd[6248]: Connection terminated.
Jul 7 20:01:39 localhost pppd[6248]: Exit.
 
Old 07-16-2004, 07:16 AM   #2
newpenguin
Member
 
Registered: Sep 2002
Location: lahore pakistan
Distribution: slackware,redhat, FreeBSD,openbsd
Posts: 219

Rep: Reputation: 30
in /etc/ppp/options

also add

"lock"
 
Old 07-16-2004, 07:25 AM   #3
Nik0s
Member
 
Registered: Jan 2004
Location: Thessaloniki
Distribution: Fedora Core 1
Posts: 41

Original Poster
Rep: Reputation: 15
What these options mean anyway?!?!

lcp-echo-interval 0
lcp-echo-failure 0
lock
 
Old 07-16-2004, 08:16 AM   #4
newpenguin
Member
 
Registered: Sep 2002
Location: lahore pakistan
Distribution: slackware,redhat, FreeBSD,openbsd
Posts: 219

Rep: Reputation: 30
lock
will make sure no other process can now use that device.

for lcp options see man pppd

but ur lcp settings arent nice

set it to

lcp-echo-interval 30
lcp-echo-failure 4

or remove them.
 
Old 07-16-2004, 08:24 AM   #5
Nik0s
Member
 
Registered: Jan 2004
Location: Thessaloniki
Distribution: Fedora Core 1
Posts: 41

Original Poster
Rep: Reputation: 15
if i remove them or if i set them to 30 and 4 asa you say i still ahve the sae problem.

damn why?
 
Old 07-16-2004, 09:04 AM   #6
newpenguin
Member
 
Registered: Sep 2002
Location: lahore pakistan
Distribution: slackware,redhat, FreeBSD,openbsd
Posts: 219

Rep: Reputation: 30
write

Stupid Mode = 1

in your /etc/wvdial.conf

because wvdial waits for telnet type login prompt, when this is specified it starts ppp automatically.

remove username and password from /etc/wvdial.conf.
add username password in

/etc/ppp/pap-secrets

like

username * password

and remove /etc/ppp/chap-secrets if it exists.

hope this will work.
 
Old 07-18-2004, 04:10 AM   #7
Nik0s
Member
 
Registered: Jan 2004
Location: Thessaloniki
Distribution: Fedora Core 1
Posts: 41

Original Poster
Rep: Reputation: 15
Gues what ti worked! Althou to understand it i then put back my original wvdial.conf without the stupid mode =1 and with the user and pass and still worked. I even removes options file and still worked!

But how did it work? So alll we have to do was

add username password in

/etc/ppp/pap-secrets

like

username * password

and remove /etc/ppp/chap-secrets?

What if i remove pp-secrets as well?

Do yout hink it will still work?

Please explain to me in detail your mehod and what the problem was nad what the use of its file....

I must undesrand what happened. Thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wvdial problem tompouceuh Linux - Networking 4 11-27-2005 03:37 AM
wvdial Problem... thmonkey Linux - Networking 5 05-17-2005 12:27 PM
wvdial problem Nik0s Linux - Newbie 5 02-04-2004 02:55 PM
WvDial Problem Nauseous Linux - Networking 5 04-08-2003 01:13 AM
Problem with wvdial telex4 Linux - Networking 3 11-04-2002 03:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration