LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-10-2017, 05:53 AM   #1
GEMarsh
LQ Newbie
 
Registered: Apr 2017
Location: Penticton, BC, Canada
Posts: 7

Rep: Reputation: Disabled
Private Server unreachable from Workstation



I have been developing a website on my private server with laptop workstation access through the router. I had access to the server with PuTTY and, with the browser, Webmin and the website.

Then, since last week, I know not why, attempts to access the server with:
  • PuTTY generates the error msg
    "Network error: Connection timed out."
  • Browser generates the error msg
    "This site canít be reached
    192.168.0.13 took too long to respond.
    Search Google for 192 168 10000
    ERR_CONNECTION_TIMED_OUT"
terminal command nmap used to generate:
PORT STATE SERVICE
22/tcp open ssh
80/tcp open http
10000/tcp open snet-sensor-mgmt
Now, nmap generates:
Starting Nmap 7.01 (...) at ....
Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
Nmap done: 1 IP address (0 hosts up) scanned in 0.52 seconds
iptables lists:
targets="ACCEPT", sources and destinations="anywhere" for:
tcp dpt:ssh
udp dpt:ssh
tcp dpt:http
tcp dpt:https
tcp dpt:ssh /* 'dapp_OpenSSH' */
tcp dpt:http /* dapp_Apache' */
tcp dpt:webmin
tcp dpt:10000
which I think is good???

Ok. I'm now well beyond my very limited understanding of Linux and server networking, but I'm suspecting that ports 22, 80 and 10000 are down for 192.168.0.13??

Can anyone suggest what I need to do, to restore my workstation access to the server??

Thank you, in advance . . .
 
Old 04-10-2017, 01:27 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,462

Rep: Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829
Welcome to LinuxQuestions.

What distribution is running on your server?

I assume that laptop networking is functioning and that you can access the internet?

Are you running nmap on the server or your laptop?

Can you verify on the server itself whether or not ssh is running?

Can you verify that networking on the server itself is working by pinging google.com?
 
Old 04-10-2017, 04:40 PM   #3
GEMarsh
LQ Newbie
 
Registered: Apr 2017
Location: Penticton, BC, Canada
Posts: 7

Original Poster
Rep: Reputation: Disabled
Hi Michaelk;
Thank you for the prompt response.
  1. Server Distribution:
    Linux version 4.4.0-72-generic (buildd@lcy01-17) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu~16.04.4) ) #930UbuntuSMP Fri Mar 31 14:07:41 UTC 2017
  2. Laptop is functioning and connects to internet.
  3. Nmap is running on server. Server is unreachable from laptop.
  4. I don't know whether SSH is running. How do I determine that?
  5. Although the internet is unable to access the server, the server does ping google.com.
Gary
 
Old 04-10-2017, 04:50 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,462

Rep: Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829
Is the server using a static IP address or reserved address from the router or I have no idea?

At a top level your LAN looks ok. What was the exact nmap command used?

Post the output of the command
ip a

To verify ssh is running.
sudo systemctl status sshd
 
Old 04-10-2017, 05:28 PM   #5
GEMarsh
LQ Newbie
 
Registered: Apr 2017
Location: Penticton, BC, Canada
Posts: 7

Original Poster
Rep: Reputation: Disabled
  1. Static IP or reserved address ... not that I am aware of ... I have no idea
  2. Exact nmap command:
    nmap -PO -p 22,80,10000 192.168.0.13
  3. ip a
    1. lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      inet 127.0.0.1/B scope host lo
      valid_lft forever preferred_lft forever
      inet6 ::1/128 scope host
      valid_lft forever preferred_lft forever
    2. eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> MTU 1500 qdisc pfifo_fast state UP group default qlen 1000
      link/ether 6c:0b:84:dd:ac:14 brd ff:ff:ff:ff:ff:ff
      inet 192.168.0.11/24 brd 192.168.0.255 scope global eno1
      valid_lft forever preferred_lft forever
      inet6 fd00:a84e:3f45:3b52:6e0b:84ff:fedd:ac14/64 scope global mngtmpaddr dynamic
      valid_lft 535427sec preferred_lft 401570sec
      inet6 fe80::6e0b:84ff:fedd:ac14/64 scope link
      valid_lft forever preferred_lft forever
  4. systemcti: command not found
 
Old 04-10-2017, 05:32 PM   #6
GEMarsh
LQ Newbie
 
Registered: Apr 2017
Location: Penticton, BC, Canada
Posts: 7

Original Poster
Rep: Reputation: Disabled
Just realized it is systemctl ... not systemcti
looking at output now
 
Old 04-10-2017, 05:39 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,462

Rep: Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829
Code:
inet 192.168.0.11/24 brd 192.168.0.255 scope global eno1
Your IP address is no longer 192.168.0.13. If you do not know how your system is configured then by default it is using DHCP which means your router is assigning a dynamic IP address. Most of the time a device will automatically acquire the same address as before but it is not guaranteed .

You can either configure your router to automatically assign the server the same address or configure the server to use a static IP address. The later might be slightly easier if you have never messed with the router.
 
Old 04-10-2017, 05:48 PM   #8
GEMarsh
LQ Newbie
 
Registered: Apr 2017
Location: Penticton, BC, Canada
Posts: 7

Original Poster
Rep: Reputation: Disabled
systemctl status sshd command:
ssh.service - OpenBSD Secure Shell server
Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2017-04-10 13:35:19 PDT; 58min ago
Main PID: 1233 (sshd)
Tasks: 1
Memory: 2.4M
CPU: 4ms
CGroup: /system.slice/ssb.service
-1233 /usr/sbin/sshd -D

Apr 10 13:35:18 ubuntuserver systemd[1]: Starting OpenBSD Secure Shell server...
Apr 10 13:35:19 ubuntuserver sshd[1233]: Server listening on 0.0.0.0 port 22.
Apr 10 13:35:19 ubuntuserver sshd[1233]: Server listening on :: port 22.
Apr 10 13:35:19 ubuntuserver systemd[1]: Started OpenBSD Secure Shell server.
 
Old 04-10-2017, 06:31 PM   #9
GEMarsh
LQ Newbie
 
Registered: Apr 2017
Location: Penticton, BC, Canada
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by michaelk View Post
Code:
inet 192.168.0.11/24 brd 192.168.0.255 scope global eno1
Your IP address is no longer 192.168.0.13. If you do not know how your system is configured then by default it is using DHCP which means your router is assigning a dynamic IP address. Most of the time a device will automatically acquire the same address as before but it is not guaranteed .

You can either configure your router to automatically assign the server the same address or configure the server to use a static IP address. The later might be slightly easier if you have never messed with the router.
Thank you for the quick analysis.

I would like to keep the 192.168.0.13 for now, which I think means that I need to configure the router to reserve IP address 192.168.0.13. Is that correct? If so, then are there also server settings that need to be changed?

Gary
 
Old 04-10-2017, 07:32 PM   #10
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,462

Rep: Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829Reputation: 5829
Nope, that is it.
 
Old 04-12-2017, 06:23 AM   #11
GEMarsh
LQ Newbie
 
Registered: Apr 2017
Location: Penticton, BC, Canada
Posts: 7

Original Poster
Rep: Reputation: Disabled
Hi Michaelk;

It turned out to be a couple of problems

The obvious one that you identified to be the router automatically changing the IP address. I configured the router to reserve the IP address but that didn't immediately solve the server access problem ...

And, a not so obvious one that, unfortunately, was the cable plugged into a dead router port. It took quite awhile but when, in desperation, I plugged the cable into a different router port, the workstation accessed the server and the problem was solved ... who would have thought?

You, very quickly, put me onto the track that solved this problem. Thank You

Gary
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables - Reply Forwarding Error / Destination unreachable (Host unreachable) keflex87 Linux - Networking 1 05-12-2015 01:03 AM
[SOLVED] Snort Signature: ICMP Destination Unreachable Port Unreachable very noisy mhollis Linux - Security 4 08-15-2011 03:01 PM
Server Becomes Unreachable carlosinfl Linux - Server 1 12-09-2009 03:15 PM
server unreachable... pimij Linux - Networking 4 09-29-2005 07:34 AM
Server unreachable flash71 Linux - Networking 0 10-01-2001 01:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration