-   Linux - Networking (
-   -   Printing to cups on Ubuntu from Mac (

peverell 09-22-2011 06:59 PM

Printing to cups on Ubuntu from Mac
I am having trouble with print from my macbook.
It has worked before but after moving house/network I am having problems.

Here is what I have done:
Printer setup with cups ubuntu desktop computer name 'hal' (

web interface on http://hal:631 works fine and can print a test page

adding a printer with ipp protocol on macbook with address 'hal' says "valid and complete address"

using driver 'hp psc 2100 series' which has worked before and the printer is an hp psc 2100.

Printer appears in the mac 'Print & Fax' dialog as 'Idle'

I send a document to the printer and it always ends up paused and no amount of 'resuming' will help.

The mac 'printers.conf' is as follows after attempting to print:
# Printer configuration file for CUPS v1.4.7
# Written by cupsd on 2011-09-23 10:33
<Printer hal>
Info hal
MakeModel hp psc 2100 series
DeviceURI ipp://hal/
State Stopped
StateMessage Destination printer does not exist!
StateTime 1316730789
Reason paused
Type 75534348
Product (PSC 2100 Series)
Filter application/vnd.cups-raw 0 -
Filter application/pdf 100 /Library/Printers/hp/cups/Inkjet6.driver/Contents/MacOS/Inkjet6
Filter application/vnd.cups-command 100 /Library/Printers/hp/cups/filters/commandtohp.filter/Contents/MacOS/commandtohp
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer

The tail of the cups error_log on the mac is as follows:
D [23/Sep/2011:10:33:09 +1200] [Job 2] max resident size: 30208000
D [23/Sep/2011:10:33:09 +1200] [Job 2] shared memory size: 0
D [23/Sep/2011:10:33:09 +1200] [Job 2] unshared data size: 0
D [23/Sep/2011:10:33:09 +1200] [Job 2] unshared stack size: 0
D [23/Sep/2011:10:33:09 +1200] [Job 2] page reclaims : 7917
D [23/Sep/2011:10:33:09 +1200] [Job 2] page faults : 129
D [23/Sep/2011:10:33:09 +1200] [Job 2] swaps : 0
D [23/Sep/2011:10:33:09 +1200] [Job 2] block inputs count: 1
D [23/Sep/2011:10:33:09 +1200] [Job 2] block outputs count: 2
D [23/Sep/2011:10:33:09 +1200] [Job 2] messages sent: 25
D [23/Sep/2011:10:33:09 +1200] [Job 2] messages received: 13
D [23/Sep/2011:10:33:09 +1200] [Job 2] signals received: 1
D [23/Sep/2011:10:33:09 +1200] [Job 2] voluntary switches: 5972
D [23/Sep/2011:10:33:09 +1200] [Job 2] preempted switches: 24282
D [23/Sep/2011:10:33:09 +1200] [Job 2] 1 files to send in job...
D [23/Sep/2011:10:33:09 +1200] [Job 2] STATE: +connecting-to-device
D [23/Sep/2011:10:33:09 +1200] [Job 2] Connecting to hal:631
D [23/Sep/2011:10:33:09 +1200] [Job 2] Connecting to printer...
D [23/Sep/2011:10:33:09 +1200] [Job 2] Set job-printer-state-message to "Connecting to printer...", current level=INFO
D [23/Sep/2011:10:33:09 +1200] [Job 2] STATE: -connecting-to-device
D [23/Sep/2011:10:33:09 +1200] [Job 2] Connected to printer...
D [23/Sep/2011:10:33:09 +1200] [Job 2] Set job-printer-state-message to "Connected to printer...", current level=INFO
D [23/Sep/2011:10:33:09 +1200] [Job 2] Connected to (IPv4)...
D [23/Sep/2011:10:33:09 +1200] [Job 2] Getting supported attributes...
D [23/Sep/2011:10:33:09 +1200] [Job 2] Set job-printer-state-message to "Destination printer does not exist!", current level=ERROR
D [23/Sep/2011:10:33:09 +1200] [Job 2] Backend returned status 4 (stop printer)
D [23/Sep/2011:10:33:09 +1200] [Job 2] Printer stopped due to backend errors; please consult the error_log file for details.
D [23/Sep/2011:10:33:09 +1200] [Job 2] End of messages
D [23/Sep/2011:10:33:09 +1200] [Job 2] printer-state=5(stopped)
D [23/Sep/2011:10:33:09 +1200] [Job 2] printer-state-message="Destination printer does not exist!"
D [23/Sep/2011:10:33:09 +1200] [Job 2] printer-state-reasons=paused

There is nothing new in the error_log or the access_log on the desktop 'server'

Thanks for any suggestions

claudelepoisson 09-24-2011 11:22 AM

One day I found this command:

[on_your_mac]$ cupsctl BrowseRemoteProtocols=cups
which tells zeroconf utilities to allow browsing and detecting remote printers.
source :
I run it again any time network printing stops working.

peverell 09-24-2011 08:59 PM

Thanks for suggestion.

However it made no difference.


All times are GMT -5. The time now is 06:21 AM.