LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-03-2004, 07:00 AM   #1
paranoidpenguin
LQ Newbie
 
Registered: Jun 2004
Location: London
Distribution: Mandrake 10.0
Posts: 14

Rep: Reputation: 0
Unhappy PPTP Client - LCP ConfReq Time-Out???


I am fairly new to Lniux though have been dabbling for a while now on and off. I am trying to setup a server at my home (since this is where I work from). I have setup Samba, Sendmail etc without too much problems. I am however trying to connect to my works PPTP server (Windows 2000 Server) and I keep on getting the following error?

sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x38c7fb34> <pcomp> <acomp>]

I have looked through the Diagnosis page on pptpclient.sourceforge.net and it says something about GRE packets??? :s

I'm running Mandrake 10.0, kernel 2.6.3, all patches for MPPE have been done to both the kernel and ppp 2.4.3... Still no joy though.

I have tried it on another pc and it manages to connect but doesn't seem to pass any network traffic?

Any ideas please?

---------
Daniel
 
Old 06-03-2004, 07:18 AM   #2
paranoidpenguin
LQ Newbie
 
Registered: Jun 2004
Location: London
Distribution: Mandrake 10.0
Posts: 14

Original Poster
Rep: Reputation: 0
Re: PPTP Client - LCP ConfReq Time-Out???

Ah ha!, ok, got it to connect now so all is good on that front:

Still having the routing problem though?

The client is connected to the Windows 2000 server (192.168.0.66) with the client IP of 192.168.0.244. I cannot however ping 192.168.0.66 or any other machine on the remote network however I can ping 192.168.0.66.

On the server side I cannot ping the client (x.244).

route print from the client show the following:-

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.66 * 255.255.255.255 UH 0 0 0 ppp0
10.0.0.0 * 255.255.255.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 10.0.0.254 0.0.0.0 UG 0 0 0 eth0

The lan settings for the client PC are 10.0.0.111/255.255.255.0 with a gateway (router) address of 10.0.0.254...

Any help would be greatly appreciated cos i'm going out of my head lol (static routes maybe? :s)


Thanks

Daniel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pptp client corruption jyao02459 Linux - Software 0 11-18-2005 12:12 PM
PPTP Client fayax Linux - Software 0 11-09-2005 01:57 PM
Looking for a KDE PPTP client netsoul Linux - Networking 1 03-28-2005 06:25 AM
pptp client error aurelio26 Linux - Newbie 1 02-08-2005 03:07 PM
pptp client KeithKessler Linux - Networking 0 05-04-2003 09:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration