LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-02-2004, 10:19 PM   #1
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Rep: Reputation: 15
pppoe problem


Hi, I use red hat 9.0 and ADSL to connect into internet, this is my problem:

when I start connection, and use adsl-start command , it shows me following messages:

Note: You have enable demand-connection:adsl-status maybe inaccurate.
adsl-status:Link is up and running on interface ppp0.
inet addr:10.10.100.172 p-t-p:24.24.24.24
mask 255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTI CAST MTU:1492 Metric:1
RX packets:33 errors:0 dropped:0 overruns:0 frume:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueue len:3
RX bytes:2155(2.1kb) TX bytes:54(54.0b)

Hope someone would be so kind to help me solve it! Thanks much in advance!
 
Old 06-02-2004, 10:36 PM   #2
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
Are those IP addresses you gave real? If so, I don't think that you have actually set the connection up properly.

It looks like you are using the Roaring Penguin pppoe package. This is really simple to configure - you are prompted for all the information required. To do (or check) the configuration, you need to run: adsl-setup
 
Old 06-02-2004, 10:58 PM   #3
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Original Poster
Rep: Reputation: 15
thank you for your answering
I give the real IP address,because of ADSL,I didn't set IP address
I'm sorry I can't understand clearly about the configuration you've said.can you say it spicific?
I don't know which version pppoe package I use, but I'm sure I've have done : adsl-setup!

thanks again for any help you give!
 
Old 06-03-2004, 12:09 AM   #4
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
To explain:

To configure rp-pppoe (which I think you have), at the command prompt, type: adsl-setup

The configuration programme will ask you a set of questions about your user name, password, the Ethernet interface you are using (probably eth1 or eth0) and whether you want to connect on demand.

* If you want to connect on demand (rather than having the connection running all the time), you will be asked for a time-out value
* You may be asked for the addresses of DNS servers - you should have been given these by your ISP.

Once you have answered your questions and have saved the configuration, run adsl-start.

You may see a similar message to the one you had before, but with legitimate IP addresses! If you do not see the message, you can make it display by doing: adsl-status

Once you have done this, try pinging an address that you know should work, such as your ISP's DNS server. If the ping comes back OK, you are up and running!

You can find more information about rp-pppoe on this page: <http://www.roaringpenguin.com/products/rp-pppoe/>
 
Old 06-03-2004, 01:20 AM   #5
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Thanks so much for your advice. I'll try it again.
 
Old 06-03-2004, 10:53 AM   #6
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Original Poster
Rep: Reputation: 15
'm sad to say that it dosen't work.
But I find a very strange fact: that every time I re-install the rp-pppoe, although the NOTE:
Quote:
Note: You have enable demand-connection:adsl-status maybe inaccurate.
adsl-status:Link is up and running on interface ppp0.
inet addr:10.10.100.172 p-t-p:24.24.24.24
mask 255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTI CAST MTU:1492 Metric:1
RX packets:33 errors:0 dropped:0 overruns:0 frume:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueue len:3
RX bytes:2155(2.1kb) TX bytes:54(54.0b)
is the same, but I can connect to internet!!!! Look, I'm using Linux pppoe communication with you!! I met this before. and I still don't know what to do!

Is there anyone could help me with this problem?thanks in advance!
 
Old 06-03-2004, 06:14 PM   #7
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
Is this actually causing you a problem? If you've got a connection, I'd say not.

The message is actually a warning, rather than an error:
"Note: You have enable demand-connection:adsl-status maybe inaccurate."

The rest of the message is just the output of adsl-status.

Now, the 10.10.x.y IP address is, as far as I know, not an address on the public Internet which is why I queried it in the beginning. (I have just checked it and it is an IANA reserved address.) So, either you are getting the wrong information through adsl-status OR your ISP is doing something really weird and using reserved addresses on their clients and is performing some sort of masquerading upstream. Anything is possible in an infinite universe ;-)

May I suggest that you try:

ifconfig ppp0

This may give you exactly the same message (without the "Note: You have..." line), but may give something different. If it is the same, you may want to ask if they are using reserved addresses and possibly why...
 
Old 06-03-2004, 10:19 PM   #8
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Original Poster
Rep: Reputation: 15
thanks first.

I do the ifconfig eth0, this is the output
Quote:
eth0 Link encap:Ethernet HWaddr 00:20:ED:9F:A9:F1
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:202 errors:0 dropped:0 overruns:0 frame:0
TX packets:247 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:130794 (127.7 Kb) TX bytes:39154 (38.2 Kb)
Interrupt:16 Base address:0x9000
Because I'm newbie for Linux , all I do is to follow the instruction, I haven't set the DNS because the instruction says ADSL is dynamic IP, so fill in "server" just enough. I don't know if my ISP used reserved addresses, and I still don't know how to sovle this problem

PS: now I use Linux surf, It's unbelieveable ha? I wonder how long it can last?

anyway,thanks
 
Old 06-03-2004, 10:36 PM   #9
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
That's your eth0 port. Even if the ADSL modem is on that port, ifconfig ppp0 will give you information about the addresses that you've been allocated. (If you run ifconfig without arguments, you will see the status of all your interfaces.)

So, what is your exact problem? You can connect to the Internet, but what can't you do?
 
Old 06-03-2004, 11:31 PM   #10
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
perhaps your ISP is assiging a private address. As you are able to use the internet, you may bebehind some proxy/NAT server.

What is the output of netstat -nr?

Do a traceroute to, say, yahoo.com and check what is the first registered / public address you encounter. That may be your proxy/NAT server/router.
 
Old 06-04-2004, 07:20 AM   #11
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by kbcnetau
So, what is your exact problem? You can connect to the Internet, but what can't you do?
My problem is, it's very unstable!! Now, I can't use linux surf, and I don't know why? I do nothing but reinstall pppoe yesterday,then I can use it, but a day later, I can't!!

I'm amazing about it! Now I use XP, but I still wanna use linux! Can you help me again to the problem? What arguments I can give you to make it more clear? Thank you!
 
Old 06-04-2004, 07:21 AM   #12
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by ppuru
perhaps your ISP is assiging a private address. As you are able to use the internet, you may bebehind some proxy/NAT server.

What is the output of netstat -nr?

Do a traceroute to, say, yahoo.com and check what is the first registered / public address you encounter. That may be your proxy/NAT server/router.
I'd like to try! But would you make it more clear? Forgive me, I'm really a newbie for linux. Thanks anyway!
 
Old 06-05-2004, 02:00 AM   #13
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
Can you post the contents of your pppoe configuration file: /etc/ppp/pppoe.conf? [Please change your user name before posting for your security!]

I'll compare your configuration to mine and see if I can see anything.
 
Old 06-05-2004, 07:26 AM   #14
morrisset
LQ Newbie
 
Registered: May 2004
Posts: 23

Original Poster
Rep: Reputation: 15
Hi, kbcnetau!
Thank you so much for your kind and patient help.
Yesterday, I happen to meet someone ask for the same question, and he solve the problem by changing rp-pppoe version!!! Whether his wrong or right I have no idea, but I try it immediatly. Now I use rp-pppoe-3.5 version, everything is OK

Yet, I don't know if it could really solve this problem, I'll check it. If it works, I think it maybe a rp-pppoe's bug, and I hope this message could be help for somebody who need.

Again, thanks kbcnetau,you're my first friend in this forum
 
Old 06-05-2004, 05:39 PM   #15
kbcnetau
Member
 
Registered: Dec 2003
Location: South Australia (ex-Devon, UK)
Distribution: SuSE, Slackware, Fedora, Debian, Knoppix
Posts: 141

Rep: Reputation: 15
Most welcome - hope it all works well for you :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PPPoE problem. hmtbooster Slackware 1 11-21-2005 04:23 PM
PPPoE problem satimis Linux From Scratch 2 09-04-2005 10:02 PM
PPPoE Serious Problem Fordor Linux - Networking 0 07-14-2005 02:31 AM
samba through pppoe problem gottin Linux - Networking 3 07-13-2004 01:42 AM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration