LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-04-2004, 09:47 PM   #16
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,105

Rep: Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381

Ok, can you post the output of ifconfig?

What are the messages when you try to ping the router?

Are the link lights illuminated on the NIC and router?
When you ping do the lights blink on the router or the NIC?

Monch,
I think the D-Link uses 192.168.0.1 for its router address. Also post the output of ifconfig.
 
Old 05-04-2004, 10:19 PM   #17
Monch
LQ Newbie
 
Registered: May 2004
Location: Philly
Distribution: Slack 9.1
Posts: 3

Rep: Reputation: 0
I'm sorry, I'll have to stop doing this for today... Please keep reading this thread, I'll post again in about 20 hrs...
 
Old 05-04-2004, 11:23 PM   #18
lamine
LQ Newbie
 
Registered: May 2004
Distribution: Slackware
Posts: 10

Original Poster
Rep: Reputation: 0
The port links on the router are still misteriously off
the NIC light is yellow, I believe there should be a green light in there, well I don't have it yet.
When I try to ping the router I get
Destination Host Unreachable
My ifconfig output:
eth0 Link encap:Ethernet HWaddr 00:08:C7:8F:B3:1B
inet addr:192.168.1.5 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:1821 dropped:0 overruns:0 frame:0
TX packets:0 errors:187 dropped:0 overruns:0 carrier:0
collisions:0 (0.0 b) txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:45 errors:0 dropped:0 overruns:0 frame:0
TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4928 (4.8 Kb) TX bytes:4928 (4.8 Kb)
 
Old 05-05-2004, 06:45 AM   #19
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Hmmm... Try a ping 192.168.1.0 and report any results. One other thing you can try is use a different port on the router. I've had the problem before of having one (some) port(s) dodgy while all others fine.

If that does nothing then I can only imagine there's something wrong with the NIC. Do you have another that you can test with?
 
Old 05-05-2004, 07:15 AM   #20
michaelk
Moderator
 
Registered: Aug 2002
Posts: 20,105

Rep: Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381Reputation: 3381
Typically for a 10/100 interface yellow means 10MB and green means 100MB. Try using a different port on the router and check its manual to verify the configuration is correct and what each lights really means. Check the configuration of the NIC using the mii-tool utility because it might not be configured correctly i.e. full vs half duplex etc.
 
Old 05-05-2004, 12:42 PM   #21
lamine
LQ Newbie
 
Registered: May 2004
Distribution: Slackware
Posts: 10

Original Poster
Rep: Reputation: 0
ping 192.168.1.0 :
Do you want to ping broadcast? Then -b
ping -b 192.168.1.0 :
Ok then I do ping it.

I think the problem is the NIC.
I used the mii-tool as suggested by Michaelk and it says
eth0: no link.
I tried the link to my laptop and I get the green light to the NIC there and the port light to the router.
My PC NIC still have that yellow light even when the cable is unpluged!
I am probably going to open it and see before I get another NIC

Thank you very much for your help and viva linux I am not turning back to windoz. nooooooo way.
 
Old 05-05-2004, 09:22 PM   #22
lamine
LQ Newbie
 
Registered: May 2004
Distribution: Slackware
Posts: 10

Original Poster
Rep: Reputation: 0
I noticed some few post about proper detection of the NIC.
I read few of them for help.
can anybody tell me how I verify whether the right module for my card.
lspci list it as
Digital Equipment Corporation DECchip 21142/43 (rev 41)

on start up it says:
Digital DS21143 Tulip rev 65 at 0x1000, 00:08:C7:8F:B3:1B, IRQ 11
 
Old 05-06-2004, 07:23 PM   #23
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Yes you have the right module. And yes I do want to broadcast but your ping must be different to mine since I don't have the "-b" option.
 
Old 05-06-2004, 07:52 PM   #24
robert_edwards
LQ Newbie
 
Registered: Apr 2004
Posts: 27

Rep: Reputation: 15
Sorry to keep putting my nose in, Id like to think im big on networking but lacking in linux. Ports on linksys routers do go bad, have you reset the router to defaults then reenter your custom settings that you may use? yes the yellow light states sync at 10mbps is the orange light where you plug you nic in on the router on? just throwing the obvious out!
maybe plug the NIC into a different pci slot? or if onboard id bet my two cents its gone bad.

Last edited by robert_edwards; 05-06-2004 at 07:54 PM.
 
Old 05-06-2004, 09:02 PM   #25
lamine
LQ Newbie
 
Registered: May 2004
Distribution: Slackware
Posts: 10

Original Poster
Rep: Reputation: 0
Well I just tried to put back Windoz as a dual boot just to see if anything wrong with my router. It detects it fine. Better yet, the NIC in my laptop works just fine and it is slackware 9.1. So I think the problem is really what driver is appropriate for that kind of NIC (Digital equipment DECchip 21143). If any help on that I will appreciate it. Meanwhile, I will search for that particular problem further.
 
Old 06-23-2004, 09:02 AM   #26
fandango
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
Hi

Hi:

Lo que tienes q hacer es olvidarse del adsl-start no les va a funcionar, porque eso solamente funciona cuando quieres conectarte directamente al modem o sea cundo tienes el modem conectado a tu placa de red.

Esto lo hice en slackware:

en una consola como root poner:

netconfig, enter

cuando pregunte por el host poner los que se le ocurra es el nombre que va a llevar la pc.

despues: domian name tan solo poner . (punto)

luego de las tres opciones elegir static ip y poner una ip asi como por ej. 10.0.0.20

en net mask 255.0.0.0, gateway 10.0.0.2 es la ip del modem, nameserver serian las dns 200.45.0.115 tan solo te deja poner una despues de esto tienes que editar el archivo resolve.conf que se encuentra en /etc y poner la segunda dns:

nameserver 200.45.0.116

salvas el archivo y pones /etc/rc.d/rc.inet1 start, y listo!!!!

para porbar que todo funcione has un ping a www.google.com.ar.

La proxima ves que inicies se conecta automaticamnete.
 
Old 06-23-2004, 09:07 AM   #27
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
The language used in these forums is English, I'm afraid.
 
Old 07-07-2004, 10:37 PM   #28
da_tibmeister
Member
 
Registered: Oct 2003
Distribution: SLES 9.3
Posts: 40

Rep: Reputation: 15
Okay, it sounds like you have the following setup:

LAN ---> Router ---> DSL

In that case, set your LAN pc's to DHCP, and tell your router to use PPPOE to authenticate against Verizon's RADIUS server. Bow, here's the key part, every Linksys, Belkin, or other router/WAP, the drfault IP is 192.168.100.1. So, set your box to this subnet (192.168.100.x) and log into your router via the webbrowser and set it all up. Also, change the subnet of the router, I like 192.168.200.x, and make sure the router's DHCP server is running. That should be all there is too it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl setup question, using rp-pppoe in Mandrake Smarvy Linux - Newbie 5 03-14-2004 12:30 AM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM
adsl-setup and rp-pppoe neonik Linux - Networking 1 10-09-2003 04:44 AM
rp-pppoe DHCP setup for USB ADSL modem Teecom Slackware 2 06-20-2003 11:09 AM
ADSL Static IP setup in Slackware Nic Slackware 1 03-10-2003 05:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration