-   Linux - Networking (
-   -   pppd & DNS(?) trouble (

Andersonian 06-14-2007 10:02 AM

pppd & DNS(?) trouble
I'm running Ubuntu Feisty, and I have a US Robotics modem. After some trouble I made it connect to the ISP.
Well, right now, I have an odd problem:
Using Kppp I connect to my ISP. Then pppd starts and authentificates through CHAP. Then the Kppp window goes into the tray (meaning connection established). At this point, I can:
* ping any website (ex: ping
* get any index page (ex: wget
* open ssh connections
* update packages through Adept (graphical package manager for ubuntu)

But(!), I can't:
* open any website through Konqueror (says it can't find host)
* connect to any IM network through Kopete

It seems like any non-graphical application run from the terminal can connect to the internet, while some graphical applications can't.
So the question is: What is the problem?

Thanks in advance.

nautilus 06-14-2007 10:47 AM


Its definitely not a DNS problem. If it was DNS you would not be able to do anything with a domain name. Pinging would not work complaining about "unknown host".

What you describe here sound more like a misconfiguration of konqueror and/or Kopete. Have you tried any other web browsers? If other browsers don't work, there might be a misconfiguration in your KDE that overrides the systems DNSs. In this case:


cat /etc/resolv.conf
In a command line. This will show you the DNS severs your system is using. Then try to find out what KDE thinks your DNS servers are (I cannot guide you here as I am big fan of Gnome) and compare the results.

I hope this helps.


Andersonian 06-14-2007 11:08 AM

I tried opening http://%google's ip% in Konqueror and it wouldn't open, which confirms your earlier afirmation that it's not a DNS issue. Aslo, /etc/resolv.conf does indeed have the ips of 2 valid nameservers.
I have noticed something else however: if I run Konqueror as root, I can open any website. Which should mean it's an issue of permissions or priveledges.
However, as I mentioned earlier, I can run wget from a terminal without root priveledges, and it works fine.
So what is the problem them?

nautilus 06-14-2007 11:43 AM


This is quite strange... But I agree with you, if it looks like sh*t and it smells like sh*t, it must be sh*t... This is a permissions issue. And most probably it has to do just with Konqueror and generally with KDE... Why don't you run Konqueror as a normal user and have a look at the logs? Surely there will be a hint in there...

By the way, what distribution is this on? Shall I assume Debian?

Andersonian 06-15-2007 04:17 PM

I can't find the place where the Konqueror logs are. Btw, there one change: Kopete now works fine i.e. it's able to connect to some IM networks.
The distro is Ubuntu Feisy.

All times are GMT -5. The time now is 06:29 AM.