LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-22-2004, 10:40 AM   #1
Kostko
Member
 
Registered: Aug 2002
Distribution: Debian
Posts: 57

Rep: Reputation: 15
port: SIOCSIFMAP: Operation not supported


When i want to set full-duplex 100mbit mode via ifconfig (ifconfig eth0 media 100baseTx) i get the following error:

port: SIOCSIFMAP: Operation not supported

NIC (RTL8139) supports 100mbit/s and full-duplex mode, so i really don't know what could be the problem ?

 
Old 04-23-2004, 09:01 PM   #2
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
Try this:

ethtool -s eth0 speed 100 duplex full
 
Old 05-13-2004, 05:09 PM   #3
disc0stu
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Rep: Reputation: 0
This didn't work for me either
Code:
$ ethtool -s eth0 speed 100 duplex full
Cannot get current device settings: Operation not supported
  not setting speed
  not setting duplex
3Com NIC, 2.6 mm-sources
 
Old 04-02-2005, 09:52 PM   #4
jimmydageek
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
You might want to force half duplex. I have seen that with two of my servers. Kind of a bandwidth bummer, but nothing compared to having a link with one card trying its hardest to do full-duplex and the other...not.

I just forced half-duplex on both sides of the link (switch port and server eth0) and stuff is moving at megabits/sec rather than 7kbps.
 
Old 04-12-2005, 01:41 AM   #5
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
$ ethtool -s eth0 speed 100 duplex full
Cannot get current device settings: Operation not supported
not setting speed
not setting duplex


You should do this as root.
 
Old 10-14-2007, 10:52 AM   #6
cemcan
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0
Keep in mind that you may get that error while using VMware or an equivalent. You should also read your messages at /var/log/messages. If you can provide that output, we may have a chance to solve that problem.

Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setfacl: test: Operation not supported raxxal Mandriva 6 10-25-2012 06:09 AM
can't do iwlist scan : operation not supported flowchartz Linux - Wireless Networking 7 02-09-2006 08:39 PM
wpasupplicant: operation not supported error Markup Linux - Wireless Networking 1 09-14-2005 10:20 AM
Set Encode - Operation not supported error notmetoo Linux - Wireless Networking 3 02-16-2005 06:50 AM
SET failed on device eth0 ; Operation not supported. rickenbacherus Linux - Wireless Networking 1 04-24-2004 04:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration