LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-09-2001, 05:56 PM   #1
zamzara
LQ Newbie
 
Registered: Jul 2001
Location: Isle of Wight, UK
Distribution: Coyote
Posts: 4

Rep: Reputation: 0
Question Port forwarding to internal machine


I'm running WinMX (similar to Napster) on my PC, which is behind a Coyote firewall.

I can connect to other people OK, but when I need to accept an incoming connection it just times out.

On the firewall I have:

ipmasqadm autofw -r tcp 6699 6699 -h 192.168.10.67
ipmasqadm autofw -r udp 6257 6257 -h 192.168.10.67

(where obviously 192.168.10.67 is the private IP address of my PC)

and in WinMX I have specified tcp and udp ports for it to listen on to match those above.

Can anyone tell me why it doesn't work?

Cheers,

Tom
 
Old 08-10-2001, 05:08 AM   #2
raz
Member
 
Registered: Apr 2001
Location: London
Posts: 408

Rep: Reputation: 31
Try a different syntax for this:

example:

ipmasqadm portfw -a -P tcp -L your_external_ip 6699 -R 192.168.10.67 6699
ipmasqadm portfw -a -P udp -L your_external_ip 6257 -R 192.168.10.67 6257

/Raz
 
Old 08-11-2001, 06:29 AM   #3
zamzara
LQ Newbie
 
Registered: Jul 2001
Location: Isle of Wight, UK
Distribution: Coyote
Posts: 4

Original Poster
Rep: Reputation: 0
I tried this but it still does the same thing.

Are my ipchains rules important for this to work?

All I have is:

-P input ACCEPT
-P output ACCEPT
-P forward DENY
-A forward -i eth1 -j MASQ

so it's not very restrictive. Then the ipmasqadm commands are executed after the ipchains.
 
Old 08-11-2001, 03:51 PM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
I am trying to do this also and I have installed ipmasqadm

This is what I get


ipmasqadm portfw -a -P udp -L external_ip 32766 -R 10.0.0.2 32766

portfw: setsockopt failed: Invalid argument

I have also tried this

# ipmasqadm autofw -A -r udp 32766 32809 -h 10.0.0.2 -v -
u
Adding autofwd udp ports 32766 - 32809 to fixed host 10.0.0.2
autofw: setsockopt failed: Invalid argument


Last edited by DavidPhillips; 08-11-2001 at 03:56 PM.
 
Old 08-12-2001, 09:41 AM   #5
Infra-R3d
LQ Newbie
 
Registered: Aug 2001
Posts: 10

Rep: Reputation: 0
If I remember correctly, there is a setting in WinMX that says you are behind a firewall and if you use that, people download the files from your box slightly differently (connection extablished throu ack packets with server rather than syn packets directly from the client), using this setting, you shouldnt need to touch your firewall settings.
 
Old 08-12-2001, 07:15 PM   #6
zamzara
LQ Newbie
 
Registered: Jul 2001
Location: Isle of Wight, UK
Distribution: Coyote
Posts: 4

Original Poster
Rep: Reputation: 0
I think I've worked it out now, it's because ipchains was denying the packets before they got a chance to be forwarded by ipmasqadm.

You need to set the destination for the forward-packets to ACCEPT rather than MASQ or DENY.
 
Old 11-30-2002, 04:15 AM   #7
jaco
LQ Newbie
 
Registered: Nov 2002
Posts: 1

Rep: Reputation: 0
Question winmx setup

Can someone please help me with setting up Winmx on my client pc and firewall? We use to have a dial-up connection, but now we are connecting thru a Linux Firewall. I`m not sure how to setup the firewall for this function. What is this port forwarding to client pc`s I read about?
 
Old 11-30-2002, 12:11 PM   #8
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
This is a very old thread, and it's out dated. iptables is being used by most of the newer distros.


You should probably start a new thread for setting up winmx
 
Old 12-01-2002, 12:21 AM   #9
RKris
Member
 
Registered: May 2002
Location: UK
Distribution: Mandriva linux
Posts: 152

Rep: Reputation: 15
Hi,
Switch to iptables!! Its simple

regards
krishna
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
External port forwarding to an internal host antken Linux - Networking 3 12-17-2006 09:43 AM
Smoothwall selective forwarding from the same port to different internal computers jimdaworm Linux - Networking 4 03-16-2005 01:44 PM
Port forwarding to RH 9.0 machine not working Jeeves79 Linux - Networking 3 05-29-2004 03:11 PM
Port Forwarding not working for Internal requests angelgw Linux - Networking 2 06-29-2003 12:42 AM
IPTABLES port forwarding to internal network ivanros Linux - Networking 2 12-28-2002 10:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration