Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 08-25-2003, 01:43 AM   #1
LQ Newbie
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
Port forwarding just isnt working... Apache / xinetd Please help!


Heres my dillema. I got my Apache going, but my Isp blocks port 80. I edited the httpd.conf and made it from 80 to 8080.

Now, I have a router, but the router doesnt have any port forwarding options. Ifconfig tellls me that my ip is 192.168.254 (internal). When I access , that tells me

Since the router doesnt have any port forwarding, I had to take things into my own hands and use xinetd. I found someone that had a situation very similar to mine and they had sucess with the following...

service 8080
disable = no
socket_type = stream
protocol = tcp
user = nobody
wait = no
port = 8080
redirect = 8080

So I added that as a file, then restarted xinetd. Now I should be able to get access at (h)ttp:// right? Well I cant. Ive spent alot of time lookin and askin around, nobodys been able to help me on this one. If you can provide some assistance, please do so, its much apprecaited! Thank you!
Old 08-25-2003, 08:15 AM   #2
Registered: Mar 2003
Distribution: Slackware
Posts: 234

Rep: Reputation: 30
Now I should be able to get access at (h)ttp:// right?
wrong. Configuring your xinetd to redirect is only if requests get to your linux machine on port 8080 in the first place. They are not. They're hitting your router and your router's saying "Port 8080 isn't open, reject!"

Your router most likely does have port forwarding options. Post the model number and brand of your router, and I (or someone) will help you forward the ports or find out exactly if it can or not. Most routers can though, they're just shady about the shiz.
Old 08-25-2003, 01:05 PM   #3
LQ Newbie
Registered: Aug 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for your reply Blindsight

Ok, well I have a Speedstream 2623. I got these instructions from speedstream when I asked about the port forwarding. I am including screenshots of the Router Control Panel in hopes that someone can understand this.

"Go to advanced setup / special applications. You will need to select an application off of the list, or fill in the information (which is obtained from the program vendor) manually.

If this does not work, there is another option for opening ports. These routers have a DMZ mode, which opens all the ports for one computer. To do this you obtain the IP address of the computer you want to open the ports for, then go to Advanced Setup / Misc. You put in the last digits of the IP address where it says: IP Address of Virtual DMZ host. Then you put a check in the "Enabled" box"

Heres a screenshot of the special applications section : (h)ttp://

And heres the one of the DMZ section: (h)ttp://

Hope someone can help me out. Thanks alot.
Old 09-09-2003, 04:12 PM   #4
LQ Newbie
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
In speedstream setup, try going to "virtual server" config page and add an entry there. Private IP is address of your server, private port is 8080, Type TCP, Public Port 8080.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
port forwarding? not working?... snip128 Linux - Networking 1 10-07-2005 09:49 AM
port forwarding apache from 80 to 8080 chess Linux - General 11 09-27-2005 02:21 PM
Port Forwarding for Apache IlyaZ Linux - Networking 14 05-15-2005 04:41 AM
xinetd launched ssh port forwarding tommyr1216 Linux - Software 0 01-20-2005 07:53 PM
port forwarding NOT working :( Avatar Linux - Networking 19 04-23-2004 01:53 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:53 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration