-   Linux - Networking (
-   -   Port forwarding issue FC5 Westell327W IRLP program (

travis5344 10-03-2006 09:17 PM

Port forwarding issue FC5 Westell327W IRLP program
I am trying to forward ports 2074-2093, and 15425 should be simple right?

Here's the set up some genius will know how to solve.

I have Bellsouth as an ISP, a new C model rev. B Westell327W modem, and a Compaq deskpro en running FC5 with a Pentium 3 and 512 meg of ram. The program is IRLP, Internet Radio Linking Project.
The Compaq has a integrated sound and ethernet connector which seem to be working ok. The net is connected and operating. The sound send audio out of the pc speaker or radio when it is connected.
The PC to radio interface is done by a proprietary card sold through irlp.
I have been through many pages of help files and haven't found anything to address this specific issue.

I spent almost 3 hours on the phone with Bellsouth and had to redo some of his mess. I called Westell directly and because of their contract with Bellsouth, cannot provide any assistance. So far I probably have over a hundred hours on this project and all I had to do was finish it up. This should not have taken more than a few minutes or an hour at best.

In order for the program to work correctly, port forwarding needs to be fixed. I cannot get the ports to forward. HELP ME PLEASE!!!

1) The IRLP program has a troubleshoot-irlp script that tests multiple areas of the program and it tells me, as does the inaction of the program, that the ports are not forwarded correctly.

2) The modem has a basic port forwarding set up as outlined here step by step at portforward dot com that specifically is set up for an IRLP example.
Done it multiple ways, splitting up the port group, leaving it whole, doing parts at a time, nothing.

3) The computer has the firewall turned off. What I don't understand it that when I run netstat, none of the ports show up that the program is supposed to use? Only one that has IRLP and some *.* in the port column.

4) The program seems to be set up correctly. The IP information is correct to the point it will take updates, connect to other nodes, disconnect, etc. Many of the basics of what it is supposed to do.
One thing it does not do is let my audio out to the other nodes. Other node audio comes in but mine does not go out, another indication according to operators that the port forwarding isn't working.
One side note about the port forwarding and audio, when I connect to a reflector without the ports forwarded, the reflector will not send back anything when I key the system but with the ports forwarded, it will send back an empty carrier for a few seconds.

5) On the system is another Windows machine that is running Echolink which operates similarly. It uses port forwarding in a simple manner and works great. It uses ports 5198-5200, 2 on UDP and one TCP.

6) I ran and it shows that the ports are not open to the Linux/IRLP or Windows/Echolink machine but the Echolink machine works great and is doing everything it should including showing up on Google Earth, which it didn't do when the ports were not forwarded correctly. The IRLP does not show up on Google Earth, another indicator it is not forwarding.

Yes, I shut off the Echolink port forwarding and tried to just forward the IRLP ports, didn't work. The modem has been rebooted and reset according to Bellsouth, nothing.

I have looked through many parts of the Fedora program and from what I can tell as a rookie and reading, is correct.
The IRLP machine accesses the web in quick order and operates quite well near as I can tell.
The latest IRLP and system updates have been downloaded.

The GUI is neat and when used with the combination of the terminal and alt F2 make it quicker to move around in the system.

The primary and secondary DNS have been set and are working correctly, used by the program. The machine IP is good, the router IP is good. The subnet mask is good. Near as I can tell.

Is there any other method of port forwarding?
Would a different modem be better?
I have read about bridging and using another router!
Maybe a better alternative to this one, especially when support is basically non-existent.

How do I check, verify and set the specific ports for the IRLP program itself?
Is there a way to find exactly where the port forwarding is failing? Eg. is it out of the modem or into the computer or into the program...or out.

Posts suggest that some modem/routers will not forward to two different machines on the same IP. For sure they won't forward the same ports but these two programs don't use any ports that are even close. How do I know if this one will or won't?

Any help from anyone would be greatly appreciated.
Learning FC5 is a new experience and this has not helped.
I would love to fix this if possible.

Extra Class operator that feels like no class when this happens.

chapman 05-18-2007 07:12 PM

IRLP vs. Port Forwarding
Hello Travis,
Sorry I am not contacting you with the answer to your problem, but I am here to support your effort and I have a very similar problem and have been on it for over 2 weeks. I have a Ham coming in from vacation this weekend who claims to have the answer,hopefully to yours too. I will continue to monitor your situation but will not tie up the forum with communication, unless I get the answer. I located your email on QRZ and you can find mine there also, W7WAC.
Here is some of my problem, prior MSG.

> I have been on this for days and have had no luck,I
> have contacted my
> ISP server and Linksys tech support and no one has
> been able to help,
> so I turn to you folks. I recently upgraded the old
> linksys router to
> Linksys wireless WRT 54GS ver 6.After many trial and
> error attempts I
> have elliminated all errors but one. When I run the
> diagnostic test
> on IRLP test #2 States:Ports incorrectly routed,
> this is referring to
> ports 2074-2093 UDP (incoming) outgoing ports all
> OK. all else is by
> the book. I can connect to a Node and watch the
> Hughes modem send and
> receive data but no audio other than the Node ID I
> am trying to
> contact, after that nothing. I have gotten to the
> point I am going to
> pack up this stuff and put it away for another life
> time. Day after
> day I get so close and then no improvement, nothing
> I have done
> helps, all I get from the server and Linksys is
> exactly what the
> diagnostic program tells me but no one can tell me
> what to do to
> eliminate the problem. I don't think I have ever
> been so frustrated
> in my life!
> I have gone to and that was no
> help at all.
> It appears the incoming ports are being blocked and
> no one knows why.
> I would sincerely appreciate any help or suggestions
> from someone who
> has been through this or knows what I am doing
> wrong.
> Thank YOU,
> Wayne

PS, I am on 3 different forums now, and so far no luck!

travis5344 10-02-2007 10:03 AM

Wow, found this post again while looking for something else.
1) I am amazed that others haven't responded because port forwarding seems to be a common problem.
2) The Westell does not have the capability to port forward to more than one machine.
3) If anyone runs into a problem with IRLP, port forwarding, Echolink, Westell router or the like, PLEASE email so we can try to work through the problem. No worries as I will respond and I will help you as much as I can.
4) My remedy was to use a Linksys WRT54G broadband router.
a) The router is not used to assign IP's so assignment is done at each machine.
b) If desired, the router assigns a port or ports to each unit that is connected.

I will try to post more info on one of my web sites time permitting but again, please email or send your number or I can send you mine, and we will start processing through your IP nightmare...if we can. :)

73's for now,
AA9NV without the www

All times are GMT -5. The time now is 11:40 AM.