LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-28-2004, 08:51 PM   #1
ruwach
Member
 
Registered: Feb 2003
Location: sc
Distribution: mandrake 9
Posts: 73

Rep: Reputation: 15
please help - using linux box as server for win2k


hey there,

i am using a linux box as a router for a laptop with win2k.

i have two ethernet cards, eth0 - connected to the internet via cablemodem, and eth1 - connected to laptop via crossover cable.

here is my ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:BF:930:81
inet addr:69.92.12.105 Bcast:255.255.255.255 Mask:255.255.255.0
inet6 addr: fe80::250:bfff:fe93:d081/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:25526 errors:0 dropped:0 overruns:0 frame:0
TX packets:3732 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4785395 (4.5 Mb) TX bytes:609630 (595.3 Kb)
Interrupt:10 Base address:0xa800

eth1 Link encap:Ethernet HWaddr 00:09:5B:E1:7E:BA
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::209:5bff:fee1:7eba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:851 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:91708 (89.5 Kb) TX bytes:378 (378.0 b)
Interrupt:11 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:450 errors:0 dropped:0 overruns:0 frame:0
TX packets:450 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1138792 (1.0 Mb) TX bytes:1138792 (1.0 Mb)


i tried using firestarter wizard but it didnt work. the lights on all of the nic cards and the pcmcia network card are blinking occationally. i just cant seem to set up the windows computer to talk thru the linux computer.
i am a serious newbie, and have some questions.

is there a way with firestarter , or another software for linux that i can set up my internal network to be dhcp instead of static? i think that would make it a whole lot easier on the stupid windows side.

what is the broadcast ip mean?

is the eth1 ip the same ip i enter in win2k to be its ip address?

do i enable the gateway?

do i have to have a host name for the win2k machine and how do i know what it is? do i need it to have a user name and password to connect to the linux box?

network restart from rc.d tells me the network is unreachable.

Gee whiz, anyone out there can help me?

what services should i select in firestarter, i know http and stuff, but what about dchcp?

is there a newbie friendly gui type of program that can automate this for me? thanks
 
Old 08-29-2004, 12:29 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
Quote:
is there a way with firestarter , or another software for linux that i can set up my internal network to be dhcp instead of static? i think that would make it a whole lot easier on the stupid windows side.
I am not familiar with firestarter so can't help you much with that... otherwise here is the general stuff.

To start with, you can just assign an ip in the 192.168.1.0 subnet .. say 192.168.1.21 to the Win PC

Quote:
what is the broadcast ip mean?
Generally the last IP of a subnet range is used as a broadcast address. In your case, 192.168.1.255 wil be the broadcast IP. This will be used by arp to discover other PC's MAC addresses and very liberally by M$ protocols.

Quote:
is the eth1 ip the same ip i enter in win2k to be its ip address?
Yes, the IP of eth1 will be the gateway for your WinPC.

Quote:
do i enable the gateway?
On your linux box, you enable the gateway only for your external NIC, your eth0. This Gateway addresses will be your ISP's rouyter address.

Quote:
do i have to have a host name for the win2k machine and how do i know what it is? do i need it to have a user name and password to connect to the linux box?
You would have a host name for your win2k machine. If you rightclick on mycomputer, properties, network identification.
To work on your linux box, obviously tou will need a login id and a password. To change system parameters like ip, default gateway, you will requre root access. login id root and its password.
 
Old 08-29-2004, 12:45 AM   #3
ilde
LQ Newbie
 
Registered: Aug 2004
Location: Mexico
Distribution: Debian
Posts: 16

Rep: Reputation: 0
more info req'd

Hi.

Not much info, but make sure your win2k notebook has next "Internet Protocol Settings" (open control panel, network settings. You should see a local area network icon. Click twice on it and then click properties. Click twice over Internet Protocol tcp/ip):

Use next IP: 192.168.1.2
Subnet mask: 255.255.0.0
Default gateway: 192.168.1.1 <-- this is your Linux box IP address on eth1

If your ISP has provided you a pair of DNS addresses, you may put them in the preferred and alternative DNS boxes. Save settings and close everything.

To check you laptop IP open a DOS prompt and type:
c:\>ipconfig

You should see the settings you entered in the dialog box. If not, you have to check your connections, network cards, etc.

Now, in a terminal session from your server type (you have to be root):
# ping -c4 192.168.1.2
You should see something like this:

PING 192.168.1.2 (192.168.1.2): 56 data bytes
64 bytes from 192.168.1.2: icmp_seq=0 ttl=128 time=0.7 ms
64 bytes from 192.168.1.2: icmp_seq=1 ttl=128 time=0.3 ms

--- 192.168.1.2 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0.3/0.5/0.7 ms

If your systems "hangs" for a while and you see something like:
PING 192.168.1.2 (192.168.1.2): 56 data bytes

--- 192.168.1.2 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss

then there's a problem with your cabling or hub (are you using a hub?)

Please also note when you double click on your "local area network", there should be a button labeled "disable" next to the "properties" button. If it reads "enable" click on it. Otherwise leave it alone.
 
Old 08-29-2004, 01:30 AM   #4
ruwach
Member
 
Registered: Feb 2003
Location: sc
Distribution: mandrake 9
Posts: 73

Original Poster
Rep: Reputation: 15
Man, this is great gents, i am going to hit this tomorrow afternoon. ( my next oportunity) so please check back with this thread, this is the best help i have had on four fourums !

ok, before i start ... i had a couple of questions about your posts.

quote:
_________________________________________________________
To start with, you can just assign an ip in the 192.168.1.0 subnet .. say 192.168.1.21 to the Win PC
__________________________________________________________

how do i do this? Firestarter didn't cover this part. the subnet is an address i would assign to the computer i want to talk to, right, not the same as the netmask? i get those two confused a bit. except that netmask is always wanting to be 255.255.255.0.

i am not using a hub. i only have one computer i want to connect to.

quote
________________________________________________________________
You would have a host name for your win2k machine. If you rightclick on mycomputer, properties, network identification.
To work on your linux box, obviously tou will need a login id and a password. To change system parameters like ip, default gateway, you will requre root access. login id root and its password.
________________________________________________________________

where do i set up in Linux the user name and password for the win2k computer? i got this computer from my employer, i dont know his password, can i supply my own somewhere ?

quote
___________________________________________________________
Use next IP: 192.168.1.2
Subnet mask: 255.255.0.0
Default gateway: 192.168.1.1 <-- this is your Linux box IP address on eth1
___________________________________________________________

Best hint yet, so most of what i need to know to set up on the windows side can be found in the output of ifconfig?

i do have tcp/ip settings in the control panel under control panel - network and dial up connections - then there is a list of these dial ins and networks this computer used to be on. there is the one i added when i put a network card in it. All the lights came on - both in the laptop (win2k) and the eth1 in my computer. it would send, but never recieve. but the settings for tcp/ip are there (whew)

the dns servers are what i found in /etc/resolve.conf right ? namely
nameserver 24.116.0.157
nameserver 24.116.0.202

Again, thank you a whole bunch, look forward to hearing from you again.

-cheers
 
Old 08-29-2004, 01:45 AM   #5
ruwach
Member
 
Registered: Feb 2003
Location: sc
Distribution: mandrake 9
Posts: 73

Original Poster
Rep: Reputation: 15
one more thing....
this is exactly what win2k is looking for if i dont check "get ip address automatically"

ip address -------------
subnet mask ----------
default gateway------


prefered dns server====
alternate dns server====

hope this helps too.
 
Old 08-29-2004, 02:16 AM   #6
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
Oh ruwach, If you are connecting the linux box and yout WinPC directly, without a hub/switch , I hope you are uising a crossovercable.

The subnet mask for 192.168.1.21 should be 255.255.255.0 instead of 255.255.0.0.

To set the ip address n your winPC, rightclick networkplaces (or network neighborhood), properties, tcpip properties.

Quote:
ip address ------------- 192.168.1.21 (OR 192.168.1.2 if you so prefer)
subnet mask ---------- 255.255.255.0
default gateway------ 192.168.1.1


prefered dns server==== 24.116. (the ones on your resolv.conf)
alternate dns server====

Last edited by ppuru; 08-29-2004 at 02:18 AM.
 
Old 08-29-2004, 02:21 AM   #7
ilde
LQ Newbie
 
Registered: Aug 2004
Location: Mexico
Distribution: Debian
Posts: 16

Rep: Reputation: 0
micro networking-concepts

Netmask: a range of addresses PCs use to talk.

examples:
netmask 192.168.0.0
means all pcs in the network must have an address in the range 192.168.0.1 to 192.168.0.254 (some addresses ar forbidden) in order to communicate.

netmask 10.0.0.0
means they are allowed to have addresses between 10.0.0.1 and 10.255.255.255

Subnet mask: a way to state the addresses you really intend to use. It depends on selected Netmask:

if netmask = 192.168.0.0 => subnetmask = 255.255.255.0
if netmask = 192.168.1.0 => subnetmask = 255.255.0.0
if netmask = 10.0.0.0 => subnetmask = 255.0.0.0
btw, you should never use other netmasks other than these (192.168.0.0, 10.0.0.0, 172.16.0.0)

Dns: a set of addresses your ISP employs to translate your requested internet addresses (i.e. www.google.com ) into something the servers understand (216.239.36.10). You must use the ones provided by YOUR ISP or leave them blank otherwise. You may also want to put these numbers in resolv.conf on your Linux box.

When you set a firewall up you may ping from the server to any other machines connected, but not from the machines to the server. This a security measure.

You need to be sure your Linux box can browse the internet. If you didn't install a gui desktop, you can install lynx or links (some distros install them by default) to find out. They are text mode browsers.

If you don't have a hub, both machines must be tied by a crosslink cable.

To add a group to your Linux box you just type:
groupadd "mygroup"

To add a new user:
adduser "newuser"

to add a user to an existing group:
adduser "newuser" "mygroup"

to remove a user:
userdel "user"

to remove a group:
groupdel "group"

To do all of the above you need to be logged in as root. Logging as root all of the time is as bad an idea as installing m$winxx

A better approach is to log in as a regular user and then type:
$ su
Password: (enter root password)
press ctrl-d when you are done, and become a regular user again.

Regards.
 
Old 08-29-2004, 08:13 AM   #8
ruwach
Member
 
Registered: Feb 2003
Location: sc
Distribution: mandrake 9
Posts: 73

Original Poster
Rep: Reputation: 15
yep, got a crossover cable, the little lights on the net cards do not light up when i tried a regualr cable. thanks for all of your help. i will giver another go this afternoon.
 
Old 08-29-2004, 02:32 PM   #9
ruwach
Member
 
Registered: Feb 2003
Location: sc
Distribution: mandrake 9
Posts: 73

Original Poster
Rep: Reputation: 15
ok, another question, in the network properties in win2k it asks me if i am connecting
to a computer with a domain? am i? how do i know? how do i know what it is?
ok, about adding a workgroup. the win2k machine is in a workgroup called "workgroup" so
this is what i add with the groupadd command, right?

ok, thats it for now.

thanks
 
Old 08-29-2004, 04:59 PM   #10
ruwach
Member
 
Registered: Feb 2003
Location: sc
Distribution: mandrake 9
Posts: 73

Original Poster
Rep: Reputation: 15
HOLD EVERYTHING ! its done, i am all set up here. thanks for everything guys. i am all hooked up now.

again, thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Win2K doesn't find apache server on linux box IndiaStarker Linux - Networking 7 10-11-2005 07:03 PM
Win2k AD server because of very tight secuirty i can't make my linux box join domain keshif Linux - Networking 7 02-05-2004 03:04 AM
Installing Win98, Win2K and Linux in 1 BOX ako Linux - Newbie 1 01-16-2004 10:06 PM
How to Q: Win2k box to see Linux Box NPSHr Linux - Networking 3 09-17-2003 11:53 PM
connecting a linux box to a win2k network theabyyss Linux - Networking 3 05-03-2002 07:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration