LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-21-2005, 04:25 AM   #1
muru
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
passing parameters to network modules


Hi guys out there, please help me with this,

My network card is connected to the LAN switch using an old 10 Mbps cable ( Don't ask me why ! it's a long story... )
The driver module loaded for the network card is e100.o and by default it is set to 100 Mbps Full duplex. Therefore it does not work.
So, I have to stop the network service; remove the module; reload the module with the correct parameters [ e100_speed_duplex=2 for 10MBps full duplex ]; and finally restart the network service. It's working fine.

Now, how can I do that do work automatically everytime I boot the machine?

Thanx in advance...
 
Old 10-21-2005, 05:26 AM   #2
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
Most distributions will have a file /etc/modules.conf or /etc/modprobe.conf which is where you put any parameters you want loaded.

man modules.conf or modprobe.conf
 
Old 10-21-2005, 06:07 AM   #3
muru
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Original Poster
Rep: Reputation: 0
thanx for replying

Yes, there is /etc/modules.conf and the following entry:

alias eth0 e100

Now how do I specify the parameter, I just tried the following but it didn't work...

alias eth0 e100 e100_speed_duplex=2

Please help!
 
Old 10-21-2005, 06:44 AM   #4
muru
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Original Poster
Rep: Reputation: 0
I tried the following and it worked!

alias eth0 e100
options e100 e100_speed_duplex=2
 
Old 10-21-2005, 11:44 AM   #5
ringding
LQ Newbie
 
Registered: Feb 2005
Distribution: RH9, RHEnt.
Posts: 23

Rep: Reputation: 0
I am having the opposite issue.....

I am trying to get my e100 to default to 100 Full Duplex!

I am running Redhat EL4 so I do not have a "modules.conf" file only a "modprobe.conf" which I edited to read:
alias eth0 e100
options e100 e100_speed_duplex=4

and it did not work!

Every time I need to reboot the server I need to do a "# mii-tool -F 100baseTx-FD" to set it to Full Duplex.

Is there another way or parameter I can use at boot time?

Thanks!!!

Last edited by ringding; 10-21-2005 at 11:46 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Passing parameters to a shell script neocookie Linux - General 5 10-20-2005 12:44 PM
Passing parameters to bash script Kamikazee Programming 4 10-01-2005 07:41 AM
Passing Parameters to Bash Script mooreted Linux - Software 3 04-05-2004 10:08 PM
Passing kernel parameters at boot with LILO Crashedfiesta Linux - Laptop and Netbook 2 12-16-2003 09:51 AM
PHP - passing multiple parameters jacksmash Programming 1 11-25-2003 11:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration