-   Linux - Networking (
-   -   openSUSE VM networking problems (

vachon 10-22-2011 12:19 PM

openSUSE VM networking problems
I'm virtualizing openSUSE 11 for class and the only interface up at startup is lo. I have to enter /sbin/ifconfig eth1 up (from root of course) and then use dhclient -4 eth1 to get it an IP address from my host adapter. At that point I can ping my virtual gateway address and host OS from linux as well as SSH into the machine and ping it from the host. However, I still have no internet access. I configured the host adapter to have DNS entries hoping the VM would take them. How do I display the DNS servers that my interface is using, if any? How can I configure my system such that I don't have to manually go through these steps every login? Thanks in advance for any advice the community can provide.

kbp 10-23-2011 11:38 PM

Have you tried configuring networking via yast2 ? .. it should do pretty much everything for you

vachon 10-24-2011 12:39 PM

The problem was my VM not using proper DNS settings. I changed my /etc/resolve.conf and viola, solved.

All times are GMT -5. The time now is 04:07 PM.