LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   only amule works in my connection, weird! (https://www.linuxquestions.org/questions/linux-networking-3/only-amule-works-in-my-connection-weird-593258/)

stabu 10-20-2007 10:10 AM

only amule works in my connection, weird!
 
Hi,

I have a dual boot Windows/Slackware machine. I have a wireless rt61 interface hooked up to ADSL, which works in Windows no problem, and USED TO work in my Linux setup.

OK, so one day I was fiddling in Linux as root (pls forgive), and now what happens is that I get port inaccessible except for the amule port which is 4545 or something like that http/80 doesn't work. Pinging www.yahoo.com does nothing. Pinging other machines on my network DOES work. Hard to believe that I run amule but not browse the web.

I don't seem to have any process blocking ports, nor is my ADSL router blocking me (or else my Windows wouldn't work either). So I'm stumped.

I'm reading the networking HOWTO, especially the "route add gw" but that might be barking up the wrong tree.

I'd appreciate suggestions from anybody who's managed to read this far.

I'm certainly confused. Cheers.

chil326 10-21-2007 09:37 AM

Quote:

Originally Posted by stabu (Post 2930722)
Hi,

I have a dual boot Windows/Slackware machine. I have a wireless rt61 interface hooked up to ADSL, which works in Windows no problem, and USED TO work in my Linux setup.

OK, so one day I was fiddling in Linux as root (pls forgive), and now what happens is that I get port inaccessible except for the amule port which is 4545 or something like that http/80 doesn't work. Pinging www.yahoo.com does nothing. Pinging other machines on my network DOES work. Hard to believe that I run amule but not browse the web.

I don't seem to have any process blocking ports, nor is my ADSL router blocking me (or else my Windows wouldn't work either). So I'm stumped.

I'm reading the networking HOWTO, especially the "route add gw" but that might be barking up the wrong tree.

I'd appreciate suggestions from anybody who's managed to read this far.

I'm certainly confused. Cheers.

It could be a firewall problem maybe.
You could try to install firestarter and configure your firewall to open some ports like 80.
Or it might be your dns also.

stabu 01-01-2008 07:16 PM

I'm still having this problem. What tool could I use to why the amule port works and the othter don't?

chil326, belated thank you for your suggestions, but I' don't have a firewall running.

chil326 01-01-2008 08:05 PM

Quote:

Originally Posted by stabu (Post 3008044)
I'm still having this problem. What tool could I use to why the amule port works and the othter don't?

chil326, belated thank you for your suggestions, but I' don't have a firewall running.

You should check your firewall.
On debian and ubuntu, by default the firewall is installed and i had to start it with firestarter to access internet...
Just try to start the firewall.

chil326 01-01-2008 08:06 PM

Quote:

Originally Posted by chil326 (Post 3008070)
You should check your firewall.
On debian and ubuntu, by default the firewall is installed and i had to start it with firestarter to access internet...
Just try to start the firewall.

you could also check your dsl box...if you have the same problem with another os

Acron_0248 01-01-2008 08:23 PM

Hi,


I think that the answers to the following questions will be usefull for troubleshooting your problem:

1) Does the access to web work if you have amule closed?

2) Did you remember what did you change as root before the problem start?

3) Did you check the configuration of:

3-a) /etc/rc.d/rc.inet1.conf
3-b) /etc/resolv.conf

The last question is the most important because what could be happening is that you've a misconfiguration in your currents DNS address. This address are the ones that made possible the resolution of a name address (www.yahoo.com) to an IP address (69.147.114.210), if you use DHCP, the domain name servers are added to /etc/resolv.conf, but you can configure rc.inet1.conf to don't change those DNS in resolv.conf and add your owns.

Also, If you use DHCP, you change something regarding to the configuration, erase the .info and .old files that might be present in /etc/dhcpc because this files could be loading old configurations that shouldn't be loading. If you do this, restart inet1 so new configurations take place

Ports inaccesible could refer to firewall settings, but you haven't said if you actually have one installed and configured in your slackware. If so, and you think that is firewall problem, you could test that by disabling the firewall.



Regards


All times are GMT -5. The time now is 07:12 AM.