-   Linux - Networking (
-   -   Onboard ethernet card in SiS630E chipset (

tobythelard 02-22-2002 03:52 AM

Onboard ethernet card in SiS630E chipset
After struggling with this for a little while I'm giving in. This post is similar to many others, but the so-far suggested remedies don't work. I tried them.....

It seems that something is a bit weird with this motherboard, the ASUS TUSI-M and SuSE Linux 7.3. The installation went like a dream, all devices recognised and correctly identified during the installation (CDR, DVD, onboard VGA, onboard sound, onboard LAN) but eth0 will not work.

The fix 'alias eth0 sis900' is already applied in SuSE7.3, so this isn't the problem. The hardware monitor shows the device using irq 10 (shared with another device), io memory at d400 which all sounds reasonable enough.

An extract from boot.msg:

insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: invalid parameter parm_io
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: insmod eth0 failed
Setting up network device eth0
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: invalid parameter parm_io
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: insmod eth0 failed
SIOCSIFADDR: No such device
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: invalid parameter parm_io
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: insmod eth0 failed
eth0: unknown interface: No such device
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: invalid parameter parm_io
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: insmod eth0 failed
SIOCSIFBRDADDR: No such device
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: invalid parameter parm_io
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: insmod eth0 failed
eth0: unknown interface: No such device
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: invalid parameter parm_io
insmod: /lib/modules/2.4.10-4GB/kernel/drivers/net/sis900.o: insmod eth0 failed
SIOCSIFNETMASK: No such device

As far as I can remember the only change I made to the standard installation is to add 'ether=d400,10,eth0' to the append line of the kernel command line:
<4>Kernel command line: auto BOOT_IMAGE=linux ro root=307 BOOT_FILE=/boot/vmlinuz enableapic vga=0x0317 hdd=ide-scsi ether=d400,10,eth0

So far, very familiar problems, but additionally I sometimes see a message like
eth0: No MII transceivers found
in the system log. I have no idea what this means.

Curiously the setup tool YaST1 shows eth0 as active, while YaST2 always shows it as inactive.

Now I don't know where insmod is getting parm_io from, if it is my ether= line going wrong, but to me this sounds like Linux knows what the hardware is, but doesn't know what to do with it. Could be me that upset something too....

That's enough complaining from me, can someone please help? Got to be worth a Mass of beer if you are ever in Munich.

Bolanle 04-14-2002 12:56 PM

Hello Toby,

I quite identify with your angry feelings. I'm experienceing the same deadlock installing teh onboard sis630e NIC on am ASUS TUSI-M motherboard.
My linux kernel version is 2.4.5. I have upgraded the sis900 module to the most current version, all to no avail.

Were you able to solve the problem, if yes, pls how?

Thanks in advance.

crashmeister 04-14-2002 01:39 PM

For whatever it's worth: I got the same stuff in my box and the eth worked after the installation without any trouble at all. It's a different mobo but it has everything onboard from SIS and a SIS900 eth - never had a problem with it - so there got to be a way

tobythelard 04-15-2002 01:14 AM

The solution was a bit subtle, but the usual cause.

The sis900 driver (sis900.c) supplied with SuSE 7.3 (ver 1.08.00 if my memory is still good) is too old for the SIS900ET chipset, you need to find a driver 1.08.02 or above, although the ES chipsets are supported by the older drivers.

To avoid updating the whole kernel I just swapped the C file and after a tiny bit of hacking it compiled, worked first time, and has been flawless since.

Hope this helps....

tobythelard 04-15-2002 01:43 AM


I should also add that the only way I could find this driver was to download the whole of the latest kernel (>18Mb, thank the heavens for DSL) and extract the 30K of the single C file I needed. If you discover this is indeed the cause of your problems then I can mail you the file.

Good luck...

sprewell 04-19-2002 08:21 PM

Just want to add my 2 cents... I installed a TUSI-M with the 630ET chipset and RedHat Linux 7.2 (kernel out of the box). I couldn't get the network card working till I got the sis900.c file that was up to Rev. 1.08.01 and inserted the module. I did get an unresolved symbol error when I inserted the module but the card seems to be working nevertheless. Anyone know if this might present a problem, i.e. do I need to recompile? It's not a problem right now, but I hope it doesn't develop into one.


crashmeister 04-19-2002 08:57 PM

Guys - I don't get it!!!
My setup shows me as ethernetcard a SIS900. I installed so far Suse 7.3,RH7.1,Mandrake8.0,Connectiva7.0 and some shorttrials on that box and the internetconnection was the thing that was always working.

tobythelard 04-20-2002 06:49 AM

What SIS900 chipset do you have? There are many different versions, the SIS900ES and SIS900ET being the most recent, I believe.

The TUSI-M with SIS900ET now works wonderfully for me but ONLY with the updated sis900.c

I'm a bit of a Linux novice, although I work as an embedded C programmer so I know the ins and outs of computers well enough. With Linux I am more or less dependant on the setup tools, I dont like hacking the config files directly, so the thing that fooled me for a while was SuSE YaST1 insisting the driver based on sis900.c ver 1.08.00 was loaded and working. SuSE YaST2 on the other hand insisted something was wrong.

Sprewell, your unresolved symbol is caused by what seems to be an interface change. Some function at the end of the file to do with unloading the driver (which you will probably never want to do) has changed.

The correction:
1) Recompile sis900.c , make a note of the error message, this will tell you the name of the function that is wrong.
2) Go to the original sis900.c file (you did save this didnt you?). Locate the function with the same name and copy it.
3) Go to the sis900.c version > 1.08.00 (1.08.02 is the latest I found) and comment out the definition of this function.
4) Paste in the old definition. You might need to change the prototype as well.

I can't remember the precise steps as it is such a nasty hack I never expected it to work. The quality option is to upgrade the whole kernel. The linux kernel works around a nice table of function pointers to make sure the correct driver is called. It was a while since I did this, and I can't remember how they implemented this, but I expect the machine to hang horribly if this hacked function is ever called.

Have fun....

xeno999 05-09-2002 10:58 PM

Im afraid Im having the same problems with the Asus TUSI-M board.

No MII Transceivers Found! error

Downloaded kernel 2.4.18 which has sis900.c ver 1.08.02 but no such luck so far.

Setting up with support compiled directly into kernel, not as a module.

Anyone have any recommendations or pointers to help me out?


crashmeister 05-10-2002 06:15 AM

Try the command lspci -v and look what it shows for your card.

xeno999 05-10-2002 11:49 AM

Sigh, I found my problem....and its a stupid one :)

I had been rebuilding kernel with make install, which symlinks vmlinuz to vmlinuz-2.4.18 and updates lilo.conf. Only problem is, default Red Hat installation was asking for vmlinuz-2.4.7-10 or whatever it was, not vmlinuz. So all this time I had been booting my old kernel and wondering why it didnt work. I added a new entry in lilo.conf to actually use my kernel and no problems.

Sorry for the inconveince.....

linuxlastslonge 06-20-2002 02:07 PM

linux is crashing on me and wiped my hdd... is it the TUSI motherboard or because i'm using the Promise FastTrack TX2?:Pengy:

linuxlastslonge 06-20-2002 02:10 PM

btw, my login name is supposed to be "linuxlastslonger".

maxima 06-21-2002 02:56 AM

Oh! People! Please help me too! TUSI-M!! No MII Transceivers Found!

I'v got data about ethernet from dos DIAG utility:

ChipID - 0900
NodeID - 00 e0 18 7a 65 c6
BusMode - PCI 32 bit
I/O base addr - d400 (it mean - d400-d4ff)
IRQ - 000a
PHY addr - 1
MII ID - 001d 8000
MasterBus - enable

This SIS900 is in lspci with right irq.
This SIS900 is in inoports with right i/o addresses.

This SIS900 in dmesg doesnt shown.
This SIS900 after insmod sis900 dmesg show:

No MII Transceivers found!

Because I see many people who need help with just TUSI-M I'll make new thread here.

Please all who know - how to install on-board ethernet on TUSI-M - please help.

P.S. I need it under RH 7.2

Thank you.


tobythelard 06-21-2002 04:16 AM


All I can say is find sis900.c in your distribution and check the version. If it isn't 1.08.02 then it certainly won't work, it was only in the 02 revision that Asus added support for this chipset in the driver. Read through the previous posts here and you will get more details. Good luck.....

All times are GMT -5. The time now is 02:05 PM.