LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-13-2002, 01:12 PM   #1
whaase
Member
 
Registered: Aug 2002
Location: Calgary, Alberta, Canada
Distribution: Ubuntu Server, Ubuntu Desktop
Posts: 128

Rep: Reputation: 15
ok, i'm lost!


I tried running the following command and this is what I got.

[root@linerver root]# modprobe iptable_nat
/lib/modules/2.4.18-3/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.18-3/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.18-3/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.18-3/kernel/net/ipv4/netfilter/ip_tables.o: insmod iptable_nat failed


What does this mean and how can I fix it. I'm running RH7.3

Walter.
 
Old 10-13-2002, 02:15 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,681

Rep: Reputation: 218Reputation: 218Reputation: 218
Maybe the module is already runing? Run
lsmod
and see. If not, please send the lsmod result here.
 
Old 10-13-2002, 05:13 PM   #3
whaase
Member
 
Registered: Aug 2002
Location: Calgary, Alberta, Canada
Distribution: Ubuntu Server, Ubuntu Desktop
Posts: 128

Original Poster
Rep: Reputation: 15
[root@linerver root]# lsmod
Module Size Used by Not tainted
smbfs 37504 1 (autoclean)
autofs 11940 0 (autoclean) (unused)
tulip 41568 1
ne2k-pci 6592 1
8390 7636 0 [ne2k-pci]
ipchains 40456 2
ide-cd 29856 0 (autoclean)
cdrom 33184 0 (autoclean) [ide-cd]
usb-ohci 20160 0 (unused)
usbcore 71168 1 [usb-ohci]
ext3 64448 2
jbd 47608 2 [ext3]


I find it weird that ipchains is running seeing that it would not work yesterday and iptables would..... guess i'll use ipchains instead!?

Walter
 
Old 10-14-2002, 04:41 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,681

Rep: Reputation: 218Reputation: 218Reputation: 218
You can use only one of them. Before you start using iptables, make sure ipchains is not running (use: rmmod ipchains).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost panel in Gnome -- now I'm completely lost! webwench Linux - Newbie 3 04-30-2005 02:38 AM
Lost mouse after reboot+lost modem BACTRATE Mandriva 3 04-07-2005 07:45 AM
power lost from cable modem, interface lost a10392 Linux - Networking 4 11-16-2004 10:01 AM
Lost klfreese Linux - Newbie 13 07-02-2004 11:27 PM
C++ templates + linked lists... lost.. very lost.. exodist Programming 2 05-13-2004 12:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration