LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-27-2007, 02:32 AM   #1
makkays
Member
 
Registered: Oct 2006
Posts: 36

Rep: Reputation: 15
NTP sync problem.


Hi,

I have windows based network in which there are two RedHat AS 3.0 machines, also. There is one atomic clock running on win machine and all the other server machines including RedHat ones keep their time synched with this machine.The windows machine remain sync but the RedHat machines are showing time drifting from 1 sec to 1 min 20 sec, which is very much unaccepatble.

I have ntp-4.1.2-4 installed and run a cron job to forcefully run the ntpdate command every 1 hour to keep it sync.

Still i find time drifting.

If i try to sync RedHat machines with Internet Time Servers still the RedHat machines show same drifting pattern.

can someone help me out of this thing.

Thanks in advance.

makkays
 
Old 04-27-2007, 02:57 AM   #2
yongitz
Member
 
Registered: Nov 2005
Location: Davao City, Philippines
Distribution: RHEL, CentOS, Ubuntu, Mint
Posts: 139

Rep: Reputation: 20
Hi! Have you tried different ntp servers? Have you tried servers nearest to your location? What is your output when you run ntpq -p ? Can you post your ntp.conf here?

Last edited by yongitz; 04-27-2007 at 05:23 AM.
 
Old 04-27-2007, 06:44 AM   #3
makkays
Member
 
Registered: Oct 2006
Posts: 36

Original Poster
Rep: Reputation: 15
hi,
Thanks for reply.

ntpq -p gives following output
@STAS1 root]# ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
ncl-dnsctxmf1.n .LOCL. 1 u 61 64 377 0.455 -236.45 5.786


Yes i have also tried other Internet Time Servers near to my location.But all give same response.same amount of drift was noted.

My ntp.conf is:

restrict default ignore
#restrict 132.246.168.164 mask 255.255.255.255 nomodify notrap noquery
#restrict time.nrc.ca
restrict 10.1.3.31 mask 255.255.255.255 nomodify notrap noquery
restrict ncl-dnsctxmf1.ncel.com.pk

# Permit all access over the loopback interface. This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict 127.0.0.1


# -- CLIENT NETWORK -------
# Permit systems on this network to synchronize with this
# time service. Do not permit those systems to modify the
# configuration of this service. Also, do not use those
# systems as peers for synchronization.
# restrict 192.168.1.0 mask 255.255.255.0 notrust nomodify notrap


# --- OUR TIMESERVERS -----
# or remove the default restrict line
# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.

# restrict mytrustedtimeserverip mask 255.255.255.255 nomodify notrap noquery
# server mytrustedtimeserverip



# --- NTP MULTICASTCLIENT ---
#multicastclient # listen on default 224.0.1.1
# restrict 224.0.1.1 mask 255.255.255.255 notrust nomodify notrap
# restrict 192.168.1.0 mask 255.255.255.0 notrust nomodify notrap



# --- GENERAL CONFIGURATION ---
#
# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available. The
# default stratum is usually 3, but in this case we elect to use stratum
# 0. Since the server line does not have the prefer keyword, this driver
# is never used for synchronization, unless no other other
# synchronization source is available. In case the local host is
# controlled by some external source, such as an external oscillator or
# another protocol, the prefer keyword would cause the local host to
# disregard all other synchronization sources, unless the kernel
# modifications are in use and declare an unsynchronized condition.
#
#server 132.246.168.164
server 10.1.3.31
fudge 127.127.1.0 stratum 10

#
# Drift file. Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
#
driftfile /var/lib/ntp/drift
broadcastdelay 0.008

#
# Authentication delay. If you use, or plan to use someday, the
# authentication facility you should make the programs in the auth_stuff
# directory and figure out what this number should be on your machine.
#
authenticate yes

#
# Keys file. If you want to diddle your server at run time, make a
# keys file (mode 600 for sure) and define the key number to be
# used for making requests.
#
# PLEASE DO NOT USE THE DEFAULT VALUES HERE. Pick your own, or remote
# systems might be able to reset your clock at will. Note also that
# ntpd is started with a -A flag, disabling authentication, that
# will have to be removed as well.
#
keys /etc/ntp/keys


Regards

makkays
 
Old 05-02-2007, 09:53 AM   #4
makkays
Member
 
Registered: Oct 2006
Posts: 36

Original Poster
Rep: Reputation: 15
Please dont leave me in dark.....it will be good enough for me if someone can tell some other ntp service software which i can install and get rid off this default.service.

waiting for some help.
makkays
 
Old 05-02-2007, 05:20 PM   #5
okonzy
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Rep: Reputation: 0
Post Ntp

Hi,
Please check this note which I use for setting up all my NTP, it may help to make sure that your sticky is good. if it help you then let me know so we can update others.

#####################

NTP Configuration

The file that starts the NTPD is in
/etc/init.d

this can be either:

ntpd # mainly 2.4.21-4.ELsmp (redhat-release-3ES-1)
service ntpd restart

xinetd # May be for 2.4.2-2smp (redhat-release-7.1-1)

[root@MATOS init.d]# ./xntpd restart
Shutting down xntpd: [ OK ]
Syncing time for xntpd. Starting xntpd: [ OK ]


Two important files are: # Found in two seperate locations.

ntpconf=/etc/ntp.conf
ntpstep=/etc/ntp/step-tickers

the "ntp.conf" is where you put the IP address of the time server
the "step-tickers" is where to put also the IP address of the time
server, but this file may not exist by default, so use
vi to create it.

then at Gospeldetectives.org you have two Time servers:
1. DMZ 192.168.101.53/54
2. MAN 192.168.202.53/54

once the above files are in place, use the following command to start the service.

# service ntpd restart

or

#/etc/init.d/xntpd restart

#####


POST:


chkconfig --list |grep ntp # this is to check at what level on boot.

########################## End ###################
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP Sync? carlosinfl Linux - Networking 12 04-13-2006 11:33 AM
NTP Client How to Sync automatically minil Programming 3 03-03-2005 03:52 AM
tuning/securing and ntp sync' in stuart39 Slackware 3 02-16-2005 12:03 PM
ntp time sync eyewittness Linux - Networking 2 08-11-2004 10:18 AM
NTP sync problems rbutler Linux - Newbie 0 01-17-2003 02:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration