-   Linux - Networking (
-   -   nss_ldap attempts to bind to ldap before rcnetwork starts? (

slugman 04-15-2012 12:39 AM

nss_ldap attempts to bind to ldap before rcnetwork starts?
Hey guys, I'm having abit of an issue getting my server to succesfully bind to ldap.

Looking at my dmesg logs, I can see nss_ldap is attempting to contact my ldap server before ifup/ rcnetwork has even started:

[ 34.292746] systemd[1]: nss_ldap: failed to bind to LDAP server ldap:// Can't contact LDAP server
[ 34.292755] systemd[1]: nss_ldap: reconnecting to LDAP server (sleeping 4 seconds)...
[ 34.305190] ifup[1272]: Service network not started and mode 'auto' -> skipping

[EDIT]I am sure my ldap configuration is okay, I simpy copied it from a working configuration in our OpenSUSE 11.4 server to our new OpenSUSE 12.1.

I'm sure I can fix this with chkconfig.. Problem is, I'm not sure which service in suse corresponds to nss_ldap, so I don't know which one to chkconfig. (I know in rhel its slapd.)

I've configured this successfully on rhel6 without any problems. I am a bit new to SUSE, any help in this issue is greatly appreciated.



slugman 04-16-2012 07:19 AM

Greg from the Suse forums, and a couple dudes from the freenode #suse channel recommended removing systemd in place of sysvinit. I was given the following link:
openSUSE:Managing Systemd - openSUSE

Unfortnately, removing systemd did not seem like a sound option.. zypper prompted me to remove 386MB worth of dependencies.. They were mostly install patterns, one of which I already had to remove. However, there were a couple packages I did not want to get rid of, i.e. acpid, samba, a couple more I can't think of off the top of my head.

So, I just settled with adding 'init=/sbin/sysvinit' to my grub kernel cmd-line parameter.

nss_ldap is now able to bind to my ldap server without issues :) Now, if I can only get getent passwd to work... (another matter for another forum).

All times are GMT -5. The time now is 06:22 PM.