LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-14-2005, 10:43 AM   #1
HellSpawn
Member
 
Registered: Jan 2005
Location: Venezuela
Distribution: Ubuntu 5.10 64bits
Posts: 81

Rep: Reputation: 15
Lightbulb SOLVED! NSlookup fails, DDNS & DHCP


I have a Fedora Core 3 DDNS DHCP Server, it seems to be working fine, because every body can go around the network useing the dns names, but when I try to do a nslookup from any Windows or Mac OS X machine I get:

c:\> $ nslookup linux
*** Can't find server name for address 192.168.0.1: Server failed
*** Can't find server name for address 192.168.0.2: Non-existent domain
*** rs26s16.datacenter.cha.cantv.net can't find linux: Non-existent domain
Server: rs26s16.datacenter.cha.cantv.net
Address: 200.44.32.12


192.168.0.1 is my DNS server.
The last DNS server is the one from my ISP.

But if a try nslookup from a Linux machine I get the proper answer I'm looking for.

I also get messages like these ones:
Quote:
unable to add reverse map from 184.0.168.192.in-addr.arpa. to WORKSTATION2.key2server.local: timed out: 1 Time(s)
Quote:
can't remove reverse map on 226.0.168.192.in-addr.arpa.: timed out: 1 Time(s)
Quote:
Zone update refused:
192.168.0.2 (key2server.local/IN): 162 Time(s)
named.conf:
Quote:
//
// named.conf for Red Hat caching-nameserver
//

options {
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
//query-source address * port 53;
forward only;
forwarders {
200.44.32.12;
200.44.32.13;
};

};

//
// a caching only nameserver config
//
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; };
inet 192.168.0.1 allow { localhost; } keys { rndckey; };
};



key ddns-key {
algorithm hmac-md5;
secret "somerandomstring";
};

include "/etc/rndc.key";

view "internal" {
zone "." IN {
type hint;
file "named.ca";
};

zone "serveftp.net" {
type master;
file "/var/named/serveftp.net.hosts";
};
zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
type master;
file "named.ip6.local";
allow-update {
none;
};
};
zone "0.in-addr.arpa" IN {
type master;
file "named.zero";
allow-update {
none;
};
};
zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update {
none;
};
};
zone "0.168.192.in-addr.arpa" {
type master;
file "key2server.rev";
allow-update {
key ddns-key;
};
};
zone "255.in-addr.arpa" IN {
type master;
file "named.broadcast";
allow-update {
none;
};
};
zone "key2server.local" {
type master;
file "key2server.zone";
allow-update {
key ddns-key;
};
};
zone "localdomain" IN {
type master;
file "localdomain.zone";
allow-update {
none;
};
};
zone "localhost" IN {
type master;
file "localhost.zone";
allow-update {
none;
};
};
zone "edunet.local" {
type master;
file "/var/named/edunet.local.hosts";
allow-update {
key ddns-key;
};

};
};
-----------------------------------
dhcpd.conf
Quote:
authoritative;
allow unknown-clients;
ddns-update-style interim;
ddns-updates on;
update-static-leases on;
ignore client-updates;

# Don't allow clients to update DNS, make the server do it
# based on the hostname passed by the DHCP client:
deny client-updates;
key ddns-key {
algorithm hmac-md5;
secret "somerandomstring";
}

zone key2server.local. {
primary 127.0.0.1;
key ddns-key;
}
zone edunet.local. {
primary 127.0.0.1;
key ddns-key;
}


zone 0.168.192.in-addr.arpa. {
primary 127.0.0.1;
key ddns-key;
}



# Laplana Network
shared-network LAPLANA {
allow unknown-clients;
# Edunet
subnet 192.168.0.0 netmask 255.255.255.0 {
allow unknown-clients;
ddns-updates on;
option domain-name "key2server.local";
option routers 192.168.0.1;
option subnet-mask 255.255.255.0;
option domain-name-servers 192.168.0.1, 192.168.0.2, 200.44.32.12, 200.44.32.13;
option ip-forwarding off;
default-lease-time 21600;
max-lease-time 43200;
range 192.168.0.25 192.168.0.254;
}
}
What may I be doing wrong??

Last edited by HellSpawn; 04-25-2005 at 12:55 PM.
 
Old 04-15-2005, 08:32 AM   #2
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
*** Can't find server name for address 192.168.0.1:

It tried to do a query of a reverse DNS lookup of 192.168.0.1 and failed. Look into setting up reverse DNS for BIND. I'm sure a google search will get you started on how to set that up.
 
Old 04-25-2005, 12:54 PM   #3
HellSpawn
Member
 
Registered: Jan 2005
Location: Venezuela
Distribution: Ubuntu 5.10 64bits
Posts: 81

Original Poster
Rep: Reputation: 15
Thumbs up Solved!!

Yeap.. that was right benjithegreat98, I solved it stoping BIND, deleting the journal files and restartint BIND (named)...

Thanks!!
 
Old 03-22-2007, 03:04 AM   #4
chockalingam
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Rep: Reputation: 0
guide me

Quote:
Originally Posted by HellSpawn
Yeap.. that was right benjithegreat98, I solved it stoping BIND, deleting the journal files and restartint BIND (named)...

Thanks!!

Hey, can you help me, how did you do that? please..............
 
Old 03-30-2007, 10:59 AM   #5
HellSpawn
Member
 
Registered: Jan 2005
Location: Venezuela
Distribution: Ubuntu 5.10 64bits
Posts: 81

Original Poster
Rep: Reputation: 15
Cool

Quote:
Originally Posted by chockalingam
Hey, can you help me, how did you do that? please..............

Look for those files on your /etc/named or /var/lib/named .... stop BIND, delete the files and restart BIND.
 
Old 04-05-2007, 10:02 PM   #6
chockalingam
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by HellSpawn
Look for those files on your /etc/named or /var/lib/named .... stop BIND, delete the files and restart BIND.

I do not see any journal files for named in the path above.
Can you please get me the name of the file, it would be, for me to check the whole system.
 
Old 04-06-2007, 08:45 AM   #7
HellSpawn
Member
 
Registered: Jan 2005
Location: Venezuela
Distribution: Ubuntu 5.10 64bits
Posts: 81

Original Poster
Rep: Reputation: 15
Exclamation

Quote:
Originally Posted by chockalingam
I do not see any journal files for named in the path above.
Can you please get me the name of the file, it would be, for me to check the whole system.

So you want me to go there and do the job for you too?? You can Google it....


Look for files with .jnl extensions, you can RTFM
 
Old 04-06-2007, 08:50 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985Reputation: 1985
chockalingam, please don't drag up old threads. this hadn't been touched for nearly 2 years! If you have a problem you then you should start a thread for yourself. try that next time... (not this time...)


HellSpawn, please play a little nicer next time, ehh?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DDNS Bind 9.0 / DHCP - mule Linux - Networking 2 01-06-2006 11:55 PM
DHCP and DDNS - not working ccigmaian Linux - Networking 3 12-05-2005 11:19 PM
nslookup fails from client dnsmasq fipeso Linux - Networking 0 10-02-2005 08:04 AM
DHCP and DDNS garullon245136 Linux - Networking 1 06-20-2005 08:29 PM
DHCP/DDNS Troubleshooting dguy Linux - Networking 5 06-09-2002 03:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration