LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Not much luck (https://www.linuxquestions.org/questions/linux-networking-3/not-much-luck-483188/)

kurcz 09-13-2006 03:13 PM

Not much luck
 
Hey guys.
Ok So, I just recently installed gentoo, but, now I seem to be having no luck getting my wireless networking to work. I normally never had any problems with getting my wireless cards to work on any other distros. I have a ipw2200bg internel card, and a dwl-ag660 external pcmcia card with madwifi-ng drivers.
First off, I can get internet on my ipw2200 card, ONLY if there is no encryption. If i type: iwconfig eth1 essid mynetwork key 0123456789 I get the following error:
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Operation not supported.

Secondly, I can't seem to get my ath0 card to work at all. It is detected when i put it in, and it is reconized and i can put it up with ifconfig ath0 up, but i can't seem to get it to associate it self with any AP's even if i put in ap any, or essid the name or the MAC address for it. when i do iwconfig ath0 it shows this:
ath0 IEEE 802.11b ESSID:"default"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:1606 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I notice that it says for Access Point Not-Associated, and for Link Quality it says 0/94, so im wondering if that helps at all.

I really appreciate any help that I get, and if you need more info, please let me know. I have been working on this for days and no one seems to know the answer.
Thanks in Advance.
Kurcz

Penguin of Wonder 09-13-2006 03:25 PM

Have you checked out these sites:

http://gentoo-wiki.com/HOWTO_Atheros...adWifi_Install
http://gentoo-wiki.com/HOWTO_Wireles...on_and_Startup

Do you want the wireless cards to connect at startup? Or do you just want to them to connect when you tell them too?

kurcz 09-13-2006 05:39 PM

yes I have followed the first one to get it set up but tis still not working and I have looked at the other one before, but still no luck. I want my ipw2200 to connect at startup but that already does that I just cant get it to allow me to connect to WEP networks. Also I want m dwl-660 to connect when I start it.


All times are GMT -5. The time now is 07:59 PM.