LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-09-2018, 11:53 AM   #1
nicedreams
Member
 
Registered: Jun 2003
Location: Phoenix, AZ
Posts: 80

Rep: Reputation: 15
Not getting mbox mail after hostname change.


I have a local home server that runs Debian Stretch stable and some containers like Plex and snapraid for files. I used to get my snapraid logs in mbox mail using Mutt under my user, but not I'm not getting mail at all.

I recently changed my hostname to be more FQDN style for more organization at home. So I changed this server from 'kenserver' to 'kenserver.home.local' and make my containers like 'plex.kenserver.home.local'. But after these changes using 'hostnamectl set-hostname kenserver.home.local' no more mail. I'm not the best with email on Debian and don't have /etc/postfix directory since looking online points to change an alias in there. It's just mbox email not working I guess which I don't know too much about. Seems you can run way too many MTA's MDA and such which is confusing.
 
Old 06-10-2018, 09:56 PM   #2
nicedreams
Member
 
Registered: Jun 2003
Location: Phoenix, AZ
Posts: 80

Original Poster
Rep: Reputation: 15
Doing more research and found out mbox is a general mail storage format. I'm just using the default built in Debian local mail system for getting snapraid log files and since changing hostname doesn't work.
 
Old 06-11-2018, 11:01 AM   #3
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.5
Posts: 1,640

Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
From where is that mail coming? The localhost? Some other server on the network?
If the former, did you change the To: email address in the utilities that are sending the email?
If the latter, did you make the change in the other server's /etc/hosts?

Just guesses, tho. You say mutt is your Mail User Agent (MUA or client). What Mail Transport Agent (MTA) are you using?
 
Old 06-11-2018, 10:28 PM   #4
nicedreams
Member
 
Registered: Jun 2003
Location: Phoenix, AZ
Posts: 80

Original Poster
Rep: Reputation: 15
I'm using what ever is built into Debian Stretch. The mail command I have in snapraid config is just my username for the debian box. Then I use mutt to read the snapraid config that was mailed to the local user. None of it is outside mail, all local on the same box not networked with any other PCs.
 
Old 06-12-2018, 02:11 PM   #5
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.5
Posts: 1,640

Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
When it was working, what was the From: address of the mail?
Look in that user's mailbox (root maybe?) to see if there are any bounce messages.

What does the maillog or messages log say?
 
Old 07-22-2018, 01:23 PM   #6
nicedreams
Member
 
Registered: Jun 2003
Location: Phoenix, AZ
Posts: 80

Original Poster
Rep: Reputation: 15
CLOSE PLEASE

Have a better understanding and reposted another question that makes more sense to answer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
getting errors related to hostname -- security problem? ok to change hostname? sneakyimp Linux - Server 2 11-18-2012 05:25 PM
after hostname change, syslogd still output previous hostname to messages file tiger2000 Linux - General 3 07-22-2009 09:36 PM
i have recieved my mail by mbox but i dont get my mail by Squirrelmail client prajapati1760 Linux - Server 1 01-07-2008 09:02 AM
Mail going to user's mbox not /var/spool/mail mazzo Linux - Networking 3 11-29-2006 08:19 PM
Script to Delete Old Mbox Mail granatica Linux - Software 2 10-06-2003 10:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration