LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-04-2015, 01:16 PM   #1
bignickel
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Rep: Reputation: Disabled
Not autoconnecting to AT&T Uverse router


I was using a wireless netgear router in my house with my previous ISP. I would login as root, and run wpa_supplicant:
wpa_supplicant -Dwext -iwland0 -c /etc/wpa_supplicant.conf -B

I would then log into my regular user account, run xwindowx, and check WPA_GUI: it had already found my wireless network and connected. I then went back to root, and ran dhclient to get an IP address:
dhclient wlan0

This would get me an IP address and I would be good to go.

Last week, AT&T came out and put me on their considerably faster (from what I was used to) network. I've had no problem connecting anything to the wireless network.

However: my Linux laptop refuses to autoconnect as before. I run wpa_supplicant from root, but when I log into my regular account, start xwindows and run WPA_GUI, it's not listing my connection to my home network; instead it says:
Status: Scanning
Last message: WPS-AP-AVAILABLE

When I check WPA_GUI event log, I see a bunch of this:
WPS-AP-AVAILABLE
WPS-AP-AVAILABLE
CTRL-EVENT-BSS-REMOVED (mac address listed)
WPS-AP-AVAILABLE
CTRL-EVENT-BSS-ADDED (mac address listed)

I can see my network listed under the Manage Networks tab, and the key is typed in the appropriate space still. I can't from that screen see any method of making it 'connect' to the my listed network. Instead, I'm forced to go to Current Status tab, Scan, d-click on my network, which brings up my network, without a security key, and I have to manually type in the key all over again. Then it connects.

Under Manage Networks, I now have 2 copies of my same network with the same key.

Can't figure out what the problem is.
 
Old 08-04-2015, 01:24 PM   #2
bignickel
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Oh, forgot: using Slackware Linux.
 
Old 11-18-2015, 04:53 PM   #3
bignickel
LQ Newbie
 
Registered: Jun 2015
Posts: 7

Original Poster
Rep: Reputation: Disabled
Figured it out; I had the pw for the old router in the pw file, and since it was the wrong pw, it kept asking for the new correct one.

Working fine now after putting in the new correct one in the file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network not autoconnecting on boot in Debian Lenny hyperbowlingball Linux - Newbie 7 12-23-2010 12:04 PM
[SOLVED] Debian 5 can't connect to internet with AT&T Uverse mtlhd Linux - Networking 4 09-15-2010 01:53 PM
Ubuntu & Uverse sittykitty Linux - Newbie 13 04-03-2009 01:37 AM
autoconnecting to internet when using mozilla muffamatician Linux - Newbie 1 08-05-2003 12:04 PM
autoconnecting Notfromkansas Linux - General 10 11-04-2001 05:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration