-   Linux - Networking (
-   -   No udev support for iwl3945? (

arobinson74 06-30-2008 11:24 PM

No udev support for iwl3945?
I am getting stuck trying to determine how to get my wireless card on my dell latitude D630 to be brought up when I enable the radio that controls the card and the bluetooth support.

I have tried "udevadm monitor --environment --kernel --udev" and I only see USB-bluetooth related events (though it is possible I missed something).

The lspci data on the card is:

0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
        Subsystem: Intel Corporation Unknown device 1020
        Flags: bus master, fast devsel, latency 0, IRQ 220
        Memory at fe8ff000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
        Capabilities: [e0] Express Legacy Endpoint IRQ 0

I am using the iwl3945 driver.

Here are some problems I am having:
  1. Enabling the radio does not bring the interface up
  2. Sometimes the link strength is 0
  3. When the link strength is 0, "modprobe -r iwl3945" will peg the CPU and the kernel appears to panic on reboot
  4. Ifplugd cannot bring the device up (udev related?)
  5. My wireless LED never works despite iwl3945 advertising it should

I have tried "auto wlan0" in the /etc/network/interfaces, but this seems to make it more unreliable. I have also tried hot plug settings and also using similar settings with ifplugd with no effect.

I am running Xubuntu Hardy. Kernel:
2.6.24-19-generic #1 SMP

I am running out of ways to diagnose this. Perhaps it is a problem in the iwl3945 driver in the provided ubuntu kernel?

Thanks for any help.

hattrick 07-02-2008 08:38 AM

try other drivers?
I know theres: iwl3945, ipw3945, intelwifi or something like that, etc

I KNOW it's on sourceforge somewhere.... or something.

when I was on backtrack2 as my distro, the LEDs never came on until I used the wlanassistant, then they turned on..

sorry,it's still very early here, I'm not completely "there" but as soon as I get into the office I'll post all the correct links, as I had to patch that damn wifi chipset yesterday and kept all the links..

arobinson74 07-02-2008 09:45 AM

iw3945 is deprecated and I have had issues with it to in the past (stops working after a period of time). iwl3945 is part of iwlwifi, which is the official, but seemingly no better, set of drivers.

hattrick 07-02-2008 09:47 AM


hope this helps

arobinson74 09-02-2009 12:16 AM

By the way I solved this by writing a udev script against bluetooth events. The radio switch governs bluetooth too, so it is a hack but it works.

All times are GMT -5. The time now is 08:33 AM.