LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-12-2015, 04:33 AM   #1
AchimRS
Member
 
Registered: Mar 2005
Location: Germany
Distribution: Debian Wheezy
Posts: 42

Rep: Reputation: 0
no network reconnect if offline for a long time


When I reboot my Debian machine offline (Ethernet cable unplugged) and stay offline for a night, it don't reconnect once the network is back (Ethernet cable plugged again).

But when the network comes back within some minutes, it reconnects fine.
I meanwhile accessed the machine via RS232 terminal and found the following:
  • it shows "Name or service not known" every 5s
  • "ip addr show" gives no IP-address, only lo and eth0 shows the MAC
  • "ifup eth0" gives "ifup: interface eth0 already configured"
  • "ifdown eth0 && ifup eth0" helps, the machine is reconnected and "Name or service not known" is gone (but I can't login via Terminal after each nightly power cycle)

Any suggestions?

Last edited by AchimRS; 06-12-2015 at 04:48 AM. Reason: rephrasing
 
Old 06-12-2015, 05:58 AM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Do you use a dhcp client to enable ethernet?

If so is the daemon alive?
 
Old 06-12-2015, 06:27 AM   #3
AchimRS
Member
 
Registered: Mar 2005
Location: Germany
Distribution: Debian Wheezy
Posts: 42

Original Poster
Rep: Reputation: 0
Yep, I use dhcp and the dhclient daemon is running even after a reboot without network (just tested). If reboot and stay disconnected for about 5-minutes, than plug in the network cable, a message "PHY: 0:1f - Link is Up - 100/Full" appears and everything works fine.

Now I've started a test over the next hours without network, whether the dhclient keeps alive - maybe it crashes after a while...

I will keep you informed, thanks for your help so far
 
Old 06-13-2015, 03:03 AM   #4
AchimRS
Member
 
Registered: Mar 2005
Location: Germany
Distribution: Debian Wheezy
Posts: 42

Original Poster
Rep: Reputation: 0
News from the test:
  • Even after staying 5h disconnected after reboot, it immediately reconnects when the cable is plugged in - fine!
  • But, after staying disconnected overnight after reboot, it can't reconnect when the cable is plugged in - problem is reproducible
  • In both cases, the message "PHY: 0:1f - Link is Up - 100/Full" appear when the cable is plugged
  • Overnight, the "dhclient" daemon crashed - this seems to be the reason for the trouble

So I've simply tried to start it with "dhclient eth0" interactively, which seems to help:
  • The IP-address is assigned back again
  • Everything else works
  • Even the annoying "Name or service not known" message which was shown every 5s disappeared

It seems that some configuration on my Debian Wheezy tries to start the dhclient every 5s but don't find it...
 
Old 06-19-2015, 08:39 AM   #5
AchimRS
Member
 
Registered: Mar 2005
Location: Germany
Distribution: Debian Wheezy
Posts: 42

Original Poster
Rep: Reputation: 0
Any idea why dhclient crashes on Debian Wheezy if Ethernet disconnected for some hours???
 
  


Reply

Tags
network, reboot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Reconnect to wireless network leupi Linux - Wireless Networking 13 02-16-2014 12:34 PM
Long time member, long time *nix user, about time to say hi. stuman LinuxQuestions.org Member Intro 0 10-15-2013 07:35 AM
Hello, its me. I've thought about this for a long, long time... Just David LinuxQuestions.org Member Intro 0 07-22-2012 07:23 PM
wpa_supplicant reconnect time jsteel Linux - General 0 02-02-2011 03:58 PM
Network access time is very long. Thasat Linux - Networking 8 01-29-2007 12:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration