-   Linux - Networking (
-   -   No Nameserver found - Nameserver (DNS) failure (

EPS 01-11-2012 10:25 AM

No Nameserver found - Nameserver (DNS) failure
I have confugured my usb wireless stick using modeswitch.
It appears to be working OK, but I have a problem connecting to the internet.
When I run wvdial, ( my ISP is in Austria )
The modem responds, it starts ppp and it waits for a carrier, It connects at 3600000, but then when it get to "Script /etc/ppp/ip-up run successful", then I get the Nameserver error.

I have looked at other threads on the forum, but none really answer my question. ie what do I do now ?

Any ideas, anybody ?

repo 01-11-2012 10:28 AM

try to add the DNS in


nameserver x.x.x.x
Kind regards

mmrtnt 01-11-2012 10:54 AM



Auto DNS
Try to get the Domain Nameserver (DNS) from the provider. This option is "on" by default. (Option added by SuSE.)
Hope this helps...

EPS 01-11-2012 11:21 AM

Thanks, both of you.
I should have mentioned I use Suse 11.4 and have tried unsuccessfully to use Yast to configure.
As far as I know the provider DNS is, there is also a secondary number there,.200

In wvdail I have a line saying " Auto DNS = 1 " , is this the same as "ON" ?

resolv.conf file as far as I can see is just a comment file telling me to go and screw around with /etc/sysconfig/network/config file, so I have been doing just that.

I have tried putting in the DNS No. that I have into this under NETCONGIG_DNS_STATIC_SEARCHLIST and NETCONFIG_DNS_STATIC_SERVERS and also NETCONFIG_DNS_FORWARDER.
.. again, I am not really too sure what I am doing here

mmrtnt 01-12-2012 08:02 AM


I haven't fought with wvdial in a while.

What I believe is supposed to happen is once you've made a connection (dialed, connected, authorized) then the PPP server should be giving you an IP address and the nameservers via DHCP. It sounds like something in that chain is failing. You should be using DHCP (Instead of static config) via PPP.

I wish I could be of more help, but I would Google the heck out of "wvdial", "dhcp", "ppp", "nameserver" and "dns" in various combinations.

Good luck...

salasi 01-12-2012 08:38 AM


Originally Posted by EPS (Post 4571913)
As far as I know the provider DNS is, there is also a secondary number there,.200

So you are saying that you know that the ISP has DNS servers at and

Do you get the chance to ping either of those addresses, or are saying that the connection auto-closes once the DNS error has happened?

And, while the connection is up, can you cat /etc/resolv.conf as....


Originally Posted by EPS (Post 4571913)
resolv.conf file as far as I can see is just a comment file telling me to go and screw around with /etc/sysconfig/network/config file, so I have been doing just that.

That should not be the case: in the particular case of SUSE, Yast has had a reputation of making things a little more confusing when things go wrong, by putting settings back to what it thinks they should be, if you go around changing settings behind its back.

What I think is happening here is that Yast is using the setting in /etc/sysconfig/network/config to configure networking, but (in this particular respect) resolv.conf is what really causes changes to system operation. Where this really gets important is that other things change resolv.conf, too. So you may start up with some default settings in resolv.conf, Yast (and associated scripts) may then change those settings, and then DHCP or PPP may change them again, as networking actually starts up. This can be confusing, particularly if it is not what you were expecting.

Usually, the first step, if you think that DNS is not being correctly configured correctly, is to see if you do something with the IP address directly (thereby side-stepping the issue of whether DNS works, DNS not being needed in that particular case). So, if, for example:
ping w.x.y.z works, and the associated
ping doesn't, then it is usually the case that you can be sure that there is a DNS configuration error.

A worthwhile thing to remember is that Google have public nameservers at and, at least one of those is a memorable address, and they do work (unlike some ISP nameservers, which can be, err, a bit intermittent, and not to be relied upon during debugging, because it adds an extra random factor, which can really mess you about, if they go wrong at a bad time).

EPS 01-12-2012 11:09 AM

Again, thank you for your replies.
I have not been able to "Ping" anything at all.
netstat -rn gives me:
destination ; Gateway ; Genmask
Can you tell me how to edit the resolv.conf file, as I think this may be where the conflict lies.
at present it looks like this, it's all just commentary:
### /etc/resolv.conf file autogenerated by netconfig!

# Before you change this file manually, consider to define the

# static DNS configuration using the following variables in the

# /etc/sysconfig/network/config file:




# or disable DNS configuration updates via netconfig by setting:



# See also the netconfig(8) manual page and other documentation.


# Note: Manual change of this file disables netconfig too, but

# may get lost when this file contains comments or empty lines

# only, the netconfig settings are same with settings in this

# file and in case of a "netconfig update -f" call.


### at least remove this warning if you change anything.

Here also is my wvdial dialog

Running as Root:

# wvdial bob
-->wvDial: Internet dialer version 1.60
-->Cannot get information for serial port
-->Initialising modem
-->Sending ATZ
-->Sending AT+CGDCONT=4,"IP",""
-->Modem initialised
-->Sending: ATDT *99***1#
ATDT *99***1#
CONNECT 3600000
-->Carrier detected. Starting ppp immediately.
-->Starting pppd:2933
-->Using Interface ppp0
-->local IP address
-->remote IP address
-->primary DNS address
-->secondary DNS address
-->Script /etc/ppp/ip-up run successful
-->Default route Ok
-->warning, no nameserver found '/etc/resolv.conf/'
-->Nameserver DNS failure, the connection may not work.
-->Connected ... Press Crtl-C to disconnect

I then press ctrl-C to terminate. That is where I stand at present.

repo 01-12-2012 12:47 PM

At the end of



Make the connection, and see if you can ping

If you can't ping, try

Kind regards

EPS 01-12-2012 05:31 PM

Hello Repo, Thanks for the tip.
Sorry, but no help. I added the code as you suggested, but I still cannot make a connection.
So I still cannot ping anything either.

As indicated at the top of my /etc/resolv.conf file
"#/etc/resolv.conf file is autogenerated by netconfig! ", I am sure that this needs to be part of the problem, because anything I add to resolv.conf is just being overwritten.
However, I have went over the netconfig file several times and I cannot see where to insert a nameserver DNS.

It also say that manually changing this file ( ie the resolv.conf ), will automatically disable Netconfig. But I don't know if that is so ?

My latin is at an end now, and I cannot see any way forward, so I will gladly try any other thoughts.

repo 01-13-2012 02:02 AM

First make a backup of the files
Then edit

and comment out or remove



check DNS = no
auto DNS = no

Kind regards

EPS 01-14-2012 09:11 AM

Hello All,

I just wanted to report my success.
I got a tip from Josh at

He suggested adding my DNS IP addresses and then making my /etc/reslv.conf file read only

chmod a-w /etc/resolv.conf

It worked ! So I am now replying to you all to say THANK YOU ALL ! for your efforts and also for your patience.

So I can confirm : ZTE MF180 wireless stick works on Suse 11.4 using USB-modeswitch.

All times are GMT -5. The time now is 08:32 PM.